summaryrefslogtreecommitdiff
path: root/dev-python/uncertainties
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-08 12:25:04 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-08 12:25:04 +0100
commita5442e2318cb4df55867389654e322dbac82067e (patch)
tree6ee33490658219395df804dbba0ea77f8b0d8c3b /dev-python/uncertainties
parent5d8ffbc273ca664e15618d557ced3e02de1a884b (diff)
gentoo auto-resync : 08:07:2024 - 12:25:03
Diffstat (limited to 'dev-python/uncertainties')
-rw-r--r--dev-python/uncertainties/Manifest4
-rw-r--r--dev-python/uncertainties/uncertainties-3.2.2.ebuild (renamed from dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild)13
2 files changed, 3 insertions, 14 deletions
diff --git a/dev-python/uncertainties/Manifest b/dev-python/uncertainties/Manifest
index 00dbfe0b14dc..461bad321386 100644
--- a/dev-python/uncertainties/Manifest
+++ b/dev-python/uncertainties/Manifest
@@ -1,5 +1,5 @@
-DIST uncertainties-3.1.7.tar.gz 158727 BLAKE2B d68b74d291b1f6c4505a47f6fa19653eade43dc1ccaf78e02bd320df92d8bdaeac1b0808a21dceb046a6e2acd076836728b4014d39ca8da17647582320ce50e8 SHA512 24576415265df22459d83bb28e632195e6760204a6e11523821afe25222ea3e035bf7f10c552ec456bb2cdf42a09e296865f9bf0d13ff44beb88c11ebc479ff9
DIST uncertainties-3.2.1.tar.gz 143154 BLAKE2B 68a0e840878eed602666f1b315ea575f3ab07ca12555f6153801ffbb54b9b1ae8742e4d87c7cec9ec0ace505c4dd8aeb45d3a010663691db31145a146390c932 SHA512 4b1b1738bed60dddacaa0e7f6d8672e32c8282681c4f2f5222e26798150774a24349fb1a98011ff37dc990ab2dd271a3fff2abbc7a0279d499d08585df1b814f
-EBUILD uncertainties-3.1.7-r1.ebuild 1019 BLAKE2B 8d1117d59ed46327d78010853620c8462e592f430fd9bf08e1e7e732bba82566bf56b33cabc2b40a567e5533f5dc98715dd65db9015d1c2d5a6ff3b2807dcc0c SHA512 c3e3d0c1b44106d617e5397c8acf22ef4543c35346cd313d147134673f16ff5b95abe1567027310c7f8af4359f813a8b0d33e9eeb06e858d998dbb99d49e4f04
+DIST uncertainties-3.2.2.tar.gz 143865 BLAKE2B 38f88ba147f2ef43749ddf2735fc26c1804e8acd504db2b8317abe69b37daded70b7e111edae1793dc3000d5bde207fe4156221d17c9284eb0006d3369efb367 SHA512 b78efc09cc572ecd24ead89db4136741429ab9032295c9e9050a79e14662b41c7537580f698e38d4ee1a36ae460ee22a463eeb473806a1f72246ab6868d950a3
EBUILD uncertainties-3.2.1.ebuild 648 BLAKE2B 14818a0d31c553ac3f9497d8e235265ac7f1e76ec3762c74557d7eecdbfb12534f26b0783a8962171609fb6553a5e04f5877fb4134169b441900aa20ff0f755d SHA512 6de58a1ae35b539367be95b4a1d0c97092fb7beb1b0233dc16f113336035fbf80eaea71566472c0f45d3358438858d1d3f999ab17afa33a2f57c9eed2eb10972
+EBUILD uncertainties-3.2.2.ebuild 648 BLAKE2B 14818a0d31c553ac3f9497d8e235265ac7f1e76ec3762c74557d7eecdbfb12534f26b0783a8962171609fb6553a5e04f5877fb4134169b441900aa20ff0f755d SHA512 6de58a1ae35b539367be95b4a1d0c97092fb7beb1b0233dc16f113336035fbf80eaea71566472c0f45d3358438858d1d3f999ab17afa33a2f57c9eed2eb10972
MISC metadata.xml 1028 BLAKE2B 26cc84a3791d81a939512fd405771c70fc606cddef64c1c47c5dbf8d0e0c390cd1cbda4d686903a146acd493c5b46018053eb42bff6a6c4abb29be12ff20ad9c SHA512 59d8a58dff2111ea9d58591ffbfc13fc0521e8234fc6a2478984b6e496f0b718eff5adea25202d1d4b2ac2d1bd46812fcc7fb4779e966e800a51d4824fef6d28
diff --git a/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild b/dev-python/uncertainties/uncertainties-3.2.2.ebuild
index d959694cae67..2a213488261f 100644
--- a/dev-python/uncertainties/uncertainties-3.1.7-r1.ebuild
+++ b/dev-python/uncertainties/uncertainties-3.2.2.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1 optfeature pypi
@@ -26,17 +26,6 @@ BDEPEND="
"
distutils_enable_tests pytest
-distutils_enable_sphinx doc --no-autodoc
-
-src_prepare() {
- # not used in py3, see https://github.com/lmfit/uncertainties/pull/168
- sed -i -e '/future/d' setup.py || die
- # fix tests with numpy-2
- # https://github.com/lmfit/uncertainties/pull/225
- sed -e "/assert not hasattr(numpy, 'acos')/d" \
- -i uncertainties/unumpy/test_unumpy.py || die
- distutils-r1_src_prepare
-}
pkg_postinst() {
optfeature "numpy support" dev-python/numpy