summaryrefslogtreecommitdiff
path: root/dev-python/unearth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-07-12 12:25:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-07-12 12:25:39 +0100
commit37bccfe5e76c5740c4ef5ba1179e9488d8404075 (patch)
treec0c962a2e83c1f38816a021ecd34c2e8c80db528 /dev-python/unearth
parent496ef6155c315ac3628b472dc9b4146fa2684286 (diff)
gentoo auto-resync : 12:07:2024 - 12:25:38
Diffstat (limited to 'dev-python/unearth')
-rw-r--r--dev-python/unearth/Manifest2
-rw-r--r--dev-python/unearth/unearth-0.16.1.ebuild42
2 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/unearth/Manifest b/dev-python/unearth/Manifest
index 1a6dc327f36c..883df805c045 100644
--- a/dev-python/unearth/Manifest
+++ b/dev-python/unearth/Manifest
@@ -1,5 +1,7 @@
DIST unearth-0.15.5.tar.gz 283787 BLAKE2B 2910be23141eb0a683766e83eae1cd35a074b98aaba7c25f49f06a321c261583a65bcb2cbd56c129efc1551e2f421e29dde784d3689c0dfc45d420c870a9b112 SHA512 84851788cd6bf6743307bb5a49fff1b6eeadd3f73605f4b2f7ffe1720d50713971d7cf020e17f34bbe755f523400a6149ace9add1c680bb955f6b46e8e092cba
DIST unearth-0.16.0.tar.gz 283848 BLAKE2B e94989b643450b0e1a12c4bcd65339c1e52acd04a447616779f085297fa13bc09e25527b858383ef2b8d645304ea42f43c41415c930064e0515569a5836cd1fb SHA512 b129c546bdd8b1f364404ad4db8e43d471a1f9e3a2cbc99775a6c3aa5bce99ed127d1cbd859c69f8c2bae7f7c8b907426c2597d27323c6b6f408df047de2410e
+DIST unearth-0.16.1.tar.gz 283913 BLAKE2B 91f599fd21e6100be7e3f3d422d595e4402a652057b327ec2f6baa45f30301ea7571473e17d202017d7d7a92f7b11acdc42d1c655865499b9eeb8bfb1f7c00a3 SHA512 2819c4da65d0bb9492546531012699fa4554d309930de4b9cc8a5319edc19c1863993badaa53c8f646b152abf133043b2d3d3816f2adb9827ed7f25541e5d603
EBUILD unearth-0.15.5.ebuild 973 BLAKE2B 954d1d0a965598bd6a1ea438a54575d7d902638b9da5631b5babca972885cb29ad338ee5392502730784d707bba730ea788c6df2d11072e51c635ea73a49250f SHA512 02ae8087266e8d28d9717e3e5acf3291172f4eb733547a5bad3402153aa5b53ec437c2c91b0259f5bab02b0aff38e4a19c493578cdbb5111bcc91593c64a7eac
EBUILD unearth-0.16.0.ebuild 973 BLAKE2B 954d1d0a965598bd6a1ea438a54575d7d902638b9da5631b5babca972885cb29ad338ee5392502730784d707bba730ea788c6df2d11072e51c635ea73a49250f SHA512 02ae8087266e8d28d9717e3e5acf3291172f4eb733547a5bad3402153aa5b53ec437c2c91b0259f5bab02b0aff38e4a19c493578cdbb5111bcc91593c64a7eac
+EBUILD unearth-0.16.1.ebuild 973 BLAKE2B 954d1d0a965598bd6a1ea438a54575d7d902638b9da5631b5babca972885cb29ad338ee5392502730784d707bba730ea788c6df2d11072e51c635ea73a49250f SHA512 02ae8087266e8d28d9717e3e5acf3291172f4eb733547a5bad3402153aa5b53ec437c2c91b0259f5bab02b0aff38e4a19c493578cdbb5111bcc91593c64a7eac
MISC metadata.xml 480 BLAKE2B 489aab9c338887392b943b48593bd9d752083d82fcf89a419e3677f2d24939af51cabe16641c3a16942f9658fe79f804af61cffc807cdeb909d44a6cff5ced5b SHA512 9fe2154826a2399f5570fa150445220f7490e10741275f77791b1d29522336912812e3f8905c026cb748845d2f2a005196185db6576708b47f1cdf582216182f
diff --git a/dev-python/unearth/unearth-0.16.1.ebuild b/dev-python/unearth/unearth-0.16.1.ebuild
new file mode 100644
index 000000000000..a135cb39bbf1
--- /dev/null
+++ b/dev-python/unearth/unearth-0.16.1.ebuild
@@ -0,0 +1,42 @@
+# Copyright 2023-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+ https://github.com/frostming/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ <dev-python/httpx-1[${PYTHON_USEDEP}]
+ >=dev-python/httpx-0.27.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver -p pytest_mock
+}