summaryrefslogtreecommitdiff
path: root/dev-python/unearth
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-09-21 17:14:54 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-09-21 17:14:54 +0100
commitd7c0aa05b3a48c9b2bad24e3d805820f861165c6 (patch)
treebf664ec4da7846863657a931f0abfcaa0d9dfd9b /dev-python/unearth
parent03633f33c2184a87f7a4cebae72542343cf0490c (diff)
gentoo auto-resync : 21:09:2023 - 17:14:53
Diffstat (limited to 'dev-python/unearth')
-rw-r--r--dev-python/unearth/Manifest4
-rw-r--r--dev-python/unearth/metadata.xml1
-rw-r--r--dev-python/unearth/unearth-0.11.0.ebuild39
3 files changed, 43 insertions, 1 deletions
diff --git a/dev-python/unearth/Manifest b/dev-python/unearth/Manifest
index a69d7caf2148..a4284cabcc66 100644
--- a/dev-python/unearth/Manifest
+++ b/dev-python/unearth/Manifest
@@ -1,3 +1,5 @@
DIST unearth-0.10.0.tar.gz 270997 BLAKE2B 8b18df4616fc72025492aa187101bc1f338967b1738ef9ec33d16cbd906c1cf91c1b84e391538521b4a9d6ea40301eb0b7ed0926aa4e6c4d6ffc57401f9d78d9 SHA512 98799202939e1206b6fdd46eb61947c9f9f8068a6857f76aace8dd2c67a3fad9dd3b7a5232d7812b0dcd214c39a9e2a6fafbd18cbfeb9aa4c216571b88b3f131
+DIST unearth-0.11.0.tar.gz 271154 BLAKE2B 405c97ef152afb241cb70d9b309fd1ac454be932c96f95b606bb6038ffb2369fbc55c6afabd86f6a15949182de276dcda035fdb17d4810933286a0fa0b567e42 SHA512 70a06a32f6f2ca74c16a55f9613b543d807e437bd99c0ebb02c0d721144cf45208df78940ee41911a8168c9181ec733b9aec2176038b2556d0e2ad5e8c2cc0d4
EBUILD unearth-0.10.0.ebuild 687 BLAKE2B 593b2a0c003808785c03b1a543564f7c403beb98e858f8991ee075271b4fd579c5141b9c3cfb94d8be9a6399afd177dfa23017a72bd2d70d2847cf98c590c04d SHA512 dd05341700e9788aa76664fed91afd2264f99d6bd8ce0c4b9ef21054e50dba42a642e6abb9706770207164a5eafa316abdfa6c3af8673afe655c1d3de06ceaab
-MISC metadata.xml 423 BLAKE2B 168ef799c8ac77adfe8937a5693054ab763e158e23c94e604fe0edcde350b9f8ea4020ef04289cb59f91f293f22677ecca4a993fa526af8923264ac3a48368ec SHA512 47a9e79481d2774b496f785ca62b71890d2bab7900fca9d4be32ae12d53f78240ebea0ed30b15f10525f71af6298bde1eb13b9518fde04507d0d036bfd067231
+EBUILD unearth-0.11.0.ebuild 818 BLAKE2B e2e8ce3d6e258627d32fe1e4a2f7cda8af19d2755def4d14715c61bdbd0d959f5659cb2fe9747df32268e20d5be9aa64e625aee17a02953f3ebee65667dc7b01 SHA512 7b965932ece6ab01a9d333fe33901d831336ede0cb14a4a273ff1a597d5ecf70f92d12dc92cdbcd0914b7170e60f9fbdf96c8a54cacccb43ccaa8a6087d6ea7b
+MISC metadata.xml 480 BLAKE2B 489aab9c338887392b943b48593bd9d752083d82fcf89a419e3677f2d24939af51cabe16641c3a16942f9658fe79f804af61cffc807cdeb909d44a6cff5ced5b SHA512 9fe2154826a2399f5570fa150445220f7490e10741275f77791b1d29522336912812e3f8905c026cb748845d2f2a005196185db6576708b47f1cdf582216182f
diff --git a/dev-python/unearth/metadata.xml b/dev-python/unearth/metadata.xml
index 112da0f56f24..b532fa36d3f4 100644
--- a/dev-python/unearth/metadata.xml
+++ b/dev-python/unearth/metadata.xml
@@ -10,6 +10,7 @@
</maintainer>
<stabilize-allarches/>
<upstream>
+ <remote-id type="github">frostming/unearth</remote-id>
<remote-id type="pypi">unearth</remote-id>
</upstream>
</pkgmetadata>
diff --git a/dev-python/unearth/unearth-0.11.0.ebuild b/dev-python/unearth/unearth-0.11.0.ebuild
new file mode 100644
index 000000000000..9c0635d2317b
--- /dev/null
+++ b/dev-python/unearth/unearth-0.11.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=pdm-backend
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A utility to fetch and download python packages"
+HOMEPAGE="
+ https://pypi.org/project/unearth/
+ https://github.com/frostming/unearth/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-httpserver[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/requests-wsgi-adapter[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p pytest_httpserver
+}