summaryrefslogtreecommitdiff
path: root/dev-python/unittest2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/unittest2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/unittest2')
-rw-r--r--dev-python/unittest2/Manifest5
-rw-r--r--dev-python/unittest2/files/remove-argparse-dependence.patch12
-rw-r--r--dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch28
-rw-r--r--dev-python/unittest2/metadata.xml12
-rw-r--r--dev-python/unittest2/unittest2-1.1.0.ebuild35
5 files changed, 92 insertions, 0 deletions
diff --git a/dev-python/unittest2/Manifest b/dev-python/unittest2/Manifest
new file mode 100644
index 000000000000..d9a28cd04e4c
--- /dev/null
+++ b/dev-python/unittest2/Manifest
@@ -0,0 +1,5 @@
+AUX remove-argparse-dependence.patch 424 BLAKE2B 6b59d1913f24b336f9cd8bd40a0d42f281fe452937be9b1f2b7187aaff611c07de8bfe138ce9bbd42c5c812d217400d4a49ee991e44821020b5d3a131b5dea18 SHA512 e4a7b803ba5e77484f4e800df4c78d5b4d35f2d66e5c416c256bd6e7fa3db193c32aa0a455aac66b34f27c1038accf7949f64d98bf4a31a896a43d790de810f7
+AUX unittest2-1.1.0-python3.5-test.patch 1304 BLAKE2B 390a1972a4f24ca348f6d1d35badd2fe9a88fada8961c16e759f39da6843a1c931040ea3cd236f20b9671efa505c58857a2872553029c88a98b75c8358ac7281 SHA512 502a72811581e3551ab8fdd80f0f72ee4f6be9a3b0ce01a131f240f2199babfa115ecb18c5d4efe297521e6951f9371869b9419c829396720623bff548f09398
+DIST unittest2-1.1.0.tar.gz 81432 BLAKE2B 02bf191baaa895689078e8f484bb368cd178ea2d1e275a5adcd3413eb25d18b9109c353046f60819c7ec26cd233867b7397e6e38004389aa928b4c53cfeb637c SHA512 3fba15728905f437767416ab4fd3573d3fb2319486ef84c52a9fa930ea84aa1f2ae29d6f58993e3509083625790e17b1ef8d9ac5de0e166c254897a3e7a202fa
+EBUILD unittest2-1.1.0.ebuild 1025 BLAKE2B 1d30da27322b224c4e80590b6ed048432fa31be0c861dc6aebc07931b5ae42a8570bf9bb4652fa39e7e6a9db090b135cebdc374c816f4a4fef9c9a636fe9164e SHA512 56dd1ea8f82e588f2ade43b24f68b3019a027d87194cef6e1610f4916fc97d32001ac8f340ba561e1ee39d864f438e993f1825893e0b37bdc083a38f564f02c5
+MISC metadata.xml 378 BLAKE2B e0a0ad885607d8593e090798b8facbacd746a69c3325f6d429743482a6265bff57b2d0fd6d12122e15336e063c4c1e539da10cc41ea5ab159b2c5673e8316c8e SHA512 b1db02e32f39f739de9a077d770579cd1adbca7bc7b9c1eb3e5800f5242a1706ec5a61694b98ea7e3e6f6099b128d22e731f4c49cf3c719bb38be52679845d34
diff --git a/dev-python/unittest2/files/remove-argparse-dependence.patch b/dev-python/unittest2/files/remove-argparse-dependence.patch
new file mode 100644
index 000000000000..36f89fc5f8f6
--- /dev/null
+++ b/dev-python/unittest2/files/remove-argparse-dependence.patch
@@ -0,0 +1,12 @@
+diff -r 8928fb47c3a9 setup.py
+--- a/setup.py Thu Mar 12 15:55:36 2015 +1300
++++ b/setup.py Sun Apr 05 09:06:44 2015 -0500
+@@ -57,7 +57,7 @@
+ # Both install and setup requires - because we read VERSION from within the
+ # package, and the package also exports all the APIs.
+ # six for compat helpers
+-REQUIRES = ['argparse', 'six>=1.4', 'traceback2'],
++REQUIRES = ['six>=1.4', 'traceback2'],
+
+ params = dict(
+ name=NAME,
diff --git a/dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch b/dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch
new file mode 100644
index 000000000000..4aae9d04b2f8
--- /dev/null
+++ b/dev-python/unittest2/files/unittest2-1.1.0-python3.5-test.patch
@@ -0,0 +1,28 @@
+diff --git a/unittest2/test/test_loader.py b/unittest2/test/test_loader.py
+index 683f662..347eea5 100644
+--- a/unittest2/test/test_loader.py
++++ b/unittest2/test/test_loader.py
+@@ -509,6 +509,7 @@ class Test_TestLoader(unittest2.TestCase):
+ #
+ # What happens when an impossible name is given, relative to the provided
+ # `module`?
++ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
+ def test_loadTestsFromName__relative_malformed_name(self):
+ loader = unittest.TestLoader()
+
+@@ -811,6 +812,7 @@ class Test_TestLoader(unittest2.TestCase):
+ # TestCase or TestSuite instance."
+ #
+ # What happens when presented with an impossible module name?
++ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
+ def test_loadTestsFromNames__malformed_name(self):
+ loader = unittest2.TestLoader()
+
+@@ -918,6 +920,7 @@ class Test_TestLoader(unittest2.TestCase):
+ # "The method optionally resolves name relative to the given module"
+ #
+ # What happens when presented with an impossible attribute name?
++ @unittest.skipIf(sys.version_info[:2] >= (3, 5), "python 3.5 has problems here")
+ def test_loadTestsFromNames__relative_malformed_name(self):
+ loader = unittest.TestLoader()
+
diff --git a/dev-python/unittest2/metadata.xml b/dev-python/unittest2/metadata.xml
new file mode 100644
index 000000000000..70f1765921a2
--- /dev/null
+++ b/dev-python/unittest2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">unittest2</remote-id>
+ <remote-id type="github">testing-cabal/unittest-ext</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/unittest2/unittest2-1.1.0.ebuild b/dev-python/unittest2/unittest2-1.1.0.ebuild
new file mode 100644
index 000000000000..b811a9c8cdc9
--- /dev/null
+++ b/dev-python/unittest2/unittest2-1.1.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="The new features in unittest backported to Python 2.4+"
+HOMEPAGE="https://pypi.org/project/unittest2/ https://github.com/testing-cabal/unittest-ext"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="alpha amd64 arm arm64 hppa ia64 ~m68k ~mips ppc ppc64 s390 ~sh sparc x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+IUSE=""
+
+CDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/linecache2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4[${PYTHON_USEDEP}]
+ dev-python/traceback2[${PYTHON_USEDEP}]
+"
+DEPEND="${CDEPEND}"
+RDEPEND="${CDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}"/remove-argparse-dependence.patch
+ "${FILESDIR}"/${P}-python3.5-test.patch
+)
+
+python_test() {
+ "${PYTHON}" -m unittest2 discover --verbose || die "tests failed under ${EPYTHON}"
+}