summaryrefslogtreecommitdiff
path: root/dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild')
-rw-r--r--dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild b/dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild
new file mode 100644
index 000000000000..d8e6ae6fb108
--- /dev/null
+++ b/dev-python/unpaddedbase64/unpaddedbase64-2.1.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Unpadded Base64"
+HOMEPAGE="
+ https://github.com/matrix-org/python-unpaddedbase64
+ https://pypi.python.org/pypi/unpaddedbase64
+"
+SRC_URI="https://github.com/matrix-org/python-unpaddedbase64/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+S="${WORKDIR}/python-${P}"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+distutils_enable_tests unittest