summaryrefslogtreecommitdiff
path: root/dev-python/uranium
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/uranium
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/uranium')
-rw-r--r--dev-python/uranium/Manifest4
-rw-r--r--dev-python/uranium/uranium-4.9.1.ebuild (renamed from dev-python/uranium/uranium-4.8.0-r1.ebuild)7
2 files changed, 8 insertions, 3 deletions
diff --git a/dev-python/uranium/Manifest b/dev-python/uranium/Manifest
index 90e8d4c9b4f5..f5a319cb3926 100644
--- a/dev-python/uranium/Manifest
+++ b/dev-python/uranium/Manifest
@@ -1,3 +1,3 @@
-DIST uranium-4.8.0.tar.gz 1027286 BLAKE2B 5e068255918ca3a6125c308a64d47fab30260aa475505edad2abda664d2c2db7d821d4219ff682d4de90e16de2e36d257410a44f2752c733994739ca160e55b0 SHA512 a2cb923d703e626760c885ceb657566abfa5662f63729fef0b5cdf408da2ed3c23fefcd173b8af529ee79c2384505b2558379b82ba2cfd7a2d2291fe723ddbbd
-EBUILD uranium-4.8.0-r1.ebuild 2334 BLAKE2B 7b842d31c4fda17a761bac9bbc7e5ebcefc0a6dab9e7926c87d9383954e1c04820069c988dce7d7829055f20c6e45ef47bc929950b6eb1742eab3b8fb94235fd SHA512 a70fc9d7ac263eb2f45da9148e611ab5dfa77c2c93ad56586c1d16f1384a26e2bbd3db5749427bf7e58892bded8a1321797f08279c318f98b52c91c23d6bb09f
+DIST uranium-4.9.1.tar.gz 1038046 BLAKE2B 3304e89e0a22fbda0e9e57aaf88f6f11979eb5273d6c8a69f5ec9f050741561f67667a76e2136148808862026e2330f3b5043141ed8d69d255632a8c3c869def SHA512 e665a1ff8ebfc629e4bc2253533a3332d8f8804155432af921ad2e7251d5725daf9346cc5f110595914ac6f0d194db6d7e06dfcd3795b57e35b3d5e6dae594a7
+EBUILD uranium-4.9.1.ebuild 2461 BLAKE2B 395ab5c2174d353c5947fccce37b079d42b315ae33168c84256ea4046583e552f5764f4c0d589f856327c7747d8735f06c054c206f0f714215db617d84fe9c99 SHA512 c361ca8125f0350f0c245a093d0123c80a319267e22ede7a6c9d2ca6416714610afbb28856f4b0adfbb75cef555f74f5a959bd53d2e32c2532bb994f4265f038
MISC metadata.xml 1208 BLAKE2B 4a7d789c09e42ecb831e92bd363f6fdf1b161d685c8a95d70f296e17306ffb5af19548ae845487eb366153e97264ba1007a67aabea1bfb3a241a7f98e7f63e4b SHA512 1a2f2e068fb647ded2277e7eb6530856534aed8815f82eba0ecd2c0a4f505327396a46b503ba1a486f35c1986af492234625e6f58a10dad762a833bf823405c7
diff --git a/dev-python/uranium/uranium-4.8.0-r1.ebuild b/dev-python/uranium/uranium-4.9.1.ebuild
index d2fbe4c60546..066a9e021074 100644
--- a/dev-python/uranium/uranium-4.8.0-r1.ebuild
+++ b/dev-python/uranium/uranium-4.9.1.ebuild
@@ -4,7 +4,7 @@
EAPI=7
DISTUTILS_SINGLE_IMPL=1
-PYTHON_COMPAT=(python3_{7..8})
+PYTHON_COMPAT=(python3_{7..9})
inherit cmake distutils-r1
@@ -26,6 +26,7 @@ BDEPEND="${PYTHON_DEPS}
$(python_gen_cond_dep '
dev-python/pytest[${PYTHON_USEDEP}]
dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
')
)"
@@ -52,6 +53,10 @@ distutils_enable_tests pytest
src_prepare() {
python_fix_shebang .
+ if ! use doc ; then
+ sed -i -e '/add_custom_target(doc/d' CMakeLists.txt || die
+ fi
+
cmake_src_prepare
}