summaryrefslogtreecommitdiff
path: root/dev-python/uranium
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-11-25 22:39:15 +0000
commitd934827bf44b7cfcf6711964418148fa60877668 (patch)
tree0625f358789b5e015e49db139cc1dbc9be00428f /dev-python/uranium
parent2e34d110f164bf74d55fced27fe0000201b3eec5 (diff)
gentoo resync : 25.11.2020
Diffstat (limited to 'dev-python/uranium')
-rw-r--r--dev-python/uranium/Manifest5
-rw-r--r--dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch32
-rw-r--r--dev-python/uranium/uranium-4.6.1.ebuild76
-rw-r--r--dev-python/uranium/uranium-4.7.0.ebuild2
4 files changed, 113 insertions, 2 deletions
diff --git a/dev-python/uranium/Manifest b/dev-python/uranium/Manifest
index 49e0a225f022..a787354daede 100644
--- a/dev-python/uranium/Manifest
+++ b/dev-python/uranium/Manifest
@@ -1,3 +1,6 @@
+AUX uranium-4.6.1-fix-install-paths.patch 1584 BLAKE2B 45a4461a2dddf00772098c0ab374fc511dcea1fc2eed94c563e1088be61c8ca6658fb6dbbf6bf2b628bd021d937fdef98a9b9b07bc861a9c3f84954fd38ecb5a SHA512 fba41223d1e14a25232b0efa0b83ccdae9e86bc18f49c5a495c2e3058bacc4a3647a567c346bd0184b22f25319c8e63e1f92fa13b4cf50385dea57d03013494f
+DIST uranium-4.6.1.tar.gz 1013314 BLAKE2B 2a89eb1c4ffab35879eea9a681ea20e9cc5f78736d9c8bda5bf33baf5ef6d3f6418fd1f4b779738d644afd2d553d500c4892559ae402eeab0c38a4d95b295cf5 SHA512 ba7ed12d507fb1bd08fc0e77285933802a31b63d09f2dd0c7329e5644f82e6372fa11a1bbc28f3f1928ae0acfb3cb0afdeedf8e90e619c484fd5f623f8af722a
DIST uranium-4.7.0.tar.gz 1021541 BLAKE2B 2a2e354def88764801f275751aaf7643c9f4ca6329c2c302d87b3d617d0e93921d0aef20b0c25c9b0a082a836f7d0cca962dfedaa0298fcf943b1a0b683e0e28 SHA512 e049fff57823107785b418a368d6c6c399775c35ffad90831c77643dee060be2ab13ad8871b11f8d59d2a090a1d26786f4cf39a5a731b616a1b08a8ae5dea996
-EBUILD uranium-4.7.0.ebuild 2290 BLAKE2B ff525cf9a033c705124bf30f8a6c5d8a045d94202f223c2e2d0f442f9706f944d0cf036535fbdbfee58eba57896adba1866d72bf92569b18e92e7e0779ff7f04 SHA512 36d10356e8954d69c10d8207df523d6c40bc833f77fb0ce772dedaf459cf2b8d73f04416b3a53210e7349d86f5da0d3131cf7f26d5688c7ad83de68d0356cc47
+EBUILD uranium-4.6.1.ebuild 1769 BLAKE2B 44c8e4e64e382ed1751effa24abc4c19a9fe28600217ac6f6f5306fd988622cf06efb533359d6606ce72f423981704f9d0f84d07fd28153ba7270dda751d576a SHA512 783e52f8bfc0523cac56e7c6901a655f9b253f6aa46a3ca329ed54e3d3f92cef2ffa1202b856e3399422aa6639cd54352331bf577c5f3be55fd5e4712ec761c5
+EBUILD uranium-4.7.0.ebuild 2290 BLAKE2B 974ca324a2fa95ae197feb34862e5d642032b2f8138c9108ad64ffe2e9bdaf98cb90dd410a2d832b6f085568467531a38367c48652514dcd04ae56d2c8d359dc SHA512 362f7e0d5d338395c51df831d338ef8e84035cd79e8531b1b2791ddacb92cb5a84c47a129a1c2bac190cf9dc0f107cbfe362c2b5ac8ba2993495254eaf953631
MISC metadata.xml 975 BLAKE2B 42ea7df7c2ee42408ada0328335319d95edc41c92d8ae74d77fb178629e48c7ab7886e4ea07f058b9be9b67f04d29b795eb353e47de60370b7949158cb7798ca SHA512 6074599c0b62f2f527041621550ec183bfa26400eee212c3e9cd0ab9742917ddf762ef668a6bba4628cee8063a0f40104f21d25e260de1d164b61389c9544824
diff --git a/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch b/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch
new file mode 100644
index 000000000000..5777065e9da8
--- /dev/null
+++ b/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch
@@ -0,0 +1,32 @@
+--- Uranium-4.5.0-orig/CMakeLists.txt 2020-03-01 16:26:44.736355687 +0200
++++ Uranium-4.5.0/CMakeLists.txt 2020-02-24 17:02:05.000000000 +0200
+@@ -12,6 +12,16 @@
+
+ find_package(PythonInterp 3.5.0 REQUIRED)
+
++if(NOT PYTHON_SITE_PACKAGES_DIR)
++ if(APPLE OR WIN32)
++ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++ CACHE STRING "Directory to install Python bindings to")
++ else()
++ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}/dist-packages CACHE
++ STRING "Directory to install Python bindings to")
++ endif()
++endif()
++
+ # # Checks using pylint
+ # Note that we use exit 0 here to not mark the build as a failure on check failure
+ # In addition, the specified pylint configuration uses the spellchecker plugin. This required python-enchant to be installed.
+@@ -48,10 +58,10 @@
+ if(EXISTS /etc/debian_version)
+ install(DIRECTORY UM DESTINATION lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}/dist-packages)
+ else()
+- install(DIRECTORY UM DESTINATION lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
++ install(DIRECTORY UM DESTINATION ${PYTHON_SITE_PACKAGES_DIR})
+ endif()
+ install(FILES ${CMAKE_SOURCE_DIR}/cmake/UraniumTranslationTools.cmake
+- DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake-${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}/Modules/ )
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake/Modules/ )
+ install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
+
+ # Detect plugins to install
diff --git a/dev-python/uranium/uranium-4.6.1.ebuild b/dev-python/uranium/uranium-4.6.1.ebuild
new file mode 100644
index 000000000000..b5a2f4ad5871
--- /dev/null
+++ b/dev-python/uranium/uranium-4.6.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake python-single-r1
+
+MY_PN="Uranium"
+
+DESCRIPTION="A Python framework for building 3D printing related applications"
+HOMEPAGE="https://github.com/Ultimaker/Uranium"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+ doc? ( app-doc/doxygen )
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ dev-python/mypy[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
+
+DEPEND="${PYTHON_DEPS}
+ ~dev-libs/libarcus-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},declarative,network,svg]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ >=dev-python/scipy-1.1[${PYTHON_MULTI_USEDEP}]
+ sci-libs/shapely[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+RDEPEND="${DEPEND}
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtquickcontrols2:5"
+
+DOCS=( README.md )
+
+PATCHES=( "${FILESDIR}/${PN}-4.6.1-fix-install-paths.patch" )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)"
+ )
+ cmake_src_configure
+
+ if ! use debug; then
+ sed -i 's/logging.DEBUG/logging.ERROR/' plugins/ConsoleLogger/ConsoleLogger.py || die
+ sed -i 's/logging.DEBUG/logging.ERROR/' plugins/FileLogger/FileLogger.py || die
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ cmake_src_compile doc
+ HTML_DOCS=( html )
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+ python_optimize "${D}/usr/$(get_libdir)"
+}
diff --git a/dev-python/uranium/uranium-4.7.0.ebuild b/dev-python/uranium/uranium-4.7.0.ebuild
index 32be957b1231..1f9643331be0 100644
--- a/dev-python/uranium/uranium-4.7.0.ebuild
+++ b/dev-python/uranium/uranium-4.7.0.ebuild
@@ -35,7 +35,7 @@ DEPEND="${PYTHON_DEPS}
dev-python/PyQt5[${PYTHON_USEDEP},declarative,network,svg]
dev-python/numpy[${PYTHON_USEDEP}]
>=dev-python/scipy-1.1[${PYTHON_USEDEP}]
- sci-libs/Shapely[${PYTHON_USEDEP}]
+ sci-libs/shapely[${PYTHON_USEDEP}]
')"
RDEPEND="${DEPEND}