summaryrefslogtreecommitdiff
path: root/dev-python/uranium
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-09-06 10:28:05 +0100
commitf1af93971b7490792d8541bc790e0d8c6d787059 (patch)
treea38046712bbc3a3844d77452d16c84e716caa3d4 /dev-python/uranium
parentfc637fb28da700da71ec2064d65ca5a7a31b9c6c (diff)
gentoo resync : 06.08.2019
Diffstat (limited to 'dev-python/uranium')
-rw-r--r--dev-python/uranium/Manifest2
-rw-r--r--dev-python/uranium/uranium-4.2.0.ebuild66
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/uranium/Manifest b/dev-python/uranium/Manifest
index c7c619295536..23d8303cbed4 100644
--- a/dev-python/uranium/Manifest
+++ b/dev-python/uranium/Manifest
@@ -1,4 +1,6 @@
AUX uranium-3.3.0-fix-install-paths.patch 1716 BLAKE2B 13ea6150f1cfb1a07ac1886be8281110bbca5abd39b78807fe67317052579efa0498bc8a321d09fc953c9358dfb963ed210451549d14d6f58ac4a94cc3e9a5d1 SHA512 a7007c74a2e46e281dc0db6fcc45475e36f3a261445c2162fe0a548e577cd7cc344957e3284c52fffdd21cf223e91ab5b4fc1936b6893de614c4143cd1b40419
DIST uranium-3.6.0.tar.gz 668552 BLAKE2B 84ab1eed5474bf14aec5b7782b332e9846d14f589c0dfa7366c74ad682fdc0a8e5ef94a0b9576f0e80cf792b49132d3abb3f17341a2e8570d08bf898231deca6 SHA512 41779e9cf76dff8f74252f668d1cf909c93f4f1416f75d2ed263f89fcfccfbcebce5580d8202d8d1697491139db448bbfa76e2dbc761dd24cb98030b3241e80d
+DIST uranium-4.2.0.tar.gz 711868 BLAKE2B 8098372704db0494519ab0a24046b72f2527695716286463e7ecffb776db351bfb4ffcd7b53276d59403b39e40ef605fb016e9ec57e18cd06e8f22f22d8ef732 SHA512 fab04efbb6337e366501ffc0336f208ddc0f9e568a2822363b84b6512268f2560a22bc71e745d30e66026d7a0bf9e150eda605ef8b511b59264407cab491eee1
EBUILD uranium-3.6.0-r1.ebuild 1416 BLAKE2B 3ea73653aa36adc305b81759ded97af57a2a5bd901a73815a8d0372ebc8fd5d1565626016f5b4a9d7556817e376ff696cfc84049201a570cf58b6dffe383bf6b SHA512 2716709771e66c3d2de8912c5fe4c5ad8f5bcc453575a1045c9e44225e5cb52fdb06240457ef8bf1c193f5b141f76c8ed912393e7fbfb555c5a48c64f0970979
+EBUILD uranium-4.2.0.ebuild 1599 BLAKE2B 48553f297c6c730ff39c886c6912d8bacb068965f3ee55901cb1c0599d6db90da352b5a7f1150ab4b36f5e5c8239a419d13616ee82c1d9e27f6b45e7b39724f3 SHA512 e84ede7ae2a0b11f8c97925ea73e4fce30d4d0225320054dac6bce84c6e69740957b6a1945e8f9fd113b01b55717d3e35d768b525a354bf86c96cc7ab3c5a1bf
MISC metadata.xml 975 BLAKE2B 42ea7df7c2ee42408ada0328335319d95edc41c92d8ae74d77fb178629e48c7ab7886e4ea07f058b9be9b67f04d29b795eb353e47de60370b7949158cb7798ca SHA512 6074599c0b62f2f527041621550ec183bfa26400eee212c3e9cd0ab9742917ddf762ef668a6bba4628cee8063a0f40104f21d25e260de1d164b61389c9544824
diff --git a/dev-python/uranium/uranium-4.2.0.ebuild b/dev-python/uranium/uranium-4.2.0.ebuild
new file mode 100644
index 000000000000..4818481b4a53
--- /dev/null
+++ b/dev-python/uranium/uranium-4.2.0.ebuild
@@ -0,0 +1,66 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6} )
+
+inherit cmake-utils python-single-r1
+
+MY_PN="Uranium"
+
+DESCRIPTION="A Python framework for building 3D printing related applications"
+HOMEPAGE="https://github.com/Ultimaker/Uranium"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+ doc? ( app-doc/doxygen )
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+RDEPEND="${PYTHON_DEPS}
+ ~dev-libs/libarcus-${PV}:=[python,${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP},declarative,network,svg]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=sci-libs/scipy-1.1[${PYTHON_USEDEP}]
+ sci-libs/Shapely[${PYTHON_USEDEP}]
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtquickcontrols2:5"
+
+DEPEND="${RDEPEND}"
+
+DOCS=( README.md )
+
+PATCHES=( "${FILESDIR}/${PN}-3.3.0-fix-install-paths.patch" )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)" )
+ cmake-utils_src_configure
+
+ if ! use debug; then
+ sed -i 's/logging.DEBUG/logging.ERROR/' plugins/ConsoleLogger/ConsoleLogger.py || die
+ sed -i 's/logging.DEBUG/logging.ERROR/' plugins/FileLogger/FileLogger.py || die
+ fi
+}
+
+src_compile() {
+ cmake-utils_src_compile
+ if use doc; then
+ cmake-utils_src_compile doc
+ DOCS+=( html )
+ fi
+}
+
+src_install() {
+ cmake-utils_src_install
+ python_optimize "${D}/usr/$(get_libdir)"
+}