summaryrefslogtreecommitdiff
path: root/dev-python/uranium
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-30 11:44:06 +0100
commitf516638b7fe9592837389826a6152a7e1b251c54 (patch)
tree8bfecb640b7b6403d7a3d662d923eed630033da7 /dev-python/uranium
parent1a61119f9f7b057830e2ce0563f913ec86f282ad (diff)
gentoo resync : 30.05.2020
Diffstat (limited to 'dev-python/uranium')
-rw-r--r--dev-python/uranium/Manifest3
-rw-r--r--dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch32
-rw-r--r--dev-python/uranium/uranium-4.6.1.ebuild76
3 files changed, 111 insertions, 0 deletions
diff --git a/dev-python/uranium/Manifest b/dev-python/uranium/Manifest
index 5d86df256009..0510ba7718cb 100644
--- a/dev-python/uranium/Manifest
+++ b/dev-python/uranium/Manifest
@@ -1,4 +1,7 @@
AUX uranium-3.3.0-fix-install-paths.patch 1716 BLAKE2B 13ea6150f1cfb1a07ac1886be8281110bbca5abd39b78807fe67317052579efa0498bc8a321d09fc953c9358dfb963ed210451549d14d6f58ac4a94cc3e9a5d1 SHA512 a7007c74a2e46e281dc0db6fcc45475e36f3a261445c2162fe0a548e577cd7cc344957e3284c52fffdd21cf223e91ab5b4fc1936b6893de614c4143cd1b40419
+AUX uranium-4.6.1-fix-install-paths.patch 1584 BLAKE2B 45a4461a2dddf00772098c0ab374fc511dcea1fc2eed94c563e1088be61c8ca6658fb6dbbf6bf2b628bd021d937fdef98a9b9b07bc861a9c3f84954fd38ecb5a SHA512 fba41223d1e14a25232b0efa0b83ccdae9e86bc18f49c5a495c2e3058bacc4a3647a567c346bd0184b22f25319c8e63e1f92fa13b4cf50385dea57d03013494f
DIST uranium-4.3.0.tar.gz 899153 BLAKE2B 314dbeed1cce49d33439b2fa744d37e4b360edb041964d2c3336730295b88bb2af86df8eac8382a6696fbc9c1ba07fa0774089ec3aa7fd0f8fbb92c61ce2825b SHA512 eac28907ccd66e5a43012a6f5af2a97daea21f0e2832613562e848cca967e036fea117811d8a4cc519c1417a113449e7065233fc541347202c6a8ff85a9d60b7
+DIST uranium-4.6.1.tar.gz 1013314 BLAKE2B 2a89eb1c4ffab35879eea9a681ea20e9cc5f78736d9c8bda5bf33baf5ef6d3f6418fd1f4b779738d644afd2d553d500c4892559ae402eeab0c38a4d95b295cf5 SHA512 ba7ed12d507fb1bd08fc0e77285933802a31b63d09f2dd0c7329e5644f82e6372fa11a1bbc28f3f1928ae0acfb3cb0afdeedf8e90e619c484fd5f623f8af722a
EBUILD uranium-4.3.0-r1.ebuild 1742 BLAKE2B 3165ae0a2295a570aea9bdd1985e935cf7a7dc2579e90e4ca7f9f65062949ffdefe1f15d52f3682cc76ae5087aefe0c5cfae0a41a44acb21661eade504f795a9 SHA512 fc01a7524769d5f70b21790a67e8b3beb61bbb9a34a4dc79f370c03f7d380b19ec9b23631fcddb37c5e34d8d3984aa5c2e0711b3a75612bf4ee811607c2004fe
+EBUILD uranium-4.6.1.ebuild 1767 BLAKE2B 1431554d0fc021d74e951bbac246880b3f74c5dd1c388a46481eb8a038b3342362b8cc13dddb1dfcf6fd58b8b6718a1e40775ec7f67d939fc67e32184bd045a1 SHA512 96d1d8a702c4d26b36328ee4873772f3c2ef907706e90916f1e60ffabf7cb9d08b57072e2e52c952e84184755f475cdf42bfdd2a6744aba39caf5c9e0633ec8c
MISC metadata.xml 975 BLAKE2B 42ea7df7c2ee42408ada0328335319d95edc41c92d8ae74d77fb178629e48c7ab7886e4ea07f058b9be9b67f04d29b795eb353e47de60370b7949158cb7798ca SHA512 6074599c0b62f2f527041621550ec183bfa26400eee212c3e9cd0ab9742917ddf762ef668a6bba4628cee8063a0f40104f21d25e260de1d164b61389c9544824
diff --git a/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch b/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch
new file mode 100644
index 000000000000..5777065e9da8
--- /dev/null
+++ b/dev-python/uranium/files/uranium-4.6.1-fix-install-paths.patch
@@ -0,0 +1,32 @@
+--- Uranium-4.5.0-orig/CMakeLists.txt 2020-03-01 16:26:44.736355687 +0200
++++ Uranium-4.5.0/CMakeLists.txt 2020-02-24 17:02:05.000000000 +0200
+@@ -12,6 +12,16 @@
+
+ find_package(PythonInterp 3.5.0 REQUIRED)
+
++if(NOT PYTHON_SITE_PACKAGES_DIR)
++ if(APPLE OR WIN32)
++ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages
++ CACHE STRING "Directory to install Python bindings to")
++ else()
++ set(PYTHON_SITE_PACKAGES_DIR lib/python${PYTHON_VERSION_MAJOR}/dist-packages CACHE
++ STRING "Directory to install Python bindings to")
++ endif()
++endif()
++
+ # # Checks using pylint
+ # Note that we use exit 0 here to not mark the build as a failure on check failure
+ # In addition, the specified pylint configuration uses the spellchecker plugin. This required python-enchant to be installed.
+@@ -48,10 +58,10 @@
+ if(EXISTS /etc/debian_version)
+ install(DIRECTORY UM DESTINATION lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}/dist-packages)
+ else()
+- install(DIRECTORY UM DESTINATION lib${LIB_SUFFIX}/python${PYTHON_VERSION_MAJOR}.${PYTHON_VERSION_MINOR}/site-packages)
++ install(DIRECTORY UM DESTINATION ${PYTHON_SITE_PACKAGES_DIR})
+ endif()
+ install(FILES ${CMAKE_SOURCE_DIR}/cmake/UraniumTranslationTools.cmake
+- DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake-${CMAKE_MAJOR_VERSION}.${CMAKE_MINOR_VERSION}/Modules/ )
++ DESTINATION ${CMAKE_INSTALL_DATADIR}/cmake/Modules/ )
+ install(DIRECTORY resources DESTINATION ${CMAKE_INSTALL_DATADIR}/uranium)
+
+ # Detect plugins to install
diff --git a/dev-python/uranium/uranium-4.6.1.ebuild b/dev-python/uranium/uranium-4.6.1.ebuild
new file mode 100644
index 000000000000..e2a3e9d997e2
--- /dev/null
+++ b/dev-python/uranium/uranium-4.6.1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit cmake python-single-r1
+
+MY_PN="Uranium"
+
+DESCRIPTION="A Python framework for building 3D printing related applications"
+HOMEPAGE="https://github.com/Ultimaker/Uranium"
+SRC_URI="https://github.com/Ultimaker/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug doc test"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+BDEPEND="${PYTHON_DEPS}
+ sys-devel/gettext
+ doc? ( app-doc/doxygen )
+ test? (
+ $(python_gen_cond_dep '
+ dev-python/pytest[${PYTHON_MULTI_USEDEP}]
+ dev-python/mypy[${PYTHON_MULTI_USEDEP}]
+ ')
+ )"
+
+DEPEND="${PYTHON_DEPS}
+ ~dev-libs/libarcus-${PV}:=[python,${PYTHON_SINGLE_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/PyQt5[${PYTHON_MULTI_USEDEP},declarative,network,svg]
+ dev-python/numpy[${PYTHON_MULTI_USEDEP}]
+ >=sci-libs/scipy-1.1[${PYTHON_MULTI_USEDEP}]
+ sci-libs/Shapely[${PYTHON_MULTI_USEDEP}]
+ ')"
+
+RDEPEND="${DEPEND}
+ dev-qt/qtquickcontrols:5
+ dev-qt/qtquickcontrols2:5"
+
+DOCS=( README.md )
+
+PATCHES=( "${FILESDIR}/${PN}-4.6.1-fix-install-paths.patch" )
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+src_configure() {
+ local mycmakeargs=(
+ -DPYTHON_SITE_PACKAGES_DIR="$(python_get_sitedir)"
+ )
+ cmake_src_configure
+
+ if ! use debug; then
+ sed -i 's/logging.DEBUG/logging.ERROR/' plugins/ConsoleLogger/ConsoleLogger.py || die
+ sed -i 's/logging.DEBUG/logging.ERROR/' plugins/FileLogger/FileLogger.py || die
+ fi
+}
+
+src_compile() {
+ cmake_src_compile
+ if use doc; then
+ cmake_src_compile doc
+ HTML_DOCS=( html )
+ fi
+}
+
+src_install() {
+ cmake_src_install
+ python_optimize
+ python_optimize "${D}/usr/$(get_libdir)"
+}