summaryrefslogtreecommitdiff
path: root/dev-python/urlgrabber/urlgrabber-3.10.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/urlgrabber/urlgrabber-3.10.1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/urlgrabber/urlgrabber-3.10.1.ebuild')
-rw-r--r--dev-python/urlgrabber/urlgrabber-3.10.1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/urlgrabber/urlgrabber-3.10.1.ebuild b/dev-python/urlgrabber/urlgrabber-3.10.1.ebuild
new file mode 100644
index 000000000000..0d7d1b75f99b
--- /dev/null
+++ b/dev-python/urlgrabber/urlgrabber-3.10.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for downloading files"
+HOMEPAGE="http://urlgrabber.baseurl.org"
+SRC_URI="http://urlgrabber.baseurl.org/download/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ia64 ~ppc ~ppc64 ~x86 ~x86-fbsd"
+IUSE=""
+
+DEPEND="dev-python/pycurl[${PYTHON_USEDEP}]"
+RDEPEND="${DEPEND}"
+# Entire testsuite relies on connecting to the i'net