summaryrefslogtreecommitdiff
path: root/dev-python/uvicorn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-05 10:11:29 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-05 10:11:29 +0000
commit68883bef20f77c2d72dfdf20bf5f9d4a5ea5ad9c (patch)
tree5bea0b1c5edcc839425e169609eb2bb2fc6aa760 /dev-python/uvicorn
parentd0f8b473674427ef4f618c94d4d132a7f79578e3 (diff)
gentoo auto-resync : 05:11:2023 - 10:11:29
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/Manifest2
-rw-r--r--dev-python/uvicorn/uvicorn-0.24.0.ebuild78
2 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index 5522ea756686..b61957992743 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1,3 +1,5 @@
DIST uvicorn-0.23.2.gh.tar.gz 723155 BLAKE2B 03edb0b6c7be001be868636a77b818491d71e28277e22f252d650c2d9452e5018470fa3cf60300a8f4358d548f794e95a1bf877ac02ed30574a14dc56cea9841 SHA512 a575482ed261dff3a74a5e04387b36dda55d5975a635ca5c124770b7bbfcf764ea420b0b78b9396e4eaa8b839031933aefc7867befb46d18f39f3df5115eb77a
+DIST uvicorn-0.24.0.gh.tar.gz 715220 BLAKE2B b71273545ae244544b5336524bf4ad1f386c8bb2b1addc501514833f37376f8a09a1d4dfc2272c3b62555337a20750af827c9a7a4c3bffc6327a9d1809869cfa SHA512 98b58ce17a1f072f36923b1b616f818cbadd091256ce1281a5236268ba2378d212384d9c3390b5903edfda5c692a67935051379e31732df45422595a88c69232
EBUILD uvicorn-0.23.2.ebuild 2243 BLAKE2B 8406e991dc792195be6224a68e0eb2d44f5a4b313d17c5c3e2970ff5a8e35d9d9cbacca827a69ccd15e28e47085e8c332880491bb834bd72e960451ce5174b45 SHA512 dae9209b460024cf24b2c731732c422a43be65c50b22cd63c209ecfa09fb19f029a254230c95b457fd4e5b75e0387a9239f113601ef4b631b27651199f0045e5
+EBUILD uvicorn-0.24.0.ebuild 2058 BLAKE2B 8456d67a71c46a4bcfd7a57dec3035c27882cad8393ef13ef0b69a37357492115da12596292d2fd3206be79902b50c50603b2201a4a27c3a04ece5ba547c2e4c SHA512 23b9c2dfa1d6a06ca1a958280c5a4060822849b4f02c21a9719c158d56c88b88ec64aae77bf99741679d977040659004048976914910efe0015224b6779f0cb8
MISC metadata.xml 451 BLAKE2B af9be617c95128297e3455b503e198e13c373244094f6aa9c80837945c3f9f023f1874efa28d4ffa8b241feb9a4e8c7f3d3534e96966733bd5593bffb90904a5 SHA512 4d76bab5c20f7cad81fa56a28c9be07bf2c2ebc412fc647f073215d437a2550eca247b8419df71d04200d0fdf545520684db0b6f4953e73848f69a4f4ad6931e
diff --git a/dev-python/uvicorn/uvicorn-0.24.0.ebuild b/dev-python/uvicorn/uvicorn-0.24.0.ebuild
new file mode 100644
index 000000000000..a131d346d201
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.24.0.ebuild
@@ -0,0 +1,78 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="
+ https://www.uvicorn.org/
+ https://github.com/encode/uvicorn/
+ https://pypi.org/project/uvicorn/
+"
+# as of 0.21.0, no tests in sdist
+SRC_URI="
+ https://github.com/encode/uvicorn/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="test-rust"
+
+RDEPEND="
+ >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/a2wsgi[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.4[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ test-rust? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ dev-python/watchfiles[${PYTHON_USEDEP}]
+ )
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # too long path for unix socket
+ tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
+ # need unpackaged httptools
+ "tests/middleware/test_logging.py::test_trace_logging_on_http_protocol[httptools]"
+ tests/protocols/test_http.py::test_fragmentation
+ # TODO
+ tests/protocols/test_websocket.py::test_connection_lost_before_handshake_complete
+ "tests/protocols/test_websocket.py::test_asgi_return_value[H11Protocol-WebSocketProtocol]"
+ )
+ case ${EPYTHON} in
+ pypy3)
+ # TODO
+ EPYTEST_DESELECT+=(
+ tests/middleware/test_logging.py::test_running_log_using_fd
+ )
+ ;;
+ esac
+
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "auto reload on file changes" dev-python/watchfiles
+}