summaryrefslogtreecommitdiff
path: root/dev-python/uvicorn
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-25 02:49:03 +0100
commitca125edb1c8e51bd222fec61eb155151bbd4b791 (patch)
treeb1ca31e2662c41a1e85c62975d23ce38fa0e5df0 /dev-python/uvicorn
parent9d0673651c57438d51e18c6b8ca894d0491b2df3 (diff)
gentoo auto-resync : 25:08:2022 - 02:49:03
Diffstat (limited to 'dev-python/uvicorn')
-rw-r--r--dev-python/uvicorn/Manifest2
-rw-r--r--dev-python/uvicorn/uvicorn-0.18.3.ebuild62
2 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/uvicorn/Manifest b/dev-python/uvicorn/Manifest
index e31be7943c71..aae0e006118e 100644
--- a/dev-python/uvicorn/Manifest
+++ b/dev-python/uvicorn/Manifest
@@ -1,5 +1,7 @@
DIST uvicorn-0.17.6.tar.gz 708048 BLAKE2B 83b06907c8109b38e13930d8b73584682fa4e34fe7e51fe14b6ca1ddc7ef8122d950a09e31cb364a02f5f12eead5d0522b41cbf428509c6900604d4e2776dfb2 SHA512 d5c5223759d59648f279e22f7e6af728fe8117ed75488d125c1db3e5e9d385a50d574cff72ac46db4eb0a78d0e4f690096cfe78c774674dfba61860e55b7494e
DIST uvicorn-0.18.2.gh.tar.gz 712706 BLAKE2B d8d300579d945a5c2f51b7746b93cd64710c103cd0b7694ce858ec0f4e9dc09f89e9663529dd84c13c9f6334d0f4543cc9442e94aedf8dbddd72a6a0394ba370 SHA512 d2e05198cd833efbe7dddffc30f9a52be3168192269cd493816df8a7d4053e312f534988ee09c5270d63f52dfa48d0b105862c9e05acad41ebf3a40e5fa1aa76
+DIST uvicorn-0.18.3.gh.tar.gz 713216 BLAKE2B ba1fb1f2241fa3c23bc4115d335ef1c176937e8af5e33ae7d1e615271c94bc330ef5cb21d6bedd697ecb2a38798758ea47d5523ea6ee45295cf447e81503ff05 SHA512 a4983e7095f3596ac54557432a074eb8cae4c6dd579fabfe8b6c34606ba8258e6c0684c2e34e8019f2455fbfd1771f8c2c88bf8b01fc505abfae93655f61f032
EBUILD uvicorn-0.17.6.ebuild 1394 BLAKE2B 1f9eb4a37f3476787f643dd1b06c846ee2d4f0aa08aedfb74589097e9163b24a4b5642bf8fdb672bbb61537a15bdbee3ecd69962bd5edb42f969b94202307320 SHA512 7e478a4e05e4ae6b097eb018ec4bc105812a368389e0b663100f1ae0abad5c11a9ceb8555119d01c1d5397bc56df9af801129ed83e246a69538aa262fa39157f
EBUILD uvicorn-0.18.2.ebuild 1673 BLAKE2B 22a286fd646394076e5c3ec3958709559bca6349e80009ee64dc75e941a1625d21594989d8b2ec97720697619a0be0efab45ff1950cb0649504d1e4f125f37ae SHA512 913f3e72abcc10ada0629218f41bb98f85afdf6ea4b4cf42df90b8dca3be7f864ff242a61b7a7f6fd95c31c84f2c512b19a4a31fb7c8a170a6a3f289a6822ace
+EBUILD uvicorn-0.18.3.ebuild 1680 BLAKE2B a20a31ce9f222039bde644a208fa34185133e1b0dbe62ce8c4d02bf9b6d65c2480a7b8bb41cbe1727fad093895a0f76e7757ee65b3e44316629acba06a47930d SHA512 94a4d3db98ffa4b74b0ba19051975fe5cc9a21efc345d5cd19f9235a2bb5b13283d9949d7eea03e66b25e0ebd013cdb75a9f1783c282696b2acca744fc879e6b
MISC metadata.xml 451 BLAKE2B af9be617c95128297e3455b503e198e13c373244094f6aa9c80837945c3f9f023f1874efa28d4ffa8b241feb9a4e8c7f3d3534e96966733bd5593bffb90904a5 SHA512 4d76bab5c20f7cad81fa56a28c9be07bf2c2ebc412fc647f073215d437a2550eca247b8419df71d04200d0fdf545520684db0b6f4953e73848f69a4f4ad6931e
diff --git a/dev-python/uvicorn/uvicorn-0.18.3.ebuild b/dev-python/uvicorn/uvicorn-0.18.3.ebuild
new file mode 100644
index 000000000000..ed997d18da2a
--- /dev/null
+++ b/dev-python/uvicorn/uvicorn-0.18.3.ebuild
@@ -0,0 +1,62 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Lightning-fast ASGI server implementation"
+HOMEPAGE="https://www.uvicorn.org/"
+SRC_URI="https://github.com/encode/${PN}/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/asgiref-3.4.0[${PYTHON_USEDEP}]
+ >=dev-python/click-7.0[${PYTHON_USEDEP}]
+ >=dev-python/h11-0.8[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/httpx[${PYTHON_USEDEP}]
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/python-dotenv[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/trustme[${PYTHON_USEDEP}]
+ >=dev-python/websockets-10.0[${PYTHON_USEDEP}]
+ dev-python/wsproto[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # too long path for unix socket
+ tests/test_config.py::test_bind_unix_socket_works_with_reload_or_workers
+ # need unpackaged httptools
+ "tests/middleware/test_logging.py::test_trace_logging_on_http_protocol[httptools]"
+ tests/protocols/test_http.py::test_fragmentation
+ )
+
+ local EPYTEST_IGNORE=()
+ # love from Rust world
+ if ! has_version "dev-python/watchfiles[${PYTHON_USEDEP}]"; then
+ EPYTEST_IGNORE+=(
+ tests/supervisors/test_reload.py
+ )
+ fi
+
+ epytest
+}
+
+pkg_postinst() {
+ optfeature "auto reload on file changes" dev-python/watchfiles
+}