summaryrefslogtreecommitdiff
path: root/dev-python/vcrpy
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-29 08:00:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-29 08:00:25 +0100
commitd855918b46ba8714cf1320fe63b55fd0ed1748a6 (patch)
tree4d7d0e86122a07796a660310d507f93e1b7747b9 /dev-python/vcrpy
parentb8325835c82367d22428eb41afa0f2d375338d3c (diff)
gentoo auto-resync : 29:06:2024 - 08:00:25
Diffstat (limited to 'dev-python/vcrpy')
-rw-r--r--dev-python/vcrpy/Manifest2
-rw-r--r--dev-python/vcrpy/vcrpy-6.0.1.ebuild19
2 files changed, 19 insertions, 2 deletions
diff --git a/dev-python/vcrpy/Manifest b/dev-python/vcrpy/Manifest
index b80fb2cb101d..0581a8b4fe6e 100644
--- a/dev-python/vcrpy/Manifest
+++ b/dev-python/vcrpy/Manifest
@@ -1,4 +1,4 @@
AUX vcrpy-6.0.1-httpbin-compat.patch 1921 BLAKE2B 7ac8e0fa08f38b2b1f3bf78f80485a32d2ca2a56bff4c9c70b42049a6ed37dadd25f25fedd77b578d7452b87bf74825b0bd062186f74c9cc6a7017be6fe189f7 SHA512 81b87869bf8af2b853ff5a336c45ac1b26ed8f49729e2da94859b621d1110a07081d280dfb541fab0a8bb2ad48c26be48a3966f17a7455242da0b150a569c0c8
DIST vcrpy-6.0.1.gh.tar.gz 337497 BLAKE2B a00571d7ed0dd895cc120e3e2615e8e6ea3e86344813e87f836a182be45389b200925ae2a02dc754b0b77db642d3be453b3b8c909b26197222b84fa95c6da804 SHA512 79ba9ea29db20ddc3db5676d7bdb05da17848eb126ed63d813a1d2b0de80573fff3afaec2ffe1af491a0310ce922c7545c4569035d0f5868f171db25965c217f
-EBUILD vcrpy-6.0.1.ebuild 1748 BLAKE2B ef578ea72d3b54a75e3d986932d1d170b6abbc14d42df5304e796c92853f95cfd1a0ae722adff5a063babc0dd53aa63e26e24d9c69bc19a4353fc8e62d653b86 SHA512 af5de06049c920f8ebfd13a11378667dddb87d6ab12e42bca8893443d42f680261c95d4c798d4f42ca9bf458e4350eae96439aead717b5d51382b39519078ee0
+EBUILD vcrpy-6.0.1.ebuild 2457 BLAKE2B 8113970483c823cc8b5b91558a970042a83e069cf82f90e567d6189c5e2b85b993dcdcfea282e4f51b31898d05632f2b9941d2085b6dfce04cd6274ba8a0e654 SHA512 d7bf742469fe375e8cf54df94676684e2cad4ffb546a7f68a6b2913d944860305fcb0ef6766281895435c5b290e33c3c63054c7e36addc35b104bc47de437b41
MISC metadata.xml 388 BLAKE2B fd31293bd6085e6a93816a1813a8c3a9d046ed3d932fba5b32b454a71e7535606ba92815699b7ca10fc837b07a5335df54d5fae8c860a7ea88c6ea72891d0620 SHA512 0360ac6f113035ffd1991d2a42000f290c9d0a3fa8c4dac9abfde0eecafd23e1ff9929d8ee521f83a924c523992fabc5cb4353079bf7c52dac9f906a31d4da55
diff --git a/dev-python/vcrpy/vcrpy-6.0.1.ebuild b/dev-python/vcrpy/vcrpy-6.0.1.ebuild
index 257bac69d0b4..f65324722b8e 100644
--- a/dev-python/vcrpy/vcrpy-6.0.1.ebuild
+++ b/dev-python/vcrpy/vcrpy-6.0.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} )
+PYTHON_COMPAT=( python3_{10..13} )
inherit distutils-r1
@@ -62,6 +62,23 @@ python_test() {
tests/integration/test_aiohttp.py
)
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # SSL problems, might be weak bundle in pytest-httpbin
+ # https://github.com/kevin1024/vcrpy/issues/848
+ "tests/integration/test_urllib2.py::test_cross_scheme"
+ "tests/integration/test_urllib2.py::test_decorator[https]"
+ "tests/integration/test_urllib2.py::test_get_data[https]"
+ "tests/integration/test_urllib2.py::test_post_data[https]"
+ "tests/integration/test_urllib2.py::test_post_decorator[https]"
+ "tests/integration/test_urllib2.py::test_post_unicode_data[https]"
+ "tests/integration/test_urllib2.py::test_response_code[https]"
+ "tests/integration/test_urllib2.py::test_response_headers[https]"
+ )
+ ;;
+ esac
+
local -x REQUESTS_CA_BUNDLE=$("${EPYTHON}" -m pytest_httpbin.certs)
epytest -m 'not online'
}