summaryrefslogtreecommitdiff
path: root/dev-python/versioningit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/versioningit
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/versioningit')
-rw-r--r--dev-python/versioningit/Manifest3
-rw-r--r--dev-python/versioningit/metadata.xml13
-rw-r--r--dev-python/versioningit/versioningit-2.0.0.ebuild46
3 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/versioningit/Manifest b/dev-python/versioningit/Manifest
new file mode 100644
index 000000000000..0427be43f5dd
--- /dev/null
+++ b/dev-python/versioningit/Manifest
@@ -0,0 +1,3 @@
+DIST versioningit-2.0.0.tar.gz 735138 BLAKE2B 59247c0a2ec85f828b1b36c7f7ff6981fdd430b242c262f7325586e8ab35410083e0a795e72204c9ad9c0c50bb02c047f8baa01c556f74d69a8ddfc9e911474b SHA512 d700e25f3b58efd87943a950ede66ad8814e3aeea1927bb68b51312a636684b16695c44492f4357595305a5a85a3fc8c411d80a02e9b157162844d731dcab93f
+EBUILD versioningit-2.0.0.ebuild 860 BLAKE2B 5b99a6099f118843506107b7738b12588971c23e63a73f9394457b364bbd852cb9af74d69db6226d94ab219cde4549bba8a6e4887b5ff6df9956fbc01e7cd1cc SHA512 fa0ad9816f14251306d7564691737a54e1f29a59be9f420a307737092c774a53eb920d3f0c5380f8c5c6b7381b0fb276be0efecc81201af7fc90f49c08350ef9
+MISC metadata.xml 400 BLAKE2B 96934adb9ade5b51537765da51d530a644f87328688415cfd5b239048adede18db1ec7cbb2a234cc2e28fea368aa9c815176bb22262c9053fdc2c85c6c6e3f56 SHA512 9070b850fff35058a11cc7504bbc5fbef17cc9154df5419a64bae10fd3cb160a043ffd0880fc3c5054bd1d2eb4891bcbf5764c56f2441ab79366336caf91e379
diff --git a/dev-python/versioningit/metadata.xml b/dev-python/versioningit/metadata.xml
new file mode 100644
index 000000000000..edc0e0bb524d
--- /dev/null
+++ b/dev-python/versioningit/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <stabilize-allarches/>
+ <upstream>
+ <remote-id type="github">jwodder/versioningit</remote-id>
+ <remote-id type="pypi">versioningit</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/versioningit/versioningit-2.0.0.ebuild b/dev-python/versioningit/versioningit-2.0.0.ebuild
new file mode 100644
index 000000000000..392e4e954b30
--- /dev/null
+++ b/dev-python/versioningit/versioningit-2.0.0.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="A setuptools plugin for versioning based on git tags"
+HOMEPAGE="
+ https://github.com/jwodder/versioningit/
+ https://pypi.org/project/versioningit/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/packaging-17.1[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pydantic[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_IGNORE=(
+ # Tries to do wheel/pip installs
+ test/test_end2end.py
+)
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ sed -i \
+ -e '/--cov/d' \
+ -e '/-cov-/d' \
+ tox.ini || die
+
+ distutils-r1_python_prepare_all
+}