summaryrefslogtreecommitdiff
path: root/dev-python/virtualenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-02-13 00:12:52 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-02-13 00:12:52 +0000
commit965058196f44550f3bc491dd85064071e085b776 (patch)
tree8485c648f0ac19b27204c8b331c3619c93463cce /dev-python/virtualenv
parent0ec1e1dd7867c3dedcbea76c9b6e847d6b388c03 (diff)
gentoo auto-resync : 13:02:2025 - 00:12:52
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/Manifest2
-rw-r--r--dev-python/virtualenv/virtualenv-20.29.2.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index e6f278fd4f75..deedba518997 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -1,4 +1,6 @@
AUX virtualenv-20.26.3-ensurepip.patch 1231 BLAKE2B e70cb1a5f8dc8ccf6e08fce67aa3485c0f584937d8e7b693f0d0859d6ec9d9b16bf1492b9abe96d4c8c8eb12814eaa54f76ed8e318f3871ee956189ce08b3dff SHA512 86c98d7ce4a9ea073c72cd103cbce66ed720794fa4fa2b68ac19382e3c4f53303613aed80a6984a68cab513cb198d648c5c6f103308eacb3c7306b72e4321129
DIST virtualenv-20.29.1.tar.gz 7658028 BLAKE2B b03008966fdeb0f7e72525ae5612a17721b9e5cbfb1e95f7a0b1d9677dfc8d3036e86623724a722ea5571f32bb7a43a7af0ec530fba3fa4e96b5215b5ee06e66 SHA512 94a2c9ce13cb98bf1df6f2e0a9db0e1acacf4667fb9609ad39d8ae7a6529818c0b1597b463262b0ea9a492684d9af027fa0ac9c1bb499e862ab587786b3b9511
+DIST virtualenv-20.29.2.tar.gz 4320272 BLAKE2B 3a00c2be2a511968020df74eb5da6ee03cafb3942ac70b23ce598840d2c21db57ba190dac0d30fade915e379fca98db1c53a0c4dbafec457e817957bb736cde4 SHA512 9c455e38fcf1eb2e8ca053df35c86c04dae6c32a55e5ba057de1f1713f5f2a8ad0fa597e4409409646d6d3b3f020058f9955a2888756ac3e6af91e37efcf8c91
EBUILD virtualenv-20.29.1.ebuild 3420 BLAKE2B 792192a5c3a267215cc9b2e13c367811aa7e75f7be7e5b9d33e80431ac7276076c6c67c47ea96ce93aa4db6633fdb142881d22521e92dc364003bc7ed2a40c9d SHA512 066e75569689fb184f902878bc102020ebaa38efc617ab5a7613958ef2dab4cda34ed50076e23e15b0e4ea4702264bdbe4dbe7eb15193cccc4a704ecba0d8c14
+EBUILD virtualenv-20.29.2.ebuild 3428 BLAKE2B 20469ae687e98bc832c49748c93c4c0ec43af8caedff983a3036000c861d4c76ddbb0d3558f772ee6a71f736f55277a7b5cbbd76675b63ed88c732a3c20b33ac SHA512 20b24b2135301fbea99864189620e7fba222d7ade11afa37d56939946c4b08879aebd5d779bcbd18057b3dc9a942f0b4d891daf511410819867d73ff343abd6a
MISC metadata.xml 406 BLAKE2B 97fee04c2662c5c36b6e16538284def46eb2454424770f42edf2567ed804ca15c4e969c714c57573f897b0946246577ab6e35204ed1f3f1735713d8ab5d24667 SHA512 356d42db463b63a3b3a55c1e98eb661de0a10aa6a5fde4f8b3f888ec73020c6679e86efd8dbb0b3e4a5a720af95e658612ba460fe548e081a90beec75fb9c1b2
diff --git a/dev-python/virtualenv/virtualenv-20.29.2.ebuild b/dev-python/virtualenv/virtualenv-20.29.2.ebuild
new file mode 100644
index 000000000000..8af728153afa
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-20.29.2.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ https://virtualenv.pypa.io/en/stable/
+ https://pypi.org/project/virtualenv/
+ https://github.com/pypa/virtualenv/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/distlib-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.12.2[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.9.1[${PYTHON_USEDEP}]
+
+ dev-python/ensurepip-pip
+ dev-python/ensurepip-setuptools
+ dev-python/ensurepip-wheel
+"
+# coverage is used somehow magically in virtualenv, maybe it actually
+# tests something useful
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/pip-22.2.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pytest-freezer-0.4.6[${PYTHON_USEDEP}]
+ ' pypy3)
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-67.8[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/time-machine[${PYTHON_USEDEP}]
+ ' 'python3*')
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=180
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ # use wheels from ensurepip bundle
+ "${FILESDIR}/${PN}-20.26.3-ensurepip.patch"
+ )
+
+ distutils-r1_src_prepare
+
+ # workaround test failures due to warnings from setuptools-scm, sigh
+ echo '[tool.setuptools_scm]' >> pyproject.toml || die
+
+ # remove useless pins
+ sed -i -e 's:,<[0-9.]*::' pyproject.toml || die
+
+ # remove bundled wheels
+ rm src/virtualenv/seed/wheels/embed/*.whl || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
+ # tests for old wheels with py3.7 support
+ tests/unit/seed/embed/test_pip_invoke.py::test_base_bootstrap_via_pip_invoke
+ tests/unit/seed/wheels/test_wheels_util.py::test_wheel_not_support
+ # broken by different wheel versions in ensurepip
+ tests/unit/seed/wheels/test_acquire_find_wheel.py::test_find_latest_string
+ tests/unit/seed/wheels/test_acquire_find_wheel.py::test_find_exact
+ tests/unit/seed/wheels/test_acquire_find_wheel.py::test_find_latest_none
+ tests/unit/seed/wheels/test_acquire.py::test_download_wheel_bad_output
+ # hangs on a busy system, sigh
+ tests/unit/test_util.py::test_reentrant_file_lock_is_thread_safe
+ )
+ case ${EPYTHON} in
+ python3.1[23])
+ EPYTEST_DESELECT+=(
+ tests/unit/create/via_global_ref/test_build_c_ext.py
+ )
+ ;&
+ python3.11)
+ EPYTEST_DESELECT+=(
+ # TODO
+ tests/unit/discovery/py_info/test_py_info.py::test_fallback_existent_system_executable
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+ local plugins=( -p flaky -p pytest_mock )
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ plugins+=( -p freezer )
+ else
+ plugins+=( -p time_machine )
+ fi
+ epytest "${plugins[@]}" -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # remove bundled wheels, we're using ensurepip bundle instead
+ find "${ED}" -name '*.whl' -delete || die
+}