summaryrefslogtreecommitdiff
path: root/dev-python/virtualenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-19 04:04:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-19 04:04:36 +0100
commitd895362f98ae63a6ed12cd16d3b3df95d6967f25 (patch)
treee6c8a50e31dc122b10c6dc3d9eee5d6ec6f002c0 /dev-python/virtualenv
parent483d7c056fba15727fe24545f93627a1d1e1e2eb (diff)
gentoo auto-resync : 19:10:2024 - 04:04:35
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/Manifest2
-rw-r--r--dev-python/virtualenv/virtualenv-20.27.0.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index a4b2eaff7e04..f21a254cbe0e 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -1,6 +1,8 @@
AUX virtualenv-20.26.3-ensurepip.patch 1231 BLAKE2B e70cb1a5f8dc8ccf6e08fce67aa3485c0f584937d8e7b693f0d0859d6ec9d9b16bf1492b9abe96d4c8c8eb12814eaa54f76ed8e318f3871ee956189ce08b3dff SHA512 86c98d7ce4a9ea073c72cd103cbce66ed720794fa4fa2b68ac19382e3c4f53303613aed80a6984a68cab513cb198d648c5c6f103308eacb3c7306b72e4321129
DIST virtualenv-20.26.5.tar.gz 9371932 BLAKE2B 3b85da76f00e44b4e9fd33ef159e06cad06e4b0663aff9433712db8dcc0abb0bad7b94f260e374687f81b09a12bb3438f533267035370efbdeef20e8f9371461 SHA512 616d6565731d8b1f4ddf90eea9c7018eb1bc553c9ad6feee5f9e6669a996205afbedd900bf8d74cbcca7113fddc985ae279454274a7ec8902ac068e5e4b1b5ba
DIST virtualenv-20.26.6.tar.gz 9372482 BLAKE2B 7e91c8beb59c3c3f4d538af425916abe94151efedae3f643c573f6c0dd05a37cfc42b5e61cbdb73e02fcc5adbfd34a0ffa5096790975890fe9d17f626ea5687c SHA512 9d403a835c66f9b7f733d3720f459b9450dddd5cd9a76358332da20dddd309918177d3d7782304e11f56f48755d901feb4eb9b708c3719241bf389f29bf0ba04
+DIST virtualenv-20.27.0.tar.gz 6483858 BLAKE2B 661a8e208eecb4cc27edd515c09e4541fca6a00285a7f4dcc798c37c602a505460cc53f699a33589dca2f686534bec188c48ae1001e52979febd1787760b2ef7 SHA512 1d0e1e32af8685d0e426823acaa3b73a1a8f60195a0627585b897d1c3d785b2cc67331c6e7f414589e5a61b84f6aecaffdaa4baefa51390bf23ebb3be2e2ef78
EBUILD virtualenv-20.26.5.ebuild 3420 BLAKE2B f14f7f0d059ee5d5c4b1a18b4068d41ad6bbce2ee2bcd49b1cac89d896398f1a72a4a41caf041b1539a5b7c85fee4ec6fb5e92882ea52d184e70dc11e3e351c6 SHA512 5daf437d02672dfd5381844336edb86e3c83a07ca521d72a9f16fe467620a1abd454e4f85f0ca9c6a9db910d30b343dc52bd2737d5cb872e580947d71e63e670
EBUILD virtualenv-20.26.6.ebuild 3428 BLAKE2B 357c6a685e462336f5aa62e316143111454b7c32d75d56f080074099d81aa86705a58638b35db827d2c69642618959ee80a138700948695a051ae4f7f9513be4 SHA512 43f379b79040c4acb4e2e26a868b7ad8ce35b39dd11cfa7082728231e90cc14eb94b33427050c375418eac9aae24f05d3e6f4cf7440c71eae01bcd2dd3a3be94
+EBUILD virtualenv-20.27.0.ebuild 3428 BLAKE2B 357c6a685e462336f5aa62e316143111454b7c32d75d56f080074099d81aa86705a58638b35db827d2c69642618959ee80a138700948695a051ae4f7f9513be4 SHA512 43f379b79040c4acb4e2e26a868b7ad8ce35b39dd11cfa7082728231e90cc14eb94b33427050c375418eac9aae24f05d3e6f4cf7440c71eae01bcd2dd3a3be94
MISC metadata.xml 406 BLAKE2B 97fee04c2662c5c36b6e16538284def46eb2454424770f42edf2567ed804ca15c4e969c714c57573f897b0946246577ab6e35204ed1f3f1735713d8ab5d24667 SHA512 356d42db463b63a3b3a55c1e98eb661de0a10aa6a5fde4f8b3f888ec73020c6679e86efd8dbb0b3e4a5a720af95e658612ba460fe548e081a90beec75fb9c1b2
diff --git a/dev-python/virtualenv/virtualenv-20.27.0.ebuild b/dev-python/virtualenv/virtualenv-20.27.0.ebuild
new file mode 100644
index 000000000000..acc7255ef749
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-20.27.0.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ https://virtualenv.pypa.io/en/stable/
+ https://pypi.org/project/virtualenv/
+ https://github.com/pypa/virtualenv/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/distlib-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.12.2[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.9.1[${PYTHON_USEDEP}]
+
+ dev-python/ensurepip-pip
+ dev-python/ensurepip-setuptools
+ dev-python/ensurepip-wheel
+"
+# coverage is used somehow magically in virtualenv, maybe it actually
+# tests something useful
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/pip-22.2.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pytest-freezer-0.4.6[${PYTHON_USEDEP}]
+ ' pypy3)
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-67.8[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/time-machine[${PYTHON_USEDEP}]
+ ' 'python3*')
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=180
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ # use wheels from ensurepip bundle
+ "${FILESDIR}/${PN}-20.26.3-ensurepip.patch"
+ )
+
+ distutils-r1_src_prepare
+
+ # workaround test failures due to warnings from setuptools-scm, sigh
+ echo '[tool.setuptools_scm]' >> pyproject.toml || die
+
+ # remove useless pins
+ sed -i -e 's:<[0-9.]*,::' pyproject.toml || die
+
+ # remove bundled wheels
+ rm src/virtualenv/seed/wheels/embed/*.whl || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
+ # tests for old wheels with py3.7 support
+ tests/unit/seed/embed/test_pip_invoke.py::test_base_bootstrap_via_pip_invoke
+ tests/unit/seed/wheels/test_wheels_util.py::test_wheel_not_support
+ # broken by different wheel versions in ensurepip
+ tests/unit/seed/wheels/test_acquire_find_wheel.py::test_find_latest_string
+ tests/unit/seed/wheels/test_acquire_find_wheel.py::test_find_exact
+ tests/unit/seed/wheels/test_acquire_find_wheel.py::test_find_latest_none
+ tests/unit/seed/wheels/test_acquire.py::test_download_wheel_bad_output
+ # hangs on a busy system, sigh
+ tests/unit/test_util.py::test_reentrant_file_lock_is_thread_safe
+ )
+ case ${EPYTHON} in
+ python3.1[23])
+ EPYTEST_DESELECT+=(
+ tests/unit/create/via_global_ref/test_build_c_ext.py
+ )
+ ;&
+ python3.11)
+ EPYTEST_DESELECT+=(
+ # TODO
+ tests/unit/discovery/py_info/test_py_info.py::test_fallback_existent_system_executable
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+ local plugins=( -p flaky -p pytest_mock )
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ plugins+=( -p freezer )
+ else
+ plugins+=( -p time_machine )
+ fi
+ epytest "${plugins[@]}" -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # remove bundled wheels, we're using ensurepip bundle instead
+ find "${ED}" -name '*.whl' -delete || die
+}