summaryrefslogtreecommitdiff
path: root/dev-python/virtualenv
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-09-19 12:11:50 +0100
commitfe0961fc9674dd24a017f474a34c1edbbd005965 (patch)
treedfdf05888e0f5fff9c1faafe6eb0dd5d827b63e5 /dev-python/virtualenv
parentbcd00c826070701606b0ccebf46234dfc792d3e9 (diff)
gentoo auto-resync : 19:09:2024 - 12:11:50
Diffstat (limited to 'dev-python/virtualenv')
-rw-r--r--dev-python/virtualenv/Manifest2
-rw-r--r--dev-python/virtualenv/virtualenv-20.26.5.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/dev-python/virtualenv/Manifest b/dev-python/virtualenv/Manifest
index 25eb0c49e226..155297ac5f23 100644
--- a/dev-python/virtualenv/Manifest
+++ b/dev-python/virtualenv/Manifest
@@ -1,6 +1,8 @@
AUX virtualenv-20.26.3-ensurepip.patch 1231 BLAKE2B e70cb1a5f8dc8ccf6e08fce67aa3485c0f584937d8e7b693f0d0859d6ec9d9b16bf1492b9abe96d4c8c8eb12814eaa54f76ed8e318f3871ee956189ce08b3dff SHA512 86c98d7ce4a9ea073c72cd103cbce66ed720794fa4fa2b68ac19382e3c4f53303613aed80a6984a68cab513cb198d648c5c6f103308eacb3c7306b72e4321129
DIST virtualenv-20.26.3.tar.gz 9057588 BLAKE2B 74268cab291e7f1e3db6a4c56f0ede1d7995069cb5594341d9af0609196a8154e9153f920043b48100c2263b7020c819135e29532483b233f3c37bf3b780592f SHA512 0cd3b4dc082d071305b44dd2aba2b28527e630b6b4bf28b7b6c59f3e061b01c1dfcfb64293f2b1904109e9e27b70a873cc8c3f1a3cde73bfee114943cef92ca7
DIST virtualenv-20.26.4.tar.gz 9385017 BLAKE2B a9b7f2dd105e6d7e5c85456351fc85fd6b4daa697574b6c1c8d51139d0b64f06fff024d721c4182cadb7c207c03b5f8877917dc79eb6102373503479a9f70215 SHA512 afce31d4bea624c98893d2ab5d7ea02e87e1ea18ae25195864b32c8d127d44fe7e1d07c24949138496f571b71d745d2f571c0b2a895d2282bef04dfe496fcd93
+DIST virtualenv-20.26.5.tar.gz 9371932 BLAKE2B 3b85da76f00e44b4e9fd33ef159e06cad06e4b0663aff9433712db8dcc0abb0bad7b94f260e374687f81b09a12bb3438f533267035370efbdeef20e8f9371461 SHA512 616d6565731d8b1f4ddf90eea9c7018eb1bc553c9ad6feee5f9e6669a996205afbedd900bf8d74cbcca7113fddc985ae279454274a7ec8902ac068e5e4b1b5ba
EBUILD virtualenv-20.26.3-r2.ebuild 3420 BLAKE2B f14f7f0d059ee5d5c4b1a18b4068d41ad6bbce2ee2bcd49b1cac89d896398f1a72a4a41caf041b1539a5b7c85fee4ec6fb5e92882ea52d184e70dc11e3e351c6 SHA512 5daf437d02672dfd5381844336edb86e3c83a07ca521d72a9f16fe467620a1abd454e4f85f0ca9c6a9db910d30b343dc52bd2737d5cb872e580947d71e63e670
EBUILD virtualenv-20.26.4.ebuild 3428 BLAKE2B 357c6a685e462336f5aa62e316143111454b7c32d75d56f080074099d81aa86705a58638b35db827d2c69642618959ee80a138700948695a051ae4f7f9513be4 SHA512 43f379b79040c4acb4e2e26a868b7ad8ce35b39dd11cfa7082728231e90cc14eb94b33427050c375418eac9aae24f05d3e6f4cf7440c71eae01bcd2dd3a3be94
+EBUILD virtualenv-20.26.5.ebuild 3428 BLAKE2B 357c6a685e462336f5aa62e316143111454b7c32d75d56f080074099d81aa86705a58638b35db827d2c69642618959ee80a138700948695a051ae4f7f9513be4 SHA512 43f379b79040c4acb4e2e26a868b7ad8ce35b39dd11cfa7082728231e90cc14eb94b33427050c375418eac9aae24f05d3e6f4cf7440c71eae01bcd2dd3a3be94
MISC metadata.xml 406 BLAKE2B 97fee04c2662c5c36b6e16538284def46eb2454424770f42edf2567ed804ca15c4e969c714c57573f897b0946246577ab6e35204ed1f3f1735713d8ab5d24667 SHA512 356d42db463b63a3b3a55c1e98eb661de0a10aa6a5fde4f8b3f888ec73020c6679e86efd8dbb0b3e4a5a720af95e658612ba460fe548e081a90beec75fb9c1b2
diff --git a/dev-python/virtualenv/virtualenv-20.26.5.ebuild b/dev-python/virtualenv/virtualenv-20.26.5.ebuild
new file mode 100644
index 000000000000..acc7255ef749
--- /dev/null
+++ b/dev-python/virtualenv/virtualenv-20.26.5.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="Virtual Python Environment builder"
+HOMEPAGE="
+ https://virtualenv.pypa.io/en/stable/
+ https://pypi.org/project/virtualenv/
+ https://github.com/pypa/virtualenv/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/distlib-0.3.7[${PYTHON_USEDEP}]
+ >=dev-python/filelock-3.12.2[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-3.9.1[${PYTHON_USEDEP}]
+
+ dev-python/ensurepip-pip
+ dev-python/ensurepip-setuptools
+ dev-python/ensurepip-wheel
+"
+# coverage is used somehow magically in virtualenv, maybe it actually
+# tests something useful
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/coverage[${PYTHON_USEDEP}]
+ dev-python/flaky[${PYTHON_USEDEP}]
+ >=dev-python/pip-22.2.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/pytest-freezer-0.4.6[${PYTHON_USEDEP}]
+ ' pypy3)
+ >=dev-python/pytest-mock-3.6.1[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-67.8[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/time-machine[${PYTHON_USEDEP}]
+ ' 'python3*')
+ dev-python/wheel[${PYTHON_USEDEP}]
+ >=dev-python/packaging-20.0[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_TIMEOUT=180
+distutils_enable_tests pytest
+
+src_prepare() {
+ local PATCHES=(
+ # use wheels from ensurepip bundle
+ "${FILESDIR}/${PN}-20.26.3-ensurepip.patch"
+ )
+
+ distutils-r1_src_prepare
+
+ # workaround test failures due to warnings from setuptools-scm, sigh
+ echo '[tool.setuptools_scm]' >> pyproject.toml || die
+
+ # remove useless pins
+ sed -i -e 's:<[0-9.]*,::' pyproject.toml || die
+
+ # remove bundled wheels
+ rm src/virtualenv/seed/wheels/embed/*.whl || die
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/unit/seed/embed/test_bootstrap_link_via_app_data.py::test_seed_link_via_app_data
+ # tests for old wheels with py3.7 support
+ tests/unit/seed/embed/test_pip_invoke.py::test_base_bootstrap_via_pip_invoke
+ tests/unit/seed/wheels/test_wheels_util.py::test_wheel_not_support
+ # broken by different wheel versions in ensurepip
+ tests/unit/seed/wheels/test_acquire_find_wheel.py::test_find_latest_string
+ tests/unit/seed/wheels/test_acquire_find_wheel.py::test_find_exact
+ tests/unit/seed/wheels/test_acquire_find_wheel.py::test_find_latest_none
+ tests/unit/seed/wheels/test_acquire.py::test_download_wheel_bad_output
+ # hangs on a busy system, sigh
+ tests/unit/test_util.py::test_reentrant_file_lock_is_thread_safe
+ )
+ case ${EPYTHON} in
+ python3.1[23])
+ EPYTEST_DESELECT+=(
+ tests/unit/create/via_global_ref/test_build_c_ext.py
+ )
+ ;&
+ python3.11)
+ EPYTEST_DESELECT+=(
+ # TODO
+ tests/unit/discovery/py_info/test_py_info.py::test_fallback_existent_system_executable
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x TZ=UTC
+ local plugins=( -p flaky -p pytest_mock )
+ if [[ ${EPYTHON} == pypy3 ]]; then
+ plugins+=( -p freezer )
+ else
+ plugins+=( -p time_machine )
+ fi
+ epytest "${plugins[@]}" -p xdist -n "$(makeopts_jobs)" --dist=worksteal
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ # remove bundled wheels, we're using ensurepip bundle instead
+ find "${ED}" -name '*.whl' -delete || die
+}