summaryrefslogtreecommitdiff
path: root/dev-python/virtualenvwrapper
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-12 13:40:16 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-12 13:40:16 +0100
commitb4ef58ede68341d0e00d761505857e965e2b4231 (patch)
tree94723f8dfd3de9243bf2ae39d9deb2ee78c9719f /dev-python/virtualenvwrapper
parent9f3ff9d79a788d420003387392ec40fd0548efae (diff)
gentoo auto-resync : 12:10:2022 - 13:40:16
Diffstat (limited to 'dev-python/virtualenvwrapper')
-rw-r--r--dev-python/virtualenvwrapper/Manifest1
-rw-r--r--dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4-r2.ebuild47
2 files changed, 48 insertions, 0 deletions
diff --git a/dev-python/virtualenvwrapper/Manifest b/dev-python/virtualenvwrapper/Manifest
index 80e4a7f9953e..07c27adfec96 100644
--- a/dev-python/virtualenvwrapper/Manifest
+++ b/dev-python/virtualenvwrapper/Manifest
@@ -1,3 +1,4 @@
DIST virtualenvwrapper-4.8.4.tar.gz 334920 BLAKE2B cd790b1e98cca7d09ea9c80df5d52380335d4a0ea4e6d95f7bd48d78583e0d842e1145ea08d8d8c73516adbe8d6c75bd53c17943723f859860a0cad105a2b058 SHA512 461938100061e11af0ee9b17405d991ae34e5ec9c79cc12614962d3178b588a2da710baa15ac626960b09177c1b5b10c7bc590cb4c126ebd2f719d0f1527c9c4
EBUILD virtualenvwrapper-4.8.4-r1.ebuild 867 BLAKE2B b2d4d40092dca2ed4ee557dfd79b948a3626f94506f84b0967d0914ace961583c3999c45244859c052a380debc4791005feb48bd8c0425b7ca0e9c2e96a9998d SHA512 7c1d69963fc47584808e680cb8e26796dba01056e1b6c9a1dd03c82e5a3d5ffb64a0313574a39bbfb3011078f71eba4f21485a581b7abacda5c011436d7342ad
+EBUILD virtualenvwrapper-4.8.4-r2.ebuild 1161 BLAKE2B de5db0c38c2333f4d16308ffb7ba226bb87ffe3ed0b6cb78b71d7cb67eb68657fd7273e5c67e24182ab1efec7337a5254141e818d9a22cca62587bd226b1c484 SHA512 ffa735061aae01fe0126f4752f201484296e3fadb03163ff79ea64b4e2f56b7a5e7ca89065a287edd0b1d280aa9181b07baea3bea400fbd5036c53aef6650c10
MISC metadata.xml 321 BLAKE2B d8a20231685666e7f87bf5e5e2def277415e72fc5f2818b5104e07631287dd6fe7b5e1e9bb06b5ff0bb08c18f0c0984aa869b6239cd9779429ccc55d04a5982a SHA512 da98e8330699413bf829815ef2e95d2c86653aa55c95a1c1b71f36c945f689a481c4dbfb754fa06c17ba13b4133263e4bd85257ce05f2330c98a1c884da1a217
diff --git a/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4-r2.ebuild b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4-r2.ebuild
new file mode 100644
index 000000000000..13f088a96ea5
--- /dev/null
+++ b/dev-python/virtualenvwrapper/virtualenvwrapper-4.8.4-r2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Set of extensions to Ian Bicking's virtualenv tool"
+HOMEPAGE="https://bitbucket.org/dhellmann/virtualenvwrapper
+ https://pypi.org/project/virtualenvwrapper/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# testsuite doesn't work out of the box. Demand of a virtualenv outstrips setup by the eclass
+RESTRICT=test
+
+RDEPEND="
+ dev-python/virtualenv[${PYTHON_USEDEP}]
+ dev-python/stevedore[${PYTHON_USEDEP}]
+ dev-python/virtualenv-clone[${PYTHON_USEDEP}]"
+DEPEND="${DEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/pbr[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ default
+ sed -i -e 's/egrep/grep -E/' "${S}/virtualenvwrapper.sh" || die
+}
+
+python_compile() {
+ distutils-r1_python_compile
+ find "${BUILD_DIR}" -name '*.pth' -delete || die
+}
+
+python_test() {
+ bash ./tests/run_tests || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ find "${D}" -name '*.pth' -delete || die
+}