summaryrefslogtreecommitdiff
path: root/dev-python/voluptuous
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-13 10:39:22 +0100
commit9452a6e87b6c2c70513bc47a2470bf9f1168920e (patch)
tree8ac67e26b45f34d71c5aab3621813b100a0d5f00 /dev-python/voluptuous
parentf516638b7fe9592837389826a6152a7e1b251c54 (diff)
gentoo resync : 13.06.2020
Diffstat (limited to 'dev-python/voluptuous')
-rw-r--r--dev-python/voluptuous/Manifest4
-rw-r--r--dev-python/voluptuous/metadata.xml4
-rw-r--r--dev-python/voluptuous/voluptuous-0.11.5.ebuild8
3 files changed, 8 insertions, 8 deletions
diff --git a/dev-python/voluptuous/Manifest b/dev-python/voluptuous/Manifest
index a384e1682762..a228da2e1c5c 100644
--- a/dev-python/voluptuous/Manifest
+++ b/dev-python/voluptuous/Manifest
@@ -1,3 +1,3 @@
DIST voluptuous-0.11.5.tar.gz 44216 BLAKE2B 921e0f35bd5348f412f0bf20939b3364b0014d3b1d1a7248cd73f2514eef0fb4e5b4b742876dc4606b5619529f1aa96e3577508ed0bf8d1e98b4d8bb88e2b8a2 SHA512 8893434e8e73ebf3682da1970d1d720444de452937ac9123fab53413c88a21d04ad3eb490902d829aa60be6804ff68b8bcf57a1c45807751c3d50be63e9b2551
-EBUILD voluptuous-0.11.5.ebuild 598 BLAKE2B fbc23b9efa73275b9a93c6a27774b416a1281570bf8712b58ac40feba75c8afaac3335d9bdb75eef500ea0d54843cfb3068606e910e214b2c3e2fcdec0dd9b3f SHA512 b67675353c810a9350c5a1721f49272eea1bb5c7d879ea992d29f9294dc9078e645485a6293c88e2bff55d6a464f230cacaaec1465199238abf9dbbe47de73da
-MISC metadata.xml 590 BLAKE2B 6d6c101d04be60962c428dc495959500a2a80aab39b7353cbd2694d27794645766c1b92b1ff09f9d8c72c5cedb4f07472a94945e8a48263d44b0134a6a0eed2c SHA512 ff4732c5a379f2607a97a45c56def4955bc542446c5545ff807138eed3992d71ffd4b3638f122accf1a272537c071ab0304717a43706efef191dfc7b35422bab
+EBUILD voluptuous-0.11.5.ebuild 526 BLAKE2B 0524f99dd3c90f446064b27a2a0d8abd6aa73bd3b2713a827cce059701e06797283dd701879b11cdfc3658cfc036465533666551e5a8bb9dd6f067623da4926e SHA512 1a059795c8e77e1d7f19fcc9cabd0bb84d265fcaa00d81b39b29387e88cf8e80139220b929a13541ec5182ba8a48bcfe0b1fbbe83340e2ab355ac41f5d0cf92d
+MISC metadata.xml 691 BLAKE2B 833a0f6176b6e2b3db23053e8be9054b28434061afa2e09aae9ceec1a3c1b841b3f0e0b9939341b66614cb12d8a002111aa554ee4c094123439de935e7e60b73 SHA512 0162ad8edf206d260e648a6a2441fdf054bc591b9368e3c78525bde5ab7e6a23f65c3f0ed1c04827847759182a8b81c0fa55ebc833a753f90a9e7df14aa04f06
diff --git a/dev-python/voluptuous/metadata.xml b/dev-python/voluptuous/metadata.xml
index b46a8cbabba5..89d22de27941 100644
--- a/dev-python/voluptuous/metadata.xml
+++ b/dev-python/voluptuous/metadata.xml
@@ -5,6 +5,10 @@
<email>prometheanfire@gentoo.org</email>
<name>Matthew Thode</name>
</maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
<longdescription lang="en">
Voluptuous, despite the name, is a Python data validation library. It is primarily intended for validating data coming into Python as JSON, YAML, etc.
</longdescription>
diff --git a/dev-python/voluptuous/voluptuous-0.11.5.ebuild b/dev-python/voluptuous/voluptuous-0.11.5.ebuild
index 7cdce4236c2a..40ef58995c16 100644
--- a/dev-python/voluptuous/voluptuous-0.11.5.ebuild
+++ b/dev-python/voluptuous/voluptuous-0.11.5.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
-PYTHON_COMPAT=( python{2_7,3_6,3_7,3_8} )
+EAPI=7
+PYTHON_COMPAT=( python{2_7,3_{6..9}} )
inherit distutils-r1
@@ -13,10 +13,6 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm arm64 hppa ~ia64 ~mips ~ppc ~ppc64 s390 sparc x86 ~amd64-linux ~x86-linux"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
python_test() {
unset PYTHONPATH