summaryrefslogtreecommitdiff
path: root/dev-python/watchdog
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/watchdog
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/watchdog')
-rw-r--r--dev-python/watchdog/Manifest4
-rw-r--r--dev-python/watchdog/metadata.xml12
-rw-r--r--dev-python/watchdog/watchdog-0.8.3-r1.ebuild36
-rw-r--r--dev-python/watchdog/watchdog-0.8.3-r2.ebuild36
4 files changed, 88 insertions, 0 deletions
diff --git a/dev-python/watchdog/Manifest b/dev-python/watchdog/Manifest
new file mode 100644
index 000000000000..5eee93ff0290
--- /dev/null
+++ b/dev-python/watchdog/Manifest
@@ -0,0 +1,4 @@
+DIST watchdog-0.8.3.tar.gz 83154 BLAKE2B d5d0635e83bbcd31544d5ea5811c2f202b0da76bd7a4086e8fc61e3293640e701b04599f95decaa82bee3705dbd6b91ad24b9dbd20edcfc329913600c8a3c932 SHA512 61f1db886e8e9a6d78b569329f4d5944c296778a5a34f94fbf115a748fb4c3be422bf4d3cc828e22fcdcd380fdf9009f5bd91a8a5edc87089afc58297a0b946f
+EBUILD watchdog-0.8.3-r1.ebuild 856 BLAKE2B 9c906c5c618f0f2649cffbd79e5b289108ded726af922a3e649d3fe82bf320943409fff5e7dcfee1d0a5028c799bdf41ca6b593019fe02776b1cdcfa08091f02 SHA512 023d639b51945dca4f7b42e439b3f2e4844f1f6d22c49ef91182bc2b899947b133c1703ad0ecfd35f7e519d724ba77cb635102871b8c08514a2ed4cfc23794e8
+EBUILD watchdog-0.8.3-r2.ebuild 858 BLAKE2B dc7e530619d92bfcab4dfe9bc8cf0bc94a765e3f27338821e80f5b21bd913a8cd22fb6858da670457d40ee639f5adef0e6d41e909ad7442bcaf857f4cac6d601 SHA512 6dd41c3cd891db711b7367f16d1d22d03054394b6df014933c46aeb19ac6429997d9145c2f0dfc10ada82ab04a0ba9a1aaeca785a538d0f221761b1f7b63b3d5
+MISC metadata.xml 384 BLAKE2B 4aa02b5d26bb82f0f0ef9d7369f984114d6b0de77f662ec150e6433324f4500b5b5004b626e7ce3558dc1190a31cbe788793ddbeab4a10f13d2b9be5de36e77e SHA512 0883ee5d6169f36b061be829e7b2e4a69f7efada9f7a2b446a9baad15c8e119d24a7bb3d80bf253a760332bfb8a03ef06b3bc91cb97b7a86d0773252fbc3db90
diff --git a/dev-python/watchdog/metadata.xml b/dev-python/watchdog/metadata.xml
new file mode 100644
index 000000000000..c2abbade6b63
--- /dev/null
+++ b/dev-python/watchdog/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">watchdog</remote-id>
+ <remote-id type="github">gorakhargosh/watchdog</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/watchdog/watchdog-0.8.3-r1.ebuild b/dev-python/watchdog/watchdog-0.8.3-r1.ebuild
new file mode 100644
index 000000000000..38133c53eea1
--- /dev/null
+++ b/dev-python/watchdog/watchdog-0.8.3-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} pypy)
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="mirror://pypi/w/watchdog/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="test"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}
diff --git a/dev-python/watchdog/watchdog-0.8.3-r2.ebuild b/dev-python/watchdog/watchdog-0.8.3-r2.ebuild
new file mode 100644
index 000000000000..f9a4f0c96461
--- /dev/null
+++ b/dev-python/watchdog/watchdog-0.8.3-r2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy)
+
+inherit distutils-r1 eutils
+
+DESCRIPTION="Python API and shell utilities to monitor file system events"
+HOMEPAGE="https://github.com/gorakhargosh/watchdog"
+SRC_URI="mirror://pypi/w/watchdog/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~ppc x86"
+IUSE="test"
+
+CDEPEND="dev-python/pyyaml[${PYTHON_USEDEP}]"
+RDEPEND="${CDEPEND}
+ dev-python/argh[${PYTHON_USEDEP}]
+ dev-python/pathtools[${PYTHON_USEDEP}]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-cov[${PYTHON_USEDEP}]
+ >=dev-python/pytest-timeout-0.3[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ esetup.py test
+}
+
+pkg_postinst() {
+ optfeature "Bash completion" dev-python/argcomplete
+}