summaryrefslogtreecommitdiff
path: root/dev-python/watchgod
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-03-20 00:40:44 +0000
commit4cbcc855382a06088e2f016f62cafdbcb7e40665 (patch)
tree356496503d52354aa6d9f2d36126302fed5f3a73 /dev-python/watchgod
parentfcc5224904648a8e6eb528d7603154160a20022f (diff)
gentoo resync : 20.03.2022
Diffstat (limited to 'dev-python/watchgod')
-rw-r--r--dev-python/watchgod/Manifest2
-rw-r--r--dev-python/watchgod/watchgod-0.8.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/watchgod/Manifest b/dev-python/watchgod/Manifest
index 2224b661f340..cfcaeedcd59e 100644
--- a/dev-python/watchgod/Manifest
+++ b/dev-python/watchgod/Manifest
@@ -1,3 +1,5 @@
DIST watchgod-0.7.gh.tar.gz 14362 BLAKE2B 0c16b7ef2a7e1d0ca2c9d27b1503a9710662364318d5021e916aabf90c8f917b0bf69559a545658f839953832edc579b0014a0736b3b155f097d1d29c2e4b4f7 SHA512 afa225b30cf796ce95861c61fbe8eb22ed72011522de53d53c41148311793db10e41b66e9eb1237c4372f142edaec992de79715c568e435ddb1695666be1cdd8
+DIST watchgod-0.8.gh.tar.gz 15354 BLAKE2B 1325f452593e54e8cc40eca0fc9867aff0c93d89de767b9512508fee02efe94e43284b30c316b2cce31a15acc2ee9ff19ca7f9cc6fb46cfffdb0458e502d85ca SHA512 0e86d9dd3eba0cd3aaeccc009ebdba8528ba23d63ad19ff789dffda075b4a01c32be0dfabf38f15e7966bc09e7fb5ae3a94a9dd89a55358a95622aaf5cad0947
EBUILD watchgod-0.7.ebuild 960 BLAKE2B df5acdbe3b1c759bc22af4451b872aa8a3b7f442350aa6e494768a7c55c5c874c335e4087b8b38078f6ccb8012b3f5f3e42d664def636f28f1a51e66a7afab90 SHA512 c0115f54f24d59c04829326d41a1ff09857609f308dfa99ef7c34fe4642fbb54d1d70c6cb96a739fd848461b1f9a8c26df2546980c82758a73dafc4f199917d8
+EBUILD watchgod-0.8.ebuild 1063 BLAKE2B 333335738be460dcab637d582bf28558a46c72b783926308850ee8654629f57c226a917058be3f2775b4616b2009e649b2def7d6d8483b9c721f4aa92122c568 SHA512 a4c0e6143ef15c30415fb388735e9d050a786e4b237fa144de4d73ca46f9fb4f91a4bce376deaab341b435f5907111f3851cac7f5ef2b53aafc69e54a895b862
MISC metadata.xml 351 BLAKE2B 07e1d5205c2ec59e8fe690449302a0cc7d75b6b3171669bdd4e0476e1c1e389b9af36a331d18f8d45b3b8486372e52558b2a6f48545b78a87eeca092c899837a SHA512 261367cd6511a897955e85335dfa158ee9441bb2e61592e2bbe964fc0f8219e271e764b7c65c659d3ed1dc4d87896dafab83abfc0708715c749e2fdf16a4c9ec
diff --git a/dev-python/watchgod/watchgod-0.8.ebuild b/dev-python/watchgod/watchgod-0.8.ebuild
new file mode 100644
index 000000000000..1326c01ccff9
--- /dev/null
+++ b/dev-python/watchgod/watchgod-0.8.ebuild
@@ -0,0 +1,47 @@
+# Copyright 2021-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Simple, modern file watching and code reload in Python"
+HOMEPAGE="
+ https://pypi.org/project/watchgod/
+ https://github.com/samuelcolvin/watchgod/
+"
+SRC_URI="
+ https://github.com/samuelcolvin/watchgod/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ =dev-python/anyio-3*[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ dev-python/pytest-mock[${PYTHON_USEDEP}]
+ dev-python/pytest-toolbox[${PYTHON_USEDEP}]
+ dev-python/trio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # flaky test on slow systems, https://github.com/samuelcolvin/watchgod/issues/84
+ tests/test_watch.py::test_awatch_log
+)
+
+src_prepare() {
+ # increase timeout
+ sed -e '/sleep/s/0.01/1.0/' -i tests/test_watch.py || die
+
+ distutils-r1_src_prepare
+}