summaryrefslogtreecommitdiff
path: root/dev-python/watchgod
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-03 14:59:59 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-03 14:59:59 +0000
commit529abfa74a08ae5099db9780bcdf8250aa52ecb6 (patch)
tree2e2d1a9fd6e89b4872499afea3dc57490271e69c /dev-python/watchgod
parente6ba529df30e3fc9dfdf55ec5797f2f764df6e54 (diff)
gentoo auto-resync : 03:12:2022 - 14:59:58
Diffstat (limited to 'dev-python/watchgod')
-rw-r--r--dev-python/watchgod/Manifest3
-rw-r--r--dev-python/watchgod/metadata.xml11
-rw-r--r--dev-python/watchgod/watchgod-0.8.2-r1.ebuild59
3 files changed, 0 insertions, 73 deletions
diff --git a/dev-python/watchgod/Manifest b/dev-python/watchgod/Manifest
deleted file mode 100644
index e170c79cf772..000000000000
--- a/dev-python/watchgod/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST watchfiles-0.8.2.gh.tar.gz 15515 BLAKE2B 97c17737c6970c8b799707547cef760c307cd000d09cf3a338e47c0735d537e0321643066eab592f7f7e6ccc25272ea1e7e0bbc02f6274864f7cc39a177b83ba SHA512 a44b831352ace03c450781bc815b1813c44c386d666a9b724b562ff69228705651bfc23e81b7344d0f79c62577d4f910b323c734298e2a609f85bbc4a0f0498e
-EBUILD watchgod-0.8.2-r1.ebuild 1396 BLAKE2B 02d1a30949eff5193cfa07751044f4eb068fbe3cd85114507b5fdb683641b6f94641604f99938de8ef46e6b36571545ffb143a6695f45e6a233a11e9b0debe25 SHA512 df3a4f91fb9cab84864405b670c27246564812ae7eb5c82574c8853c1bb69b0efd4efe93629944f5e24ca96596c2add167af1c251aee1de60d37cef692f99a66
-MISC metadata.xml 353 BLAKE2B 9fba49b9fcbfb15db8c5709ba52b803063c010ebeaed0ab6ee715e776a7da16c295ef6ae6495dd94372835970b34676dbf5b05d96b6bfc737bd68f504384d9f1 SHA512 ca0d0d4135e2ce7678ce004a48389ac614f512f502194ec542d461592ab73d63d68ed5d9a4f9ccc1a37b74435bfb6c75d309bccc43eba8d53fdc36520199d751
diff --git a/dev-python/watchgod/metadata.xml b/dev-python/watchgod/metadata.xml
deleted file mode 100644
index f8df5d7b0948..000000000000
--- a/dev-python/watchgod/metadata.xml
+++ /dev/null
@@ -1,11 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- </maintainer>
- <upstream>
- <remote-id type="github">samuelcolvin/watchfiles</remote-id>
- <remote-id type="pypi">watchgod</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/watchgod/watchgod-0.8.2-r1.ebuild b/dev-python/watchgod/watchgod-0.8.2-r1.ebuild
deleted file mode 100644
index a19fe1d0b4f5..000000000000
--- a/dev-python/watchgod/watchgod-0.8.2-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 2021-2022 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{8..11} )
-
-inherit distutils-r1
-
-MY_P=watchfiles-${PV}
-DESCRIPTION="Simple, modern file watching and code reload in Python"
-HOMEPAGE="
- https://pypi.org/project/watchgod/
- https://github.com/samuelcolvin/watchfiles/
-"
-SRC_URI="
- https://github.com/samuelcolvin/watchfiles/archive/v${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- =dev-python/anyio-3*[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/pytest-asyncio[${PYTHON_USEDEP}]
- dev-python/pytest-mock[${PYTHON_USEDEP}]
- dev-python/pytest-toolbox[${PYTHON_USEDEP}]
- dev-python/trio[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- distutils-r1_src_prepare
-
- # increase timeout
- sed -i -e '/sleep/s/0.01/1.0/' tests/test_watch.py || die
- # fix version number in metadata
- sed -i -e "s:0\.0\.dev0:${PV}:" watchgod/version.py || die
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # flaky test on slow systems, https://github.com/samuelcolvin/watchgod/issues/84
- tests/test_watch.py::test_awatch_log
- )
- [[ ${EPYTHON} == pypy3 ]] && EPYTEST_DESELECT+=(
- tests/test_watch.py::test_does_not_exist
- )
- epytest
-}