summaryrefslogtreecommitdiff
path: root/dev-python/weakrefmethod
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /dev-python/weakrefmethod
reinit the tree, so we can have metadata
Diffstat (limited to 'dev-python/weakrefmethod')
-rw-r--r--dev-python/weakrefmethod/Manifest3
-rw-r--r--dev-python/weakrefmethod/metadata.xml19
-rw-r--r--dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild22
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-python/weakrefmethod/Manifest b/dev-python/weakrefmethod/Manifest
new file mode 100644
index 000000000000..79dbc02f1327
--- /dev/null
+++ b/dev-python/weakrefmethod/Manifest
@@ -0,0 +1,3 @@
+DIST weakrefmethod-1.0.3.tar.gz 7472 SHA256 37bc1fbb5575acf82172d4eb7b6fc4412d77d5a1d70dff2c1f8a4574301cda66 SHA512 c68dc806904eb954319984003506eb9b552005ce04722c6a3eb123ecde8f4413f9f9d114f0923c6f6ae2e25b4dbaf8c225c070a1720a6563cf1517f2411a60d5 WHIRLPOOL f34fd902a17cc134952ec51fb1025a78e288349d7f36cea9ab24f5155dd2112ee83416563c8f4cf60daf5129c6531dbec512e4bb5b56e52950b6a10317c2f35c
+EBUILD weakrefmethod-1.0.3.ebuild 470 SHA256 6ee1156729d571bf7b7b2ec4c9bf9c203f92a5effb4b8c300f10c283e0cbb5db SHA512 88860816c1b689fcdab41f545c077287f29acd0ba8fb6237b3ad172b02f69262db75dba6bf0bb16ea544c4229e44ef1c4a75db42c32f4e77017836d4f8552122 WHIRLPOOL 66089f886497d66bd9502c7cce3b0273c52649847b35196010a6411c36a3c47b2aa7aa9777da9811b7703d3a13a3b4ea7e9a649484956a13c7a4ca2e7ac5553c
+MISC metadata.xml 603 SHA256 866aac69c8147b5b29781c0bca0ee37d961019f33dc7795d92b0936f37d99718 SHA512 97e9f0da46bbec178b6ba2fd9dfd99189f1a00bbad2b26cef5307c3dc0ec5dbb651b325d6ec7ae1cd429a8b23d1b654e1bb2fbc5960aa8d9752b593eac990fd0 WHIRLPOOL 362235bdc1bd10df21c1e31637c79ed0ddfb43985efa55c2397747f608432744a1df7bcccb1ffb58a0919c77a6a70610ce6881d708a585ae5b00ab16ce32dde7
diff --git a/dev-python/weakrefmethod/metadata.xml b/dev-python/weakrefmethod/metadata.xml
new file mode 100644
index 000000000000..a40778af57c7
--- /dev/null
+++ b/dev-python/weakrefmethod/metadata.xml
@@ -0,0 +1,19 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>prometheanfire@gentoo.org</email>
+ <name>Matthew Thode</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>openstack@gentoo.org</email>
+ <name>Openstack</name>
+ </maintainer>
+ <longdescription lang="en">
+ Backport of WeakMethod from Python 3.4 to Python 2.6+
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">weakrefmethod</remote-id>
+ <remote-id type="github">twang817/weakrefmethod</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild b/dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild
new file mode 100644
index 000000000000..01ea69b6ab7e
--- /dev/null
+++ b/dev-python/weakrefmethod/weakrefmethod-1.0.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of WeakMethod from Python 3.4 to Python 2.6+"
+HOMEPAGE="https://github.com/rholder/retrying"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="amd64 ~arm64 x86"
+IUSE=""
+
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+RDEPEND=""