summaryrefslogtreecommitdiff
path: root/dev-python/weasyprint
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-31 22:43:14 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-31 22:43:14 +0000
commit7323114f21150e9c3714584386134160e2c520cf (patch)
treeb361bee15d0d87cf243bdf778fdfff9e8d7256a8 /dev-python/weasyprint
parent4856d9d89d9f533d36c415521ddc9c23be3c6033 (diff)
gentoo auto-resync : 31:01:2025 - 22:43:14
Diffstat (limited to 'dev-python/weasyprint')
-rw-r--r--dev-python/weasyprint/Manifest2
-rw-r--r--dev-python/weasyprint/weasyprint-64.0.ebuild47
2 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/weasyprint/Manifest b/dev-python/weasyprint/Manifest
index ccb55b7f6881..d7c9f60e64f3 100644
--- a/dev-python/weasyprint/Manifest
+++ b/dev-python/weasyprint/Manifest
@@ -1,3 +1,5 @@
DIST weasyprint-63.1.tar.gz 491880 BLAKE2B 564c52abe3299aa2c51733c883c59ea0581953e067c003377cf0456412bd0cc49f38a03ea46f9cc6e3a3eb4c8df4daa1359996e0525bd9420b1720a26a393877 SHA512 1fda3126dd5c028b42515819f58153092d1607ea5a327a8668cd11ce44aa2b73d7340c04825ce80486881ac1b0dcfe789ffaec277f7a81465efc9067b9b9c87c
+DIST weasyprint-64.0.tar.gz 498075 BLAKE2B 572bac1f70476d63f8f40e3ace90e534bbe69c5a071bbe1e9de7bb8d1c5b06b150d9e7ad7261e74d0c6aeb740b9889608e22bf71b7e01e0d313a1dc546b58fe8 SHA512 46e65777804d53174bb3020b1418d19c0bf815667d020c40fb7de567439272df65d74ab941fdb37edc7f1d4f06430d3ebaa65f8ce13c887235e39c51cefb3930
EBUILD weasyprint-63.1.ebuild 1054 BLAKE2B 2e70f87830b4bd8134d60db76d4074985cd2b295489a165723ebdd80acc2a28a09a0cb8e7e458f3b1a897bed0d57e04052d3164d5def1fd55434c0fd5c040c35 SHA512 2b22de21f83625ad101aa5904893d44daa337738d60e1b6a58e2e376134646fcecd521d79419a5499b507039f434581ed5eb641e96fdbf97bba3efa6c7974820
+EBUILD weasyprint-64.0.ebuild 1055 BLAKE2B ca8289b15255682b429bd7966e6df10f3e1e4d665d12e9676c00d4ee0789358bc2eee399a0c5122fe7daa35d67969cb343b6d139702bc4f3fe5b60719bec8a3c SHA512 d0cf55032ff827bd628b52878bf04d1a32b9521c5091678ae41b25059d047ff86e70aae421dde9d0fb94ed3f3b6808f64c4a4c41c0a76dc415c91622326b9720
MISC metadata.xml 382 BLAKE2B 3e5d142b055354e1ea440d9efd4bf92458b1da3f777dd90929ce2041ca6e0969fa6e58aacfb4a5a93ff90805e0d8ec4c9c6253559ca54698f5029639ce35ac8a SHA512 43415064a6f56eaca974031e51d63118d1c65b33e4399302fc72cc2cd6f15e0a47cf411b18d3c5136e866115855deb19b6a9e058a18049151959ce5ee29ececf
diff --git a/dev-python/weasyprint/weasyprint-64.0.ebuild b/dev-python/weasyprint/weasyprint-64.0.ebuild
new file mode 100644
index 000000000000..d62e3bc92379
--- /dev/null
+++ b/dev-python/weasyprint/weasyprint-64.0.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Visual rendering engine for HTML and CSS that can export to PDF"
+HOMEPAGE="
+ https://weasyprint.org/
+ https://github.com/Kozea/WeasyPrint/
+ https://pypi.org/project/weasyprint/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/cffi-0.6:=[${PYTHON_USEDEP}]
+ >=dev-python/cssselect2-0.1[${PYTHON_USEDEP}]
+ >=dev-python/fonttools-4.0.0[${PYTHON_USEDEP}]
+ >=dev-python/pillow-9.1.0[jpeg,jpeg2k,${PYTHON_USEDEP}]
+ >=dev-python/pydyf-0.11.0[${PYTHON_USEDEP}]
+ >=dev-python/pyphen-0.9.1[${PYTHON_USEDEP}]
+ >=dev-python/tinycss2-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/tinyhtml5-2.0.0[${PYTHON_USEDEP}]
+ media-fonts/dejavu
+ x11-libs/pango
+"
+
+BDEPEND="
+ test? (
+ >=app-text/ghostscript-gpl-9.56.1-r3
+ media-fonts/ahem
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}