summaryrefslogtreecommitdiff
path: root/dev-python/websocket-client/websocket-client-1.6.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-09 00:04:30 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-09 00:04:30 +0100
commit94ead5b3c01213a82c9b72a2df165452421db42b (patch)
tree8a48ed4d21de4204607288d00e68a671bef1e8f8 /dev-python/websocket-client/websocket-client-1.6.4.ebuild
parent418459f7de9eb29d6db8b61681f39c467d9600e1 (diff)
gentoo auto-resync : 09:10:2023 - 00:04:30
Diffstat (limited to 'dev-python/websocket-client/websocket-client-1.6.4.ebuild')
-rw-r--r--dev-python/websocket-client/websocket-client-1.6.4.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/websocket-client/websocket-client-1.6.4.ebuild b/dev-python/websocket-client/websocket-client-1.6.4.ebuild
new file mode 100644
index 000000000000..e70ca56c7688
--- /dev/null
+++ b/dev-python/websocket-client/websocket-client-1.6.4.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="WebSocket client for python with hybi13 support"
+HOMEPAGE="
+ https://github.com/websocket-client/websocket-client/
+ https://pypi.org/project/websocket-client/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="examples"
+
+BDEPEND="
+ test? (
+ dev-python/python-socks[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests unittest
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}