summaryrefslogtreecommitdiff
path: root/dev-python/webtest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-29 02:06:03 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-29 02:06:03 +0000
commit2a3c08f4647671d17f534a5dbd8bd45e11c90ea2 (patch)
tree67ecd2d13b251a03c4834bdec638d301818901eb /dev-python/webtest
parenta2148b9fab4c83209816a49f091d70873b19881d (diff)
gentoo auto-resync : 29:11:2024 - 02:06:03
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/Manifest2
-rw-r--r--dev-python/webtest/webtest-3.0.2.ebuild45
2 files changed, 47 insertions, 0 deletions
diff --git a/dev-python/webtest/Manifest b/dev-python/webtest/Manifest
index 932a013cd923..fc0d0b8cd24d 100644
--- a/dev-python/webtest/Manifest
+++ b/dev-python/webtest/Manifest
@@ -1,4 +1,6 @@
AUX webtest-2.0.33-no-pylons-theme.patch 1556 BLAKE2B e108d05467d87aa0dcc50e8a9fcb8032eeabdf6801d5a66fa9cbe6f51b6dd4539c71b4ff1cf0ef39edfee689e51a6e67e30e473fffa8f2db9225ff23e3b4619b SHA512 6423cc275c2774b07819079d8fe8478cf2b322c16860b600dbd039480a8883252046a6c9fc2136ec4ff54a8adbfceeb3a8ee4a7e43faea17ec588f42a5eafd5e
DIST webtest-3.0.1.tar.gz 79278 BLAKE2B 3466e0d291cc8b02f5f11c8174dcf99cf56696d394de195fce721bb4f01cb76140bf39a955a264f84daad091ad8c37b6302e39c351373b77c4ec0d8a40d74575 SHA512 58417f2d533bd8339258f756d16d1f1cf26f89d8bc387cc7a7ba8fa2b30346454c053b531f79238939112b318fe1972d960d681c605e178d223acc53a8784be4
+DIST webtest-3.0.2.tar.gz 79331 BLAKE2B 2fa124c25889e5d256861b9df6d2b7b3af18a8ea367197b7dcf38e6182c64e8c3fbba6855f1b95f69917caef6cc82bab3a24064f8ec496775fe1f972d838c63d SHA512 f94d78a09368575f772136f7263244d0dfacd344d94d819b15a7e7d5af2a4186cb88659249f1e7009754ac45fbb9f5a3ee0f9bb7f6eccf903f955b9072bb0433
EBUILD webtest-3.0.1.ebuild 1083 BLAKE2B 824e7abec048b9fc33d8638d5726dc7c5b32069b2d5bb72f8a3bd9a2b82eb890bf3066a945cde77658118f2247aa98106a0569b3e6912d7dd6bab06484ec9b9a SHA512 46d4336a306f0e552af7feb1f8d0693ea79900bd00d5aec0f7253b9c26b1cef5c5e2737c99fc33535a0529ebdf113e4088ff6856c31a23cfdde19abc9a6183fc
+EBUILD webtest-3.0.2.ebuild 1091 BLAKE2B 028794296e45317938687ec48cbd47fa0630505bcf66832dc4e056479be0f56cbef41df54e2ec19061fead89233f1aa6a65e496b2c202209dfc9ddff4928dffe SHA512 cb1662c37e22e062523a3c40e9a559f4599ce0087b009d6da6928fc3fb4be5895dd9cdb1e3eaeba7a398da98090c4d2941aad1db0a0b570b2c932609a0867256
MISC metadata.xml 389 BLAKE2B 8cce21b0f8aed22e408af586691c2bcb8cfbf36af3ecf4a08de924f973e5cc4f49fc598ff1a2f651b81605ede0fa22b41518c29866703e4601d5742b78139be4 SHA512 df2b2eb916f60a9c2bc3c0a4321c54ff579e91d11a8dd3ebdc6b4526299b9dbd77b8ec630449df29fba94a483c6ab318d914c7666cb6dcf36b220de1d2f63dbb
diff --git a/dev-python/webtest/webtest-3.0.2.ebuild b/dev-python/webtest/webtest-3.0.2.ebuild
new file mode 100644
index 000000000000..b7e323dd3b3c
--- /dev/null
+++ b/dev-python/webtest/webtest-3.0.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_PN="WebTest"
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Helper to test WSGI applications"
+HOMEPAGE="
+ https://docs.pylonsproject.org/projects/webtest/en/latest/
+ https://github.com/Pylons/webtest/
+ https://pypi.org/project/WebTest/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+RDEPEND="
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pastedeploy[${PYTHON_USEDEP}]
+ >=dev-python/webob-1.2[${PYTHON_USEDEP}]
+ >=dev-python/waitress-3.0.2[${PYTHON_USEDEP}]
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pyquery[${PYTHON_USEDEP}]
+ dev-python/wsgiproxy2[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ dev-python/legacy-cgi[${PYTHON_USEDEP}]
+ ' 3.13)
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/webtest-2.0.33-no-pylons-theme.patch"
+)
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest