summaryrefslogtreecommitdiff
path: root/dev-python/webtest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-06 23:13:57 +0000
commita8b0d35ab742f31538d515dea39716e566d533c0 (patch)
tree40c6c87a13f0e5ef1111ed1bdd9191f3bd1c1e59 /dev-python/webtest
parent8fcdcec5fbdd0e3a77391e4f354218014f59f358 (diff)
gentoo resync : 06.01.2018
Diffstat (limited to 'dev-python/webtest')
-rw-r--r--dev-python/webtest/Manifest2
-rw-r--r--dev-python/webtest/webtest-2.0.16.ebuild67
2 files changed, 0 insertions, 69 deletions
diff --git a/dev-python/webtest/Manifest b/dev-python/webtest/Manifest
index 7eaee49fcca5..b90fa5c6ce61 100644
--- a/dev-python/webtest/Manifest
+++ b/dev-python/webtest/Manifest
@@ -1,5 +1,3 @@
-DIST WebTest-2.0.16.zip 88232 BLAKE2B 659ba614aae5fcd9194c7efc63c7d34096e66d6edf12efae569902caafd1f782a501a6c4ce1df0ebea3be61bd1674609e9be96860afdf0dc3ec667e0530837e7 SHA512 da09abba8ed52c8d673acf547f47df6919b534b33b746944610fc78bd3695f36e3718f89e68f8aec7852b6cf98da0f0b5500dfe9427fd7926e5304ad216eafbb
DIST WebTest-2.0.21.tar.gz 66866 BLAKE2B d2830fcce7fb4b91029838806952e3e9c6916c3b292c7142138f30486d936b4a1f0c2d28a5973b0c351c64e499f343f3711296c6e37c38548e3a81b108163a17 SHA512 21f58ee9192fd0eb0eb2d88179ffc015aa5cf04c8004db251bd65d13d54c34b9e6b5fc9fdd8e9fcbbc18fcfb2be714c0691b2ef034318861262f8705b4a44610
-EBUILD webtest-2.0.16.ebuild 1744 BLAKE2B 39d60dc59d75d8afdbfdfd763d867074d41e418933b170a9ca556ba6b545dc2cecf74fd3be2d12f736d94ee832b04a8feeeaf0183c18bb501629c35c8fbe6e31 SHA512 e7cbc3bf52b3596e7487e334068bf146bb59d3230ab420f42e94add9c5ab0878d5491a70b7d06d5f65da71bb3bc693390331e650d87acc716e2adc5b05bff5c6
EBUILD webtest-2.0.21.ebuild 1841 BLAKE2B b38938e9aa5ffbcff77672e6aa1ea357fcdcbcf70c889e8130bd3d0fd9d8beed272968744b3b3a05b6000b87f668831b8e073ee2af6ed852a24da3ab766e4f62 SHA512 1c0201d485c7cc3a00e3f2f6c3ed7c54f3eccba4c3404365139699a432fe751e94dd070ebb2fd3de7de52b6e2cd5c102aa7f5d297dfaa92c922b5b15b015299f
MISC metadata.xml 310 BLAKE2B 34f814fb04671947a228986ee91f8eaafec5a2931cdb87c63b8e135130dc60eff1a2fc2d15f0aba767fac07d853ffcdc339dfdd02495ccc40830b5452b6173d1 SHA512 0fb6e471cf00fcbea309bdb63d23c5917250f2de2e3e245a91d6ccf1258123ee6f0a8c3f311c526b7f9062c6ed93df1c89f44abf16879440dd1dc81c7fba2743
diff --git a/dev-python/webtest/webtest-2.0.16.ebuild b/dev-python/webtest/webtest-2.0.16.ebuild
deleted file mode 100644
index fb9c40e1754b..000000000000
--- a/dev-python/webtest/webtest-2.0.16.ebuild
+++ /dev/null
@@ -1,67 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_7,3_4} )
-
-inherit distutils-r1
-
-MY_PN="WebTest"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Helper to test WSGI applications"
-HOMEPAGE="http://pythonpaste.org/webtest/ https://pypi.python.org/pypi/WebTest"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.zip"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha amd64 arm ~hppa ia64 ppc64 ~s390 ~sh sparc x86"
-IUSE="doc test"
-
-#nose<1.3.0
-RDEPEND="
- dev-python/six[${PYTHON_USEDEP}]
- >=dev-python/waitress-0.8.5[${PYTHON_USEDEP}]
- >=dev-python/webob-1.2[${PYTHON_USEDEP}]
- dev-python/beautifulsoup:4[${PYTHON_USEDEP}]
- dev-python/lxml[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- app-arch/unzip
- dev-python/setuptools[${PYTHON_USEDEP}]
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( dev-python/nose[${PYTHON_USEDEP}]
- dev-python/pyquery[${PYTHON_USEDEP}]
- dev-python/pastedeploy[${PYTHON_USEDEP}]
- dev-python/wsgiproxy2[${PYTHON_USEDEP}]
- dev-python/coverage[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 )
- )"
-
-S="${WORKDIR}/${MY_P}"
-
-# Makes testing easier; otherwise we get errors from pkg_resources.
-DISTUTILS_IN_SOURCE_BUILD=1
-
-python_prepare_all() {
- # Prevent un-needed d'loading during doc build
- sed -s 's:intersphinx_mapping:_&:' -i docs/conf.py || die
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- if use doc; then
- sphinx-build docs html || die
- fi
-}
-
-python_test() {
- # Tests raise ImportErrors with our default PYTHONPATH.
- local -x PYTHONPATH=
- nosetests || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( html/. )
- distutils-r1_python_install_all
-}