summaryrefslogtreecommitdiff
path: root/dev-python/wehjit
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/wehjit
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/wehjit')
-rw-r--r--dev-python/wehjit/Manifest4
-rw-r--r--dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch23
-rw-r--r--dev-python/wehjit/metadata.xml17
-rw-r--r--dev-python/wehjit/wehjit-0.2.2-r1.ebuild36
4 files changed, 80 insertions, 0 deletions
diff --git a/dev-python/wehjit/Manifest b/dev-python/wehjit/Manifest
new file mode 100644
index 000000000000..59b263572e75
--- /dev/null
+++ b/dev-python/wehjit/Manifest
@@ -0,0 +1,4 @@
+AUX wehjit-0.2.2-SkipTest.patch 648 BLAKE2B 8dd41cdd67e3cf90b93e02d98e7a0bc30c591600cd058951233d8d315ce78397d3a93347ea74d7ed7c2e224de0c9d8889139a0f9fc5a5dd2c91348c4295534dc SHA512 56c7cd048f9faa71f0fbcf77e894c064f9c4428e165a0fd470d417c9bdde631e4594ddb9dcaa060f3c438d98b2007e5fe815fd949d62aeb58b6161b608abcf78
+DIST wehjit-0.2.2.tar.gz 100515 BLAKE2B 2eddf7ce81583080b051ecfd07d108a2e72dbcaba3616359d463e5c4f92d11463a03197ba372476cc5ab1523cf58614db3cb8d8a72586359a7d95620bd578d7c SHA512 f8fb2edeeb9e90315d3c8f1e9e7d73d556fcad780c4dea637599291b2094e292a42b6f3671407f3d9d88733894501796484fa05ac52f3c1f3e1cb29d376a87fb
+EBUILD wehjit-0.2.2-r1.ebuild 742 BLAKE2B 043c2bc7e2e537f40a87d2bb86ef38d07fbe022b17cb58ae59413606253210d3152896174dcdadfd52eecf3145793c58d8ab44b3a63630837260f289382ea004 SHA512 7b47dccf4365662aa000818cd4d79e0d65c4ba2693f955459dd7e537d5a3d6062d491c48c5cf2a119f5f3f39781718ceec10522ff98e132088111f1f8c4b284f
+MISC metadata.xml 578 BLAKE2B 48514e174995072e4e89560d31aceb0440a4cfd22230ded9298fe3b1e70ac9c699367dba2282e6e3e347375040d5891631d172255a5fd98fb8d5db8dfc5ce5e8 SHA512 cb9f24891df1a9c13cc0c165514b63d4877947a0793bd81c98fe7735b4afd7e9620e1dc742c6cc01a7f82ba9dc19f3770bd289ba15343a0324eb23a5cbe9a4e7
diff --git a/dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch b/dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch
new file mode 100644
index 000000000000..057d70747e74
--- /dev/null
+++ b/dev-python/wehjit/files/wehjit-0.2.2-SkipTest.patch
@@ -0,0 +1,23 @@
+diff -ur wehjit-0.2.2.orig/wehjit/collection.py wehjit-0.2.2/wehjit/collection.py
+--- wehjit/collection.py 2010-02-11 16:26:14.000000000 +0800
++++ wehjit/collection.py 2012-11-08 14:24:40.326482713 +0800
+@@ -22,6 +22,11 @@
+ Collect widget plugins together in a `Collection`.
+ """
+
++import sys
++if sys.version_info[:2] == (2, 7):
++ import unittest
++else:
++ import unittest2 as unittest
+ import inspect
+ import os
+ from os import path
+@@ -130,6 +135,7 @@
+ """
+ return name in self.__plugins
+
++ @unittest.skip("Plugin not in gentoo")
+ def __getitem__(self, name):
+ """
+ Return the plugin named ``name``.
diff --git a/dev-python/wehjit/metadata.xml b/dev-python/wehjit/metadata.xml
new file mode 100644
index 000000000000..e84e225efc41
--- /dev/null
+++ b/dev-python/wehjit/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>maksbotan@gentoo.org</email>
+ <name>Maxim Koltsov</name>
+</maintainer>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+<longdescription>
+ wehjit is a Python library for for building XHTML widgets for web
+ applications and web pages. It encapsulates the XHTML
+ (a Genshi XML template), CSS, and JavaScript for each widget into a plugin
+</longdescription>
+</pkgmetadata>
diff --git a/dev-python/wehjit/wehjit-0.2.2-r1.ebuild b/dev-python/wehjit/wehjit-0.2.2-r1.ebuild
new file mode 100644
index 000000000000..55996c08bf61
--- /dev/null
+++ b/dev-python/wehjit/wehjit-0.2.2-r1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python web-widget library"
+HOMEPAGE="http://jderose.fedorapeople.org/wehjit"
+SRC_URI="http://jderose.fedorapeople.org/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/genshi
+ dev-python/assets[${PYTHON_USEDEP}]
+ dev-python/paste[${PYTHON_USEDEP}]
+ dev-python/pygments[${PYTHON_USEDEP}]
+ "
+DEPEND="${RDEPEND}"
+
+DOCS=( README NEWS )
+
+PATCHES=( "${FILESDIR}"/${P}-SkipTest.patch )
+
+python_test() {
+ if [[ "${EPYTHON:6:3}" == '2.6' ]]; then
+ nosetests -I test_app* -e=*getitem
+ else
+ nosetests
+ fi
+}