summaryrefslogtreecommitdiff
path: root/dev-python/whatthepatch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-21 00:11:18 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-21 00:11:18 +0100
commitbed3b604e16fc6075e29f1af8d47507a07035bd3 (patch)
tree1f5d57fd86e90db37f62afb463f4b4c08a2b6eda /dev-python/whatthepatch
parentd6ca4e4f90cb75c323b5988eefa96a04c0d36908 (diff)
gentoo auto-resync : 21:06:2024 - 00:11:18
Diffstat (limited to 'dev-python/whatthepatch')
-rw-r--r--dev-python/whatthepatch/Manifest2
-rw-r--r--dev-python/whatthepatch/whatthepatch-1.0.5.ebuild10
2 files changed, 9 insertions, 3 deletions
diff --git a/dev-python/whatthepatch/Manifest b/dev-python/whatthepatch/Manifest
index ba2271bbb37e..3bc8f31681f3 100644
--- a/dev-python/whatthepatch/Manifest
+++ b/dev-python/whatthepatch/Manifest
@@ -1,3 +1,3 @@
DIST whatthepatch-1.0.5.tar.gz 31850 BLAKE2B dfded6069aa70051fb5f399c9f4707969be4dfc1dee853cd8eb7f36e074c2b595eddbae3efd534321dbbcce7a6658ef9e9bc7675ef466e0a486d930d62761e1e SHA512 d87a36a608a15bcf6d28d26afee40161e26f17fa3b011056388f9850896577f913a91066de8b6071ea15b28fa05f8d00acb997b18483ea56218df4efb40109ab
-EBUILD whatthepatch-1.0.5.ebuild 454 BLAKE2B 4d18dc3e821c01ae7c7c140de800144f5b017e78ddc0063c5e6e5e4f3c5e448a2536557137aeffed2f39ff7606a2e64d59b153d344bc782127c8e950acc48ca2 SHA512 07f301275ff76b414c5ca85ed656d6bd8c91ee04314400a1c8ac50fdc082e8c97ba77b73a2d20717ff04b0eb1fa88ff738daf6ae242caefa49327074ba3a3fb2
+EBUILD whatthepatch-1.0.5.ebuild 682 BLAKE2B fb569361d2056bdd73f3fe4d3690a61830768ce77cade42aae59828fd261c44e05064a3ba3f696da6d4b7c6419e51f1532822b4a31018a33338fc624cdcacd71 SHA512 6b9dc18984e8774cc66c1df3a559c168bfecaf2100cdd63437d916ca3d0b730f9c20fa3732c3daf82418f14af3f5818a29e8edc0d14f3aa7aac74e0313bc81e7
MISC metadata.xml 401 BLAKE2B ee370b7f08a16ea4054d5192831a530a9bceac969b2832d6fe058e98dd7558498afbebf4c1f2102979b2f3c252de73c5b11aafcdfed7044a5218144def4f333a SHA512 2a5c7944923e59032c3e75a0a08339ab4b273a346ef855a8ff61c45cc52ecc847db314b0e733876e6d14c3ca42418d9573a26d7f47213958f44a47c6dcbb6c48
diff --git a/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild b/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild
index f5f6080fcdac..9810e44f809c 100644
--- a/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild
+++ b/dev-python/whatthepatch/whatthepatch-1.0.5.ebuild
@@ -1,10 +1,10 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
@@ -18,4 +18,10 @@ LICENSE="MIT"
SLOT="0"
KEYWORDS="amd64 arm64 ~ppc64 x86"
+EPYTEST_DESELECT=(
+ # the test measures performance of the patch parser together with test data
+ # preparation, which can take long time in some interpreters, bug #907243
+ tests/test_patch.py::PatchTestSuite::test_huge_patch
+)
+
distutils_enable_tests pytest