summaryrefslogtreecommitdiff
path: root/dev-python/wheel/wheel-0.34.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-23 10:22:15 +0100
commit8b4ace9c50842c5b83401ea7b179dcab940387e1 (patch)
tree230f3135ceaace633cf93e9838b185c4a6664c2e /dev-python/wheel/wheel-0.34.2.ebuild
parent9ee6d97c2883d42f204a533a8bc1f4562df778fb (diff)
gentoo resync : 23.09.2020
Diffstat (limited to 'dev-python/wheel/wheel-0.34.2.ebuild')
-rw-r--r--dev-python/wheel/wheel-0.34.2.ebuild32
1 files changed, 0 insertions, 32 deletions
diff --git a/dev-python/wheel/wheel-0.34.2.ebuild b/dev-python/wheel/wheel-0.34.2.ebuild
deleted file mode 100644
index 80c4b19e4e16..000000000000
--- a/dev-python/wheel/wheel-0.34.2.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python2_7 python3_{6,7,8,9} pypy3 )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="A built-package format for Python"
-HOMEPAGE="https://pypi.org/project/wheel/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-SRC_URI="https://github.com/pypa/wheel/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~m68k ~mips ppc ppc64 s390 sparc x86"
-
-distutils_enable_tests pytest
-
-src_prepare() {
- sed \
- -e 's:--cov=wheel::g' \
- -i setup.cfg || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- distutils_install_for_testing
- pytest -vv || die "Tests failed with ${EPYTHON}"
-}