summaryrefslogtreecommitdiff
path: root/dev-python/whisper/whisper-1.1.5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-01-25 08:09:37 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-01-25 08:09:37 +0000
commit693cc9b6e847a01c1bb692153021aaf9fb0fab25 (patch)
treebb2f7c299a4149f841c37a1208c7ac861aa95640 /dev-python/whisper/whisper-1.1.5.ebuild
parent09351e78166b5e864197c4456ebae3f89dd0bed9 (diff)
gentoo resync : 25.01.2019
Diffstat (limited to 'dev-python/whisper/whisper-1.1.5.ebuild')
-rw-r--r--dev-python/whisper/whisper-1.1.5.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/whisper/whisper-1.1.5.ebuild b/dev-python/whisper/whisper-1.1.5.ebuild
new file mode 100644
index 000000000000..6d5870e8d76c
--- /dev/null
+++ b/dev-python/whisper/whisper-1.1.5.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{3,} python{2_7,3_{4,5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="https://github.com/graphite-project/whisper"
+# PyPI tarballs don't contain tests
+# https://github.com/graphite-project/whisper/pull/253
+SRC_URI="https://github.com/graphite-project/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~x64-solaris"
+SLOT="0"
+IUSE="test"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ virtual/python-unittest-mock[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ py.test || die "tests failed with ${EPYTHON}"
+}