summaryrefslogtreecommitdiff
path: root/dev-python/whisper/whisper-1.1.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /dev-python/whisper/whisper-1.1.7.ebuild
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'dev-python/whisper/whisper-1.1.7.ebuild')
-rw-r--r--dev-python/whisper/whisper-1.1.7.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/whisper/whisper-1.1.7.ebuild b/dev-python/whisper/whisper-1.1.7.ebuild
new file mode 100644
index 000000000000..201d0c86240a
--- /dev/null
+++ b/dev-python/whisper/whisper-1.1.7.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6,7,8,9} )
+inherit distutils-r1
+
+DESCRIPTION="Fixed size round-robin style database"
+HOMEPAGE="https://github.com/graphite-project/whisper"
+# PyPI tarballs don't contain tests
+# https://github.com/graphite-project/whisper/pull/253
+SRC_URI="https://github.com/graphite-project/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+KEYWORDS="~amd64 ~x86 ~x64-solaris"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+#python_test() {
+# py.test || die "tests failed with ${EPYTHON}"
+#}