summaryrefslogtreecommitdiff
path: root/dev-python/whoosh
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-16 00:09:44 +0100
commit0a3feeaba4dbc58966dccdbbfcd7fb14deef0831 (patch)
treed48a200142b883af377722ab54ec0c1d8c19912f /dev-python/whoosh
parent6a7029e0f7370d4d5dfe9e31cc2719a870482392 (diff)
gentoo auto-resync : 16:06:2024 - 00:09:44
Diffstat (limited to 'dev-python/whoosh')
-rw-r--r--dev-python/whoosh/Manifest2
-rw-r--r--dev-python/whoosh/whoosh-2.7.4-r2.ebuild11
2 files changed, 8 insertions, 5 deletions
diff --git a/dev-python/whoosh/Manifest b/dev-python/whoosh/Manifest
index 350341f4fd92..d9c37db45e17 100644
--- a/dev-python/whoosh/Manifest
+++ b/dev-python/whoosh/Manifest
@@ -1,4 +1,4 @@
AUX whoosh-2.7.4-tests-specify-utf8.patch 319 BLAKE2B b889ccda8723208af56659616ead64b1779c1bd96abff594a099ddeaa9aac3be86603dd0825507b30a900f38d80b184dfdbddfa42087969ec7fbce43cc8c1617 SHA512 53dc8336ac9895659d92001cb22137011d9da753c299bc3fecd34ed6b42f0f169967dfd41b0403462e54e62af1f6390c58386a91a89ddc880a4fe0a4e05ce14b
DIST Whoosh-2.7.4.tar.gz 968741 BLAKE2B 698ec603eb1201f2b1a934785f84108cb5d91114c9a4e1943cfcd2c8c878f7fb0a0868d54d3a11f8aa30890179c555bdc11cbf34962f5f4781c6d43a090ba872 SHA512 7cdefdcf52b704ffe50c00718c42677e2ddfe879f81ad2d14b580b0e026cc0ebb6b9ddc99d8709eaff4eb9b83f654b042c8792821e1ed90aa85cfa6f82845074
-EBUILD whoosh-2.7.4-r2.ebuild 994 BLAKE2B f0f12cb13bb8b0c629866fbac1752ad662053f173714dc8a51f88094c7c06a1c89c835ddb7d2d23b66c2cb0afdb762afc1e4dbd4d14d02a5fc162f6bdc0f9cc5 SHA512 055467e68db9cd34952fc88e4771a277132c1f7871ef1239a6641fd237a3b205724f0f46ae2c43c009abf780a42e76762f4667f64034f352ee54c51293e84532
+EBUILD whoosh-2.7.4-r2.ebuild 983 BLAKE2B f53700948062e4c0aafff5dff9357a52a1e4d40c1648c48132b477b8354bd6c5fa15051d7b00730a685c4f4437f0ba9e46d16ac0a0a269d251440e8fb5594e51 SHA512 3ed2aaf811a0d6fdacdeadbf9b2585bab12cf0acb2bdec36433e5b7ac412dbcbf9bb190a304f69279001b8c5f9041d72051ec1ae4166ab55dbe79da1f98395ac
MISC metadata.xml 726 BLAKE2B db87e24c05f168e3fa7400152a63f1eeb9b95626e07619ececa06e8bacc493666623b144d665e1db431b060e30156d228145b1fa5bd78b4e8e80e2fcc5971784 SHA512 702f2d0c6bd5df4fbb5ee1841422129bc63ffa6674779e9e43c8b9120a3b54367eb9a426615e998163dd7351f0da587a172f51e8241f22b28cdb72e4cb2f8325
diff --git a/dev-python/whoosh/whoosh-2.7.4-r2.ebuild b/dev-python/whoosh/whoosh-2.7.4-r2.ebuild
index 8b2f267ea928..4e4aa79962dc 100644
--- a/dev-python/whoosh/whoosh-2.7.4-r2.ebuild
+++ b/dev-python/whoosh/whoosh-2.7.4-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -6,7 +6,7 @@ EAPI=8
DISTUTILS_USE_PEP517=setuptools
PYPI_NO_NORMALIZE=1
PYPI_PN=${PN^}
-PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
inherit distutils-r1 pypi
DESCRIPTION="Fast, pure-Python full text indexing, search and spell checking library"
@@ -26,13 +26,16 @@ PATCHES=(
distutils_enable_sphinx docs/source
distutils_enable_tests pytest
+EPYTEST_DESELECT=(
+ # TODO
+ tests/test_automata.py::test_minimize_dfa
+)
+
python_prepare_all() {
# (backport from upstream)
sed -i -e '/cmdclass/s:pytest:PyTest:' setup.py || die
# fix old section name
sed -i -e 's@\[pytest\]@[tool:pytest]@' setup.cfg || die
- # TODO: broken?
- sed -i -e 's:test_minimize_dfa:_&:' tests/test_automata.py || die
distutils-r1_python_prepare_all
}