summaryrefslogtreecommitdiff
path: root/dev-python/widgetsnbextension/widgetsnbextension-4.0.14.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-04-11 08:43:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2025-04-11 08:43:59 +0100
commitbb59556b3302a941db4630613c604644d5f7a617 (patch)
tree42e60b7ae227b0fe3af52dfac08d59653066a2db /dev-python/widgetsnbextension/widgetsnbextension-4.0.14.ebuild
parent3cd09a18bad26aad2645241b868755cfdf41b6ae (diff)
gentoo auto-resync : 11:04:2025 - 08:43:58HEADmaster
Diffstat (limited to 'dev-python/widgetsnbextension/widgetsnbextension-4.0.14.ebuild')
-rw-r--r--dev-python/widgetsnbextension/widgetsnbextension-4.0.14.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/widgetsnbextension/widgetsnbextension-4.0.14.ebuild b/dev-python/widgetsnbextension/widgetsnbextension-4.0.14.ebuild
new file mode 100644
index 000000000000..a4a540b5c3fd
--- /dev/null
+++ b/dev-python/widgetsnbextension/widgetsnbextension-4.0.14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 pypy3_11 python3_{10..13} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="IPython HTML widgets for Jupyter"
+HOMEPAGE="
+ https://ipython.org/
+ https://pypi.org/project/widgetsnbextension/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86 ~amd64-linux ~x86-linux"
+
+BDEPEND="
+ dev-python/jupyter-packaging[${PYTHON_USEDEP}]
+"
+
+src_install() {
+ distutils-r1_src_install
+
+ mv "${ED}/usr/etc" "${ED}/etc" || die
+}