summaryrefslogtreecommitdiff
path: root/dev-python/wrapt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-10-18 04:04:23 +0100
commit483d7c056fba15727fe24545f93627a1d1e1e2eb (patch)
tree80d144b60f8e1dc0d14c15cb3e5950da12c80074 /dev-python/wrapt
parent8796aaedb3257bbe4d80b0033408b2210b2259d6 (diff)
gentoo auto-resync : 18:10:2024 - 04:04:23
Diffstat (limited to 'dev-python/wrapt')
-rw-r--r--dev-python/wrapt/Manifest2
-rw-r--r--dev-python/wrapt/wrapt-1.17.0_rc1.ebuild40
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index 7cd4a53824e1..5ca6b6c2c6f6 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -1,4 +1,6 @@
AUX wrapt-1.16.0-py313.patch 4564 BLAKE2B 84cec43af7738320fa6ae9d804557594eb43e71f5a42fbfc3bb2a2c84c236b7c0556176d171d0faf16e767f5c45c300f7e1da41d2c987ca1a7c8221a5ff1e793 SHA512 cf913c8b5105f50219c59bb8b1eba2fdbee39ff731cd48aeb4a4aab11864421f874ec86d8c91fdf97d6a74df24117f093c936e6ec14286910ab6cfe284e292b5
DIST wrapt-1.16.0.gh.tar.gz 138520 BLAKE2B 6317f2fa58aaa017b510f60fb20e8b3bc4721977806f4b8e7a3f316bfa4da2a8d24156f8ab670d96f5bab6fcc29437d5d18c28ce91618f5a7093cc85d6c5b578 SHA512 65bdda3b6580748ceb720e8fc1a6b05832a355d541aa650bc87052f3aa8793d03d29a080b79eceb16392e297aed8f11a283e36f5f40a0db614b409b1dc2b6c9c
+DIST wrapt-1.17.0rc1.gh.tar.gz 140545 BLAKE2B 825b6c4e8d22af404ea0e0e586542be9ef8a302389ba683548e41d93adb2afdd33e61269a2d4d9a832eedc8d48c4a96076ac14d44d3c9617c241cf76910ee753 SHA512 833ba6a8e07b610bdf830bd6c1cac9140a94f35a18f19ea5aa52c3673323e11ce15f302cc38c1ed12d7f24c220540f30c43a8186bda6bb42609f68774cd8409b
EBUILD wrapt-1.16.0.ebuild 1069 BLAKE2B 381b6cc955dc9a825fc201eb06a4472ef365e53275e43d87d91f89dc6a7f34a9b06ccd28da0bcc531ecf08024ef79df09e015dfd5521023967a4a384ff9233de SHA512 541a92e917090d81072cb66d394a1731f8c8fb0e3d9ee431c2147d361ac9f6fb99d01d232dcf180d2e922cc4fb1880221db1ad1688b388b8af7676a99e6bc302
+EBUILD wrapt-1.17.0_rc1.ebuild 979 BLAKE2B b9379e5c46c6f232a59de950a6ed61c1a1c895dfe5e0af436a05f9ea50036e76cb5df8be4ad5de0d1b1000f4ea5aa5a11a77b571cc500f852534e0b217155af0 SHA512 e98c95a1cdca33c83e147440730943726cd0691c1844727146b12a741f48cf57dffa3ea9f8f3c49e9d6bea1a0f3d70d545f3fefe0e03be5ba2cdae99b32b9235
MISC metadata.xml 515 BLAKE2B 9a7eb633f7a52c3bb378854a89d8b529adfb09f4db96502875da844c4d256aa1ca2346831be3f7949894045d9185df284a7b50c142a22b1340676d079913abf6 SHA512 f260a2482e32147b1a052b949f1b438efcb406b52caad79951b60cd79c330dacc5c612269b80c730c489a9b2896c4d91572796409bbceabc36a83c056522cac2
diff --git a/dev-python/wrapt/wrapt-1.17.0_rc1.ebuild b/dev-python/wrapt/wrapt-1.17.0_rc1.ebuild
new file mode 100644
index 000000000000..10b0cdd3eb23
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.17.0_rc1.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} pypy3 )
+
+inherit distutils-r1
+
+MY_P=${P/_}
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="
+ https://github.com/GrahamDumpleton/wrapt/
+ https://pypi.org/project/wrapt/
+"
+SRC_URI="
+ https://github.com/GrahamDumpleton/wrapt/archive/${PV/_}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+IUSE="+native-extensions"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx-rtd-theme
+
+python_compile() {
+ local -x WRAPT_INSTALL_EXTENSIONS=$(usex native-extensions true false)
+ distutils-r1_python_compile
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest
+}