summaryrefslogtreecommitdiff
path: root/dev-python/wrapt
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-02-02 01:39:05 +0000
commitfcc5224904648a8e6eb528d7603154160a20022f (patch)
tree3bfce096b38a9cea8eed13fc70c1526c456e9abd /dev-python/wrapt
parent2fd57282f0262ca084e05b0f2c63fbada395d02b (diff)
gentoo resync : 02.02.2022
Diffstat (limited to 'dev-python/wrapt')
-rw-r--r--dev-python/wrapt/Manifest1
-rw-r--r--dev-python/wrapt/wrapt-1.13.2-r1.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/dev-python/wrapt/Manifest b/dev-python/wrapt/Manifest
index 074c64026c07..031f5433d38a 100644
--- a/dev-python/wrapt/Manifest
+++ b/dev-python/wrapt/Manifest
@@ -2,5 +2,6 @@ AUX wrapt-1.12.1-py39.patch 8250 BLAKE2B d3f40b0ef14dc61a12b4e386d1b14b5f5d7f944
DIST wrapt-1.12.1.tar.gz 126750 BLAKE2B 92aba2d400aa626445be68fdda2831132e1c341a2f20065b3d7071a2ebc174cb9de7e6a20a8375360cf7df181881fd20b7b2f70dbfdf533e8823982eeaa722f5 SHA512 33e964cb3aa2437bc7d084a98f622f7c5c8c719d97806796ae0317d35130bdb2679a9dd87be7077e2cae1eb32b65d152349fa7cc138cb392d5999cbfdcecc9ac
DIST wrapt-1.13.2.tar.gz 130624 BLAKE2B 7ad74653208042326630ae4464494fcdd5299b35a42d495a16a3cbd68bb60fe5ea17f3e95eac85d98142fe339a593a8cda7e3182ce2a6e96f6ba2bb204a1fc46 SHA512 14648465745af7972ffd449783a24a4b5bf8187cbee517d3427825409bd5d073e3153a0c61f5583b84fc6ca2c48479ebf112977ce340369019a617559d09dfc0
EBUILD wrapt-1.12.1.ebuild 765 BLAKE2B 54e2d2d3ce53c7c234f48b305bcfd1c0b1c2a4ea00697816871580dc5347f428af4729ba5f7c280e31420ea88221a640430b8e98472ebf2ab85da2ed882e6253 SHA512 0ec5d5a96394877bc7a29b7feedf13a203d7d0c8282d3f452c70a9026234f6888187756232a98e94bb90c459c2d9c90de9000722bb692fa70e826bea8518d640
+EBUILD wrapt-1.13.2-r1.ebuild 739 BLAKE2B c18e0245ab4a9998c09495ecdf4cafb477bfa0efd781a1af3d8c0eb4da077b0e48fc68b689cd6d3cc494f64269c4b674496522190f7d8a3f28b89c0d791ac027 SHA512 6a686f352fd59cf3f94f97f99e36d9dcdbee51b5d0f9f8b441034c879f7ba02760b1eb4ed994f5c408da4cdcf6b9e293d7f793abf1ddf9d17b1cbf46897222ec
EBUILD wrapt-1.13.2.ebuild 698 BLAKE2B 6bdb354ede6b31faf464fd3ef775aabb0884658662fae939d2c0a4d8a06145476c400a3cd125b345ec477b3b4b489cd91801fa4a3baa5add0483f086aa56555b SHA512 c9a91744f730b9184f99e776b4146b79e05c487a54aef71587e62c5fc11b17fc726405dac7b277648f81495a69b172f242d594d8436f529c2368b050bbfe2804
MISC metadata.xml 370 BLAKE2B 251d8c90cd2a0a1b9fbc714b624c7113e9791f268130211160655f4e4e32aadaddaf98a95bb6d9fff5a5df128da9d551b1281a28e4bd7fa6e3c9db7d35b10829 SHA512 31b369317f4a44d593d9fb72bcb9fcb792809323862866da7c3464ca2282e29a65cd353909c05782b85b162cff363b0ad8ea4750d89c942d442034b9a6eb7dba
diff --git a/dev-python/wrapt/wrapt-1.13.2-r1.ebuild b/dev-python/wrapt/wrapt-1.13.2-r1.ebuild
new file mode 100644
index 000000000000..5a6bf40b15a8
--- /dev/null
+++ b/dev-python/wrapt/wrapt-1.13.2-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Module for decorators, wrappers and monkey patching"
+HOMEPAGE="https://github.com/GrahamDumpleton/wrapt"
+SRC_URI="https://github.com/GrahamDumpleton/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-macos"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs dev-python/sphinx_rtd_theme
+
+python_compile() {
+ local WRAPT_EXTENSIONS=true
+
+ distutils-r1_python_compile
+}