summaryrefslogtreecommitdiff
path: root/dev-python/ws4py
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-03-09 16:53:27 +0000
commit80208fb578cf92cc308906660ca6d7860c6b2a1f (patch)
tree6f06818031b553c506fc10dfe9908a835df288aa /dev-python/ws4py
parent06a7b5647e11a8ddf69b1c3d3ded6a8ba28b923e (diff)
gentoo resync : 09.03.2018
Diffstat (limited to 'dev-python/ws4py')
-rw-r--r--dev-python/ws4py/Manifest4
-rw-r--r--dev-python/ws4py/ws4py-0.5.1.ebuild51
-rw-r--r--dev-python/ws4py/ws4py-9999.ebuild10
3 files changed, 59 insertions, 6 deletions
diff --git a/dev-python/ws4py/Manifest b/dev-python/ws4py/Manifest
index b551e717d054..6446faef6814 100644
--- a/dev-python/ws4py/Manifest
+++ b/dev-python/ws4py/Manifest
@@ -1,4 +1,6 @@
DIST ws4py-0.3.4.tar.gz 65467 BLAKE2B c51e338f3c65e100b55e83cd7b09fb8e4eafec3adc118a2744ea4aabc54c91efacda94cb3018550049d617b6759198cfbdb4497a024c597de942abe9e5517ab6 SHA512 32cd2eb9df7367e2bf42e354766a0ca407715a863be6b51b7701ec6e0537a2ecf7c2a59423f56ae093855b075c30a4065c7f7efe3b0227915639223b9ba7a55f
+DIST ws4py-0.5.1.tar.gz 116673 BLAKE2B 31db304800f0d3da61dc4c1a3381a8fcfcfa8f16b36d916311cc32f1d294c9f7b3627dac673edf824f529f485f825ca418ab1e1a8a2fda5583c6a6a1bd9b752c SHA512 4c90d66d37fb5bdc8f7fc9fd184b20a7dc2dae811ecf3a041477e3c26a2577008be7041799daca5b8c0de65cb2454022a6c135cf02534ca98b6946abbfce0e11
EBUILD ws4py-0.3.4.ebuild 1744 BLAKE2B 60b5ecfa1ae1f3732be19b927ea594e4b2c1ffd9a0980365b684ca578f40276f4c5432606b43c9bf2ff841d73d52057fbf600833fcb528c5b3c6639c3129a6dc SHA512 c286aac539f135c63001503cdb1ede1cdb5c589a5871025ff1b445c257fc68859bac8022c13b4bf4b9b43940fabe6786e285f521ea646f5eb10b8f0edc8671e9
-EBUILD ws4py-9999.ebuild 1747 BLAKE2B 53461b85c1514ab41a02a1822052f6f9a06c149a8be18ca1f5c17f4d81292b3b174856bf02fe65a90baa9478c70e20c331c629a0fea402d6d6209f52ececec03 SHA512 e0ae0d6d2dd0bd18a92b37f98c1eb83fdb3c77766c645ff5a94d98cb2e7c1df349067ff5429dda9fc079b2d680750539ed8c13f78fbb956b7d459f29f87017c1
+EBUILD ws4py-0.5.1.ebuild 1757 BLAKE2B 91537d7c377c77209c934fc1bd2cebe54fe8ae6053c2831cfe243fa306ec5a236b9f2ac9fc298ec1dddca03f347ffa327f47e968f90cfe9341bf3ea6662c5905 SHA512 8fb67724223be45dc4da1f9d3e03dfd151029cefa0efd05dfed89bf6ad9808f00bfa458c0abe5fa0c670b97ba318ea753818f7974518a865b09c949c12776c00
+EBUILD ws4py-9999.ebuild 1758 BLAKE2B 47a6b79fe9acbb8b336165f0080806dcf5929596fd95daad03211a398ad34c648e4935dda3a54b11b3fbc9ea33947187a6a279eba3cf8c86a7478b5eff7cee39 SHA512 db3f7a232a93c30bc77bbf1c3840f228ecbe1539499c271c8a4a3ff26b75bf75c3426e07a9292466594b01bceb3df1580367a74ecfae8f00912a77617ab16efd
MISC metadata.xml 469 BLAKE2B 7c2212a53fd485fe5e99a53741f0d828bf09fca7dac40ddd1c0326eebffb1f0fef0c305ac00d61747d6184f3f309e711157f0b715d3fc49694bedabb9f09d513 SHA512 a368692c9de68b711cae8c35305b35e445f47046ecf2226d36d5944be4e8a6d29311c28c6ed74ae794517eb2f20c0b2eeeb0ce33e719029b843c8d23b2e2e838
diff --git a/dev-python/ws4py/ws4py-0.5.1.ebuild b/dev-python/ws4py/ws4py-0.5.1.ebuild
new file mode 100644
index 000000000000..c1c647c9a5e3
--- /dev/null
+++ b/dev-python/ws4py/ws4py-0.5.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+# We could depend on dev-python/cherrypy when USE=server, but
+# that is an optional component ...
+# Same for www-servers/tornado and USE=client ... so why not???
+# pypy is viable but better with a cutdown set of deps
+
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+PYTHON_REQ_USE="threads?"
+
+inherit distutils-r1
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
+ inherit git-3
+else
+ inherit vcs-snapshot
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~x86"
+fi
+
+DESCRIPTION="WebSocket client and server library for Python 2 and 3 as well as PyPy"
+HOMEPAGE="https://github.com/Lawouach/WebSocket-for-Python"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="+client +server test +threads"
+# doc build requires sphinxcontrib ext packages absent from portage
+
+RDEPEND=">=dev-python/greenlet-0.4.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/gevent[${PYTHON_USEDEP}]' python2_7)
+ >=dev-python/cython-0.19.1[${PYTHON_USEDEP}]
+ client? ( >=www-servers/tornado-3.1[${PYTHON_USEDEP}] )
+ server? ( >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}] )"
+DEPEND="test? (
+ >=dev-python/cherrypy-3.2.4[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ # testsuite displays an issue with mock under py3 but is non fatal
+ "${PYTHON}" -m unittest discover || die "Tests failed under ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+ use client || rm -rf "${D}$(python_get_sitedir)"/ws4py/client
+ use server || rm -rf "${D}$(python_get_sitedir)"/ws4py/server
+}
diff --git a/dev-python/ws4py/ws4py-9999.ebuild b/dev-python/ws4py/ws4py-9999.ebuild
index 757d4a7a3ea7..74386cac1ba9 100644
--- a/dev-python/ws4py/ws4py-9999.ebuild
+++ b/dev-python/ws4py/ws4py-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# We could depend on dev-python/cherrypy when USE=server, but
@@ -6,17 +6,17 @@
# Same for www-servers/tornado and USE=client ... so why not???
# pypy is viable but better with a cutdown set of deps
-EAPI="5"
-PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+EAPI="6"
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
PYTHON_REQ_USE="threads?"
inherit distutils-r1
if [[ ${PV} == "9999" ]] ; then
EGIT_REPO_URI="https://github.com/Lawouach/WebSocket-for-Python.git"
- inherit git-2
+ inherit git-r3
else
inherit vcs-snapshot
- SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/tarball/v${PV} -> ${P}.tar.gz"
+ SRC_URI="https://github.com/Lawouach/WebSocket-for-Python/archive/${PV}.tar.gz -> ${P}.tar.gz"
KEYWORDS="~amd64 ~arm ~x86"
fi