summaryrefslogtreecommitdiff
path: root/dev-python/wurlitzer/wurlitzer-3.0.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-02 20:57:17 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-02 20:57:17 +0000
commit9bc9c4dcc38dc560cff8e5d083d1e5f282ddde98 (patch)
treeaebfd3698cdc5ed079dbfd553063a19b4662965d /dev-python/wurlitzer/wurlitzer-3.0.3.ebuild
parentcc2c9e975285d6fb1be1b71d18ba4cca7991b921 (diff)
gentoo auto-resync : 02:12:2022 - 20:57:16
Diffstat (limited to 'dev-python/wurlitzer/wurlitzer-3.0.3.ebuild')
-rw-r--r--dev-python/wurlitzer/wurlitzer-3.0.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/wurlitzer/wurlitzer-3.0.3.ebuild b/dev-python/wurlitzer/wurlitzer-3.0.3.ebuild
new file mode 100644
index 000000000000..5c0e6bfb4973
--- /dev/null
+++ b/dev-python/wurlitzer/wurlitzer-3.0.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+inherit distutils-r1
+
+DESCRIPTION="Capture C-level stdout/stderr in Python"
+HOMEPAGE="
+ https://github.com/minrk/wurlitzer/
+ https://pypi.org/project/wurlitzer/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest test.py
+}