summaryrefslogtreecommitdiff
path: root/dev-python/xarray/xarray-2023.10.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-29 09:35:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-10-29 09:35:43 +0000
commit704343381e435b306648a2d85a77a58e34478643 (patch)
tree009e24c29e03885a4bd7bb17b673f62567395237 /dev-python/xarray/xarray-2023.10.1-r1.ebuild
parenteb147001d2176fe9850e42017a6b1284baf865ff (diff)
gentoo auto-resync : 29:10:2023 - 09:35:42
Diffstat (limited to 'dev-python/xarray/xarray-2023.10.1-r1.ebuild')
-rw-r--r--dev-python/xarray/xarray-2023.10.1-r1.ebuild23
1 files changed, 22 insertions, 1 deletions
diff --git a/dev-python/xarray/xarray-2023.10.1-r1.ebuild b/dev-python/xarray/xarray-2023.10.1-r1.ebuild
index 2acfcd5dc6b8..e25ad9fd6048 100644
--- a/dev-python/xarray/xarray-2023.10.1-r1.ebuild
+++ b/dev-python/xarray/xarray-2023.10.1-r1.ebuild
@@ -17,7 +17,8 @@ HOMEPAGE="
LICENSE="Apache-2.0"
SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~riscv ~sparc ~x86"
+IUSE="big-endian"
RDEPEND="
>=dev-python/numpy-1.22[${PYTHON_USEDEP}]
@@ -58,5 +59,25 @@ EPYTEST_DESELECT=(
python_test() {
local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ if ! has_version ">=dev-python/scipy-1.4[${PYTHON_USEDEP}]" ; then
+ EPYTEST_DESELECT+=(
+ 'xarray/tests/test_missing.py::test_interpolate_na_2d[coords1]'
+ )
+ fi
+
+ if use big-endian ; then
+ EPYTEST_DESELECT+=(
+ # Appears to be a numpy issue in display? See bug #916460.
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145224193-ns-int64-20-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1970-09-21T00:12:44.145224808-ns-float64-1e+30-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145225216-ns-float64--9.223372036854776e+18-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145224193-ns-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145225-us-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1970-01-01T00:00:01.000001-us-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:21:52.901038080-ns-float32-20.0-True]'
+ )
+ fi
+
epytest -p xdist.plugin -n "$(makeopts_jobs)" --dist=worksteal
}