summaryrefslogtreecommitdiff
path: root/dev-python/xarray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-10-25 02:45:51 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-10-25 02:45:51 +0100
commit237ad05f4a374a9f1707c3413a5094a6ce93e7ab (patch)
tree4e147c642dea57b55f5219109ecce4757a022f4b /dev-python/xarray
parent342922f04a58a969ff23806acc427c7ff79119ce (diff)
gentoo auto-resync : 25:10:2023 - 02:45:51
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest1
-rw-r--r--dev-python/xarray/xarray-2023.10.1-r1.ebuild62
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index bfc41da12f93..63d41c65a696 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -2,6 +2,7 @@ DIST xarray-2023.10.1.tar.gz 3796343 BLAKE2B 8c4bcccf977bf22dcb7495a35b507b113cf
DIST xarray-2023.7.0.tar.gz 3725483 BLAKE2B 814af19a4c24eb0179441d07bcd6165dee2ed5430a6fd94f4014387b7b7fd4ae250b64124bdda8ca411124ab2276075af65bde2a3ed3dc6d081dd466a485007e SHA512 88863770b22978ba681a2d970453ae087a234fcfb68f047b6020b39841a91207e8d92e01486d58bbeadac8d14608aa0c744ee9b6d54890f52fe3537b28292239
DIST xarray-2023.8.0.tar.gz 3757528 BLAKE2B f94bcf90ee06273e82400f4786af97d5cf0db32ff4070929863d5072056fa4e0a33feaf3d378d9d67eed61f349df3ac96efcd1bb3b455043e01af0abf96bb6b3 SHA512 1d712e9fbf266906ac35c199eead77cec76ba5b4b4462140bef2fffd227a52d2cba9670a042cb669b0567320e9308bf81fe4e84c1cfcff234ad2332d72e895a3
DIST xarray-2023.9.0.tar.gz 3776743 BLAKE2B 38433f7898db2b53f31db134b110fea743ea5886c33f8f8390b85cda18c1a1d7d178681e4e442ecc39f2f19ae4b761f94b38ccab27e8e20c3463f4364f1222dd SHA512 d6c1e6ff438415766dedada5841413b9c7514dc2b1bf71a4adb17df4d78b68f5f22cded09c20511e4e2e85ac3284c447fc13191397b7ae77d1294d7867e3ac3f
+EBUILD xarray-2023.10.1-r1.ebuild 2100 BLAKE2B c25e6d9a2873bdbd2555d14868b966579e80e9aaa72bce58ff250cc3d935f1f052c145372050acb0fbcab8d291e7cf300ae77e227462d5bc44d22bd8f4ccb1fd SHA512 cfdfa701521f6e7c33bb6e0d3bf7d6d1b0357656cc7e185e10a1ce69ff64f6aaed5165575c95e8c51b90efdcc70bb44cfd49efb36f2ece337d932f41dc4a7e06
EBUILD xarray-2023.10.1.ebuild 2161 BLAKE2B 678f1511363c270bac10f3205c5296417e348c856f2fe813be2b6f62475d804f0b10e32737075d8c5c791b7229907d7e84dbd23a2872a008fd293f4db2287917 SHA512 407a9740240bb506474405e3487cac8c78a70d159bf0ad89840e87ec3db66a886099b930c9cdabc343301b832e9e638f958bdff6c53c97b7d515ddb32be3227b
EBUILD xarray-2023.7.0.ebuild 1907 BLAKE2B 481fda79294db9c840b8c305f53932add621a349b7280c99a844ddcd06094501b26800f59accbc5d14c73e1bd8b6a3b2c93d5d24b5990c9470b0af2efc393bc4 SHA512 3c4eae63b5b799345cbdf5204be00bce6f29546f396cecc7e5aadb6700973f6fe92c96d0a75e1215cc7a90de9726b5373edae57b1e5ef7d48c58399fcd75eb58
EBUILD xarray-2023.8.0.ebuild 2157 BLAKE2B 93efdab515a5ce1e15394ae8d37a7b1513010ce9423dc459d63547775a20e94b24009ec21cbae173514b8849886a544b4634881bf1a772713ebc14fa9221717a SHA512 8dcc6b942f26281e417c4a2e309f8f1bde22c764a04a3e7fcca0294769a30fc1eef6b33ae289728207fbee3c2ff4a5805ec0f385c3272c5751fc62e188adbf81
diff --git a/dev-python/xarray/xarray-2023.10.1-r1.ebuild b/dev-python/xarray/xarray-2023.10.1-r1.ebuild
new file mode 100644
index 000000000000..2acfcd5dc6b8
--- /dev/null
+++ b/dev-python/xarray/xarray-2023.10.1-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~x86"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ # TODO: segv in netcdf4-python
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
+ xarray/tests/test_backends.py::TestDask::test_save_mfdataset_compute_false_roundtrip
+ # hangs
+ xarray/tests/test_backends.py::TestDask::test_dask_roundtrip
+ # mismatches when pyarrow is installed
+ # https://github.com/pydata/xarray/issues/8092
+ xarray/tests/test_dask.py::TestToDaskDataFrame::test_to_dask_dataframe_2D
+ xarray/tests/test_dask.py::TestToDaskDataFrame::test_to_dask_dataframe_not_daskarray
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -p xdist.plugin -n "$(makeopts_jobs)" --dist=worksteal
+}