summaryrefslogtreecommitdiff
path: root/dev-python/xarray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-18 17:04:41 +0000
commit6cdde4bf2702fac82ba7163fe9f922e7fa0b9a66 (patch)
tree876fe918d1abfd24cf9323208d2929b94a47cfc7 /dev-python/xarray
parentce89e807ecd2194613ad6e6bcee8cf95e982ad1a (diff)
gentoo auto-resync : 18:11:2023 - 17:04:41
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest2
-rw-r--r--dev-python/xarray/xarray-2023.11.0.ebuild83
2 files changed, 85 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index c77785085136..b88c54e983b0 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,6 +1,8 @@
DIST xarray-2023.10.1.tar.gz 3796343 BLAKE2B 8c4bcccf977bf22dcb7495a35b507b113cf888819c202f4bdd90fb0146b1a8c75d79337f7dedad5d248330a2cc2dcfb07dae4faa60d90e611e1418be530c2ee4 SHA512 1fe193fc2fbd31d7478bd3152f8322f0c20e312518d1f607b483d2b9c3c19d84fb175319fa55fc01d5da13ee471c60c1976617e33760d10168d6fc7b556aeac4
+DIST xarray-2023.11.0.tar.gz 3800529 BLAKE2B 45b54588e3178c5104f40741cf2a3cb6403a0ab199ad1b24a6b2da9cb19649184ba4ca516d54002753ba62c7df6e80dde3b25c68cd63d65dd076b412219de3bc SHA512 fe84884b9147683d61d68233c703d07617f61638d84e28f94c9b9f1fdddf942c563af20a15c6d765b0ff169fe0985d74d7cb4d35d42c3988f62263e55e3e9071
DIST xarray-2023.9.0.tar.gz 3776743 BLAKE2B 38433f7898db2b53f31db134b110fea743ea5886c33f8f8390b85cda18c1a1d7d178681e4e442ecc39f2f19ae4b761f94b38ccab27e8e20c3463f4364f1222dd SHA512 d6c1e6ff438415766dedada5841413b9c7514dc2b1bf71a4adb17df4d78b68f5f22cded09c20511e4e2e85ac3284c447fc13191397b7ae77d1294d7867e3ac3f
EBUILD xarray-2023.10.1-r1.ebuild 3396 BLAKE2B dde22ebb0e1d2b2ec9b0d4cc0423e36e201660d5d854f133df05feaa8842162e3373c4e5710719bef7b0ad1d3be55712504a41869665cf189f547505d57981e6 SHA512 6862761b7c01904fadba146c585059791809ea0951cf9d462a7d512c1670763b74c617486e2e14d713696909cfd41756c91574ab476fa6778b29d3735b4194ed
EBUILD xarray-2023.10.1.ebuild 2161 BLAKE2B 678f1511363c270bac10f3205c5296417e348c856f2fe813be2b6f62475d804f0b10e32737075d8c5c791b7229907d7e84dbd23a2872a008fd293f4db2287917 SHA512 407a9740240bb506474405e3487cac8c78a70d159bf0ad89840e87ec3db66a886099b930c9cdabc343301b832e9e638f958bdff6c53c97b7d515ddb32be3227b
+EBUILD xarray-2023.11.0.ebuild 3297 BLAKE2B 0a8f6fce475bd2cc2f6c5078def670ac347f0a550afafa4002cdc0bb23f022c022a5e3e0a4dee7708994346f56d5f8dc27f95ae0e821afa3f828118075c1d246 SHA512 7d1068944255051ffdedc94456d48223dcef108c9e52a002f3ea440d2ac122ab37388e717b84e6d3aa33464ebbad6ff8dbd2b774c83bc197fe693852db65358f
EBUILD xarray-2023.9.0.ebuild 2156 BLAKE2B a383efc4e5cb2c95f9b29afd0da35c2542f60d0445b974a707215cecfdfa1032536cf62f5b52d40cfe6ed3cc35de2ccdce3357c2c86c682902eb56043f2009b5 SHA512 75bf7fde06b2ac525ddc5b4ac61a2a1314fb7ae4ea240632635d3d519a39695738df5bb3123dd3b8c06150bbfc9327191d6c9a02a215d15c244adce458c0a3a1
MISC metadata.xml 509 BLAKE2B d470cc092eb055215a5868c22f9ec458057cfad600357fa1f658ed4537a6a6f68bda1422c4a665f1963ce0a6049e691befc3ca4baa60cc898364ad5f18164979 SHA512 602755896a3655295058afc8543a4bb64192d5c625f2edd86291c1f23d171f051a4238466163c2d469874aff3e68770fc76177e720870492266fb14e6faf6ce7
diff --git a/dev-python/xarray/xarray-2023.11.0.ebuild b/dev-python/xarray/xarray-2023.11.0.ebuild
new file mode 100644
index 000000000000..e158ce05a4de
--- /dev/null
+++ b/dev-python/xarray/xarray-2023.11.0.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~riscv ~sparc ~x86"
+IUSE="big-endian"
+
+RDEPEND="
+ >=dev-python/numpy-1.22[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.4[${PYTHON_USEDEP}]
+ >=dev-python/packaging-21.3[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ # TODO: segv in netcdf4-python
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
+ xarray/tests/test_backends.py::TestDask::test_save_mfdataset_compute_false_roundtrip
+ # hangs
+ xarray/tests/test_backends.py::TestDask::test_dask_roundtrip
+ # mismatches when pyarrow is installed
+ # https://github.com/pydata/xarray/issues/8092
+ xarray/tests/test_dask.py::TestToDaskDataFrame::test_to_dask_dataframe_2D
+ xarray/tests/test_dask.py::TestToDaskDataFrame::test_to_dask_dataframe_not_daskarray
+)
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ if ! has_version ">=dev-python/scipy-1.4[${PYTHON_USEDEP}]" ; then
+ EPYTEST_DESELECT+=(
+ 'xarray/tests/test_missing.py::test_interpolate_na_2d[coords1]'
+ )
+ fi
+
+ if use big-endian ; then
+ EPYTEST_DESELECT+=(
+ # Appears to be a numpy issue in display? See bug #916460.
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145224193-ns-int64-20-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1970-09-21T00:12:44.145224808-ns-float64-1e+30-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145225216-ns-float64--9.223372036854776e+18-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145224193-ns-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145225-us-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1970-01-01T00:00:01.000001-us-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:21:52.901038080-ns-float32-20.0-True]'
+ )
+ fi
+
+ epytest
+}