summaryrefslogtreecommitdiff
path: root/dev-python/xarray
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-19 17:39:35 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-19 17:39:35 +0000
commit9aa795a0179b29f7489bd04584bc8d2914da467b (patch)
treee628e5bd3419ed93917cff26165964b8d82064f6 /dev-python/xarray
parentfac3cfaabc3c46bf5cb7a2492197925c7c557b42 (diff)
gentoo auto-resync : 19:02:2024 - 17:39:34
Diffstat (limited to 'dev-python/xarray')
-rw-r--r--dev-python/xarray/Manifest2
-rw-r--r--dev-python/xarray/xarray-2024.2.0.ebuild91
2 files changed, 93 insertions, 0 deletions
diff --git a/dev-python/xarray/Manifest b/dev-python/xarray/Manifest
index 25c0a59d3f4e..0a657e651e3f 100644
--- a/dev-python/xarray/Manifest
+++ b/dev-python/xarray/Manifest
@@ -1,6 +1,8 @@
AUX xarray-2024.1.1-pytest-8.patch 3537 BLAKE2B fad48831eb697cf3d6f36eda1b96e160deaf35a158c39292f6fe566ad80a6c37290c918392e75d120110538515cd7e2714fda7dfc5f10cb9e78832ba7a2be330 SHA512 8be5a6efa52a6914dddf1e20e0553359d894eb9a365bdc4dd027ea0412a64418631b58ad3d809494065ef61253d22aad2fd528ba8a193ee5e9905ba9dffb0a38
DIST xarray-2024.1.0.tar.gz 3612457 BLAKE2B 53c99ade060ee9aafb9ff1416ab50e27271a5c45c06b8bda5183757b64694eea8649ae9515261112926aa872364c7a9349fb874114b82d5c7221d4d6104feb23 SHA512 1a5c184e6547e867076cd4faf533476608de13c4cfdb7085362e93c974598ea29d42c8fa55374b4782cc36ab7d870d4b7174217b3854db367ae16772e7f37cc8
DIST xarray-2024.1.1.tar.gz 3614037 BLAKE2B cc50fbfa19a2c9229b85b8c7d5d0e7e7f6d3e5a484955fcc81aa0b37839a0b992d2c2f928e4097ca05c7b8294ed1061fbd0c1b7e7c65c9087a940dab97c520ce SHA512 b6447ca2c80b3a3091ac2baba648fef4faa79ffff272360e9726b318b517ede9d2717d1b6f77f03fdacf55527233f1a37c0d114901fe1a265d3e435cf293a487
+DIST xarray-2024.2.0.tar.gz 3634288 BLAKE2B 8d1165360300da5af6d670947e5280052a3d8915768e02448b86ab38283d6d45258a2c4eb91982ba732ccedb3a7afc5f274116c9ee0072d35cdc5631b8a2ca50 SHA512 dcfe6d1f0edab8659664c5399b96d622d2e3df2f85bb7672d9afab6f74294a6449772efde080aaa7323f733c09cbd0f6f037e547be0afa79f39450eead777828
EBUILD xarray-2024.1.0.ebuild 3434 BLAKE2B 3ae3dfd236de77bd785432a6bbad30f4ae0c9e533f18d8e2177cf48e028d7f0ad5957e339162d4935ce6004b4007e831dfa5c9fbafec24000dcbdca23739aeb0 SHA512 386ce4c14867e050cb7765d1c0ad01f6d26dc72cdd9d2570e4da76d167b4c75f7a62d6406f700aee7dd36fd59d78e2cf55a4bbacd46f0f0756fd4bba59cdb442
EBUILD xarray-2024.1.1.ebuild 3554 BLAKE2B 47dcc42c080ca69c0d160524c7cd4bee6d7c7bb563302ca1060892d28cd6d55d38e4ff887b52db3a8bcb0a069ef1e688fd4f2aaa658a2ae4a8637a54fdd7e430 SHA512 ba0561337c4859775d34c7f91837ecad463a8b46819ea9b2827528f941a28e398da681900d5cb52a68cbf141099c65a9d84fc62e0700f0ffa16d4654d3586dfc
+EBUILD xarray-2024.2.0.ebuild 3629 BLAKE2B 3c2bc96f11d84192ce510b474d624d2697a393096fad623b4e8d0c62de05863386602c372797c0502ca8ef9ab1c0e926cddb658b7c5941408d4fc7e07c2cab72 SHA512 0b388e664a4694992f690ca9175c7c335cb99f5e50ebc1890149e30e2a996ea4364290d03fe74bcebff3b9d0e56c00bcb870e1447e3fe7b25f07f2ca20d767fa
MISC metadata.xml 509 BLAKE2B d470cc092eb055215a5868c22f9ec458057cfad600357fa1f658ed4537a6a6f68bda1422c4a665f1963ce0a6049e691befc3ca4baa60cc898364ad5f18164979 SHA512 602755896a3655295058afc8543a4bb64192d5c625f2edd86291c1f23d171f051a4238466163c2d469874aff3e68770fc76177e720870492266fb14e6faf6ce7
diff --git a/dev-python/xarray/xarray-2024.2.0.ebuild b/dev-python/xarray/xarray-2024.2.0.ebuild
new file mode 100644
index 000000000000..177406558283
--- /dev/null
+++ b/dev-python/xarray/xarray-2024.2.0.ebuild
@@ -0,0 +1,91 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="N-D labeled arrays and datasets in Python"
+HOMEPAGE="
+ https://xarray.pydata.org/
+ https://github.com/pydata/xarray/
+ https://pypi.org/project/xarray/
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="big-endian"
+
+RDEPEND="
+ >=dev-python/numpy-1.23[${PYTHON_USEDEP}]
+ >=dev-python/pandas-1.5[${PYTHON_USEDEP}]
+ >=dev-python/packaging-22[${PYTHON_USEDEP}]
+"
+# note: most of the test dependencies are optional
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+ test? (
+ dev-python/bottleneck[${PYTHON_USEDEP}]
+ dev-python/hypothesis[${PYTHON_USEDEP}]
+ dev-python/matplotlib[${PYTHON_USEDEP}]
+ dev-python/toolz[${PYTHON_USEDEP}]
+ !hppa? ( >=dev-python/scipy-1.4[${PYTHON_USEDEP}] )
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # warning-targeted tests are fragile and not important to end users
+ xarray/tests/test_backends.py::test_no_warning_from_dask_effective_get
+ # TODO: segv in netcdf4-python
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-5-None]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-5]'
+ 'xarray/tests/test_backends.py::test_open_mfdataset_manyfiles[netcdf4-20-True-None-None]'
+ xarray/tests/test_backends.py::TestDask::test_save_mfdataset_compute_false_roundtrip
+ # TODO: broken
+ xarray/tests/test_backends.py::TestNetCDF4Data
+ xarray/tests/test_backends.py::TestNetCDF4ViaDaskData
+ # hangs
+ xarray/tests/test_backends.py::TestDask::test_dask_roundtrip
+ # mismatches when pyarrow is installed
+ # https://github.com/pydata/xarray/issues/8092
+ xarray/tests/test_dask.py::TestToDaskDataFrame::test_to_dask_dataframe_2D
+ xarray/tests/test_dask.py::TestToDaskDataFrame::test_to_dask_dataframe_not_daskarray
+ )
+ local EPYTEST_IGNORE=(
+ # requires datatree_ subpackage that is not part of public API
+ # https://github.com/pydata/xarray/issues/8768
+ xarray/tests/datatree
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+
+ if ! has_version ">=dev-python/scipy-1.4[${PYTHON_USEDEP}]" ; then
+ EPYTEST_DESELECT+=(
+ 'xarray/tests/test_missing.py::test_interpolate_na_2d[coords1]'
+ )
+ fi
+
+ if use big-endian ; then
+ EPYTEST_DESELECT+=(
+ # Appears to be a numpy issue in display? See bug #916460.
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145224193-ns-int64-20-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1970-09-21T00:12:44.145224808-ns-float64-1e+30-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145225216-ns-float64--9.223372036854776e+18-True]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145224193-ns-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:12:43.145225-us-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1970-01-01T00:00:01.000001-us-int64-None-False]'
+ 'xarray/tests/test_coding_times.py::test_roundtrip_datetime64_nanosecond_precision[1677-09-21T00:21:52.901038080-ns-float32-20.0-True]'
+ )
+ fi
+
+ epytest
+}