summaryrefslogtreecommitdiff
path: root/dev-python/xlrd/xlrd-2.0.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-03-20 14:27:17 +0000
commit5bb9ff1ee56d2b5e75e01a7f066d8b0cec84ec02 (patch)
tree66e860a5099bcad013f1cf667255dc372a7c11b3 /dev-python/xlrd/xlrd-2.0.1.ebuild
parent7218e1b46bceac05841e90472501742d905fb3fc (diff)
gentoo resync : 20.03.2021
Diffstat (limited to 'dev-python/xlrd/xlrd-2.0.1.ebuild')
-rw-r--r--dev-python/xlrd/xlrd-2.0.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/xlrd/xlrd-2.0.1.ebuild b/dev-python/xlrd/xlrd-2.0.1.ebuild
new file mode 100644
index 000000000000..af980a3294ce
--- /dev/null
+++ b/dev-python/xlrd/xlrd-2.0.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Library to extract data from Microsoft Excel spreadsheets"
+HOMEPAGE="
+ https://www.python-excel.org/
+ https://github.com/python-excel/xlrd/"
+SRC_URI="
+ https://github.com/python-excel/xlrd/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~sparc-solaris ~x86-solaris"
+
+distutils_enable_tests pytest