summaryrefslogtreecommitdiff
path: root/dev-python/xonsh/xonsh-0.4.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/xonsh/xonsh-0.4.7.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/xonsh/xonsh-0.4.7.ebuild')
-rw-r--r--dev-python/xonsh/xonsh-0.4.7.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/dev-python/xonsh/xonsh-0.4.7.ebuild b/dev-python/xonsh/xonsh-0.4.7.ebuild
deleted file mode 100644
index d6c9310916d2..000000000000
--- a/dev-python/xonsh/xonsh-0.4.7.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python3_{4,5,6} )
-
-inherit distutils-r1 eutils
-
-DESCRIPTION="An exotic, usable shell"
-HOMEPAGE="
- https://github.com/scopatz/xonsh
- https://pypi.org/project/xonsh/"
-SRC_URI="mirror://pypi/${P:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="test"
-
-RDEPEND="
- dev-python/ply[${PYTHON_USEDEP}]
- dev-python/pygments[${PYTHON_USEDEP}]
-"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- )"
-
-python_prepare_all() {
- sed \
- -e "/install_jupyter_hook/s:prefix=prefix:prefix=u\"${ED}/usr\":g" \
- -i setup.py || die
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- nosetests --verbose || die
-}
-
-pkg_postinst() {
- elog "Please install"
- optfeature "Jupyter kernel support" dev-python/jupyter
- optfeature "Alternative to readline backend" dev-python/prompt_toolkit
-}