summaryrefslogtreecommitdiff
path: root/dev-python/zeroconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-11-23 03:02:57 +0000
commit71dd9d29cdaf7cc0ecdb9ea37d128726a941c630 (patch)
tree4eccd905f575579fe47abb8a83bbdb44ceb8c929 /dev-python/zeroconf
parentc7a7ec40cf928d8fc6a8241aa208272c008c7b4d (diff)
gentoo auto-resync : 23:11:2024 - 03:02:56
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest2
-rw-r--r--dev-python/zeroconf/zeroconf-0.136.2.ebuild56
2 files changed, 58 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index ad2f28b18129..0e4d9feba452 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,3 +1,5 @@
DIST zeroconf-0.136.0.tar.gz 238635 BLAKE2B 265dac1aed041d86f81264b5449952695f316cdfd9ff8e594631cd5c5eebad917d32537920308ae62feee7927307a667fdfd3cfd5c182fff08120cba19bbc60e SHA512 835f1e22a92e62efaba055816c962fdea12b80e3a875883da28919e952363ce14dea6b60738a2c199d6e4718c016c00a7dfaa86ee4b20347c69a771515240be3
+DIST zeroconf-0.136.2.tar.gz 238720 BLAKE2B c47bd38a75f01c1e4268c6567a13e664638c05efa1a45ff1593b3d1347e369acd7a284580a02d34f398710f5faf319150c9eca151667dbb6a184bad35f24d4ce SHA512 30e352cfa2c3b7e7c3b9e38d6d1db0471d1f2c7dcd6785b0aab63a1027da21e966565803d4b2bfde6a89d4362039165f19b5c179117128a992f4960af2ac031d
EBUILD zeroconf-0.136.0.ebuild 1409 BLAKE2B bc29d08b2a93901ce889dd094b144328333ffdf940e84971e0c78b24bd0f4330de4a95c2d05a04d20d702f69c15d31d4b76b2022f52197614ddbb25b12b67816 SHA512 4b338e29e336ad205806358794762adb29083aad3d64e1b19950d7a9d2f042c6e59d683b066e84054105c0122295c5d89f559d73deaabe711c4146aa4c0c94d3
+EBUILD zeroconf-0.136.2.ebuild 1412 BLAKE2B 7b3c132c3f717e491569ec8e914c8cd75f24ab3c382515b6d48d8e2beb47a485d28ba1ffa5e96c2bac5c979301efb6479bc52bd916978e654c45e90b15ad7f3a SHA512 973114e5a9cdd60cb595528bfb0f761ec4ed46b162d0bf914933e6fcaf46f6c4d4eb822d94aa56593a4e52ce19eca467c329bcf16667e1414dd36b21e621ff13
MISC metadata.xml 395 BLAKE2B e1ce7a8fbd6d50fd59fbce671a535a3af2fde79dcc98f146c4e361759e61ce6d7e4e241866262fcd78744c673212d1946830c3d7628956b498a98d0af36d4c3d SHA512 544cb62da7212926b63c4e19467fc3e3f7c8210320a8096dc913a846d392e9a09c2b9860312f88effc8ad7a54e0329149a68012b08c674663af5779957e037f9
diff --git a/dev-python/zeroconf/zeroconf-0.136.2.ebuild b/dev-python/zeroconf/zeroconf-0.136.2.ebuild
new file mode 100644
index 000000000000..838baef40e66
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.136.2.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.10)
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-3.0.8[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export REQUIRE_CYTHON=1
+
+python_test() {
+ local -x SKIP_IPV6=1
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}