summaryrefslogtreecommitdiff
path: root/dev-python/zeroconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/zeroconf
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest4
-rw-r--r--dev-python/zeroconf/zeroconf-0.38.5.ebuild46
-rw-r--r--dev-python/zeroconf/zeroconf-0.38.6.ebuild50
3 files changed, 100 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index c94b5d5a760e..19d3eed32856 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,3 +1,7 @@
DIST python-zeroconf-0.38.4.gh.tar.gz 133770 BLAKE2B 2b7b01112957ed9456acd7ef842a010d38b2a6e589b1714ed3fd47d2b51f448bf716bdd8511b0a3f4560cdcf0cc16bad06ac73f9a42b5c5cf4154b48cafdf97b SHA512 6b0df6fed453dab2e554d4af4d807eed1108fe50fdcc41096a11944577ee8cfa0a0b30491a1ebe6d95ddc5b78c3c0cb07bd34ef279fbfca70775628667f40212
+DIST python-zeroconf-0.38.5.gh.tar.gz 134146 BLAKE2B d1ad69e8fe9f236c95862e1e415c5739a5627ed6d96b71f7af418e1f5cc9ca9c57feac34fa18d3928bdc6cf54c7d28dd30c9f259038e018746ad6a3671101225 SHA512 68ee397b567795f55e9374906761682e404ee0428b8b104c3dfedac473bbda780c086d50b598be9940a9b14e58642960dc29280036d3ff8e3fb76660806e0f54
+DIST python-zeroconf-0.38.6.gh.tar.gz 134795 BLAKE2B 839d59d7c46d9ab16145e37bb58acc7a71072b00507ee0ae8325fea9a3ebc0e567f9e257937675f8eaf44095c7449f96e6bc42b82d34f75a39cc87fd29be2766 SHA512 274db525751191b0188a4f00505c795420f975de3f714f84f2207271ff484bb5de1c881c0ed00b1ad3a6265d5d461519cf46041ab907026d9e6937844bbab6af
EBUILD zeroconf-0.38.4.ebuild 1191 BLAKE2B 4ca78e9ce862079cf574933de24a22f692f90b71e1b377a137c108a289b418a77e794eddfe4c8ddb19a1e58346f03ad833116091fce9a773784889d5454b763a SHA512 1b02d8deba87834c152222c58d19f7c46bb3ada77cd2da974735bdfb227037cee6193c3528decd5fc3c1fe401f2c2316cafc21cb037266788c90a467ef2ecf35
+EBUILD zeroconf-0.38.5.ebuild 1211 BLAKE2B ce5af78b00dcc07ab807cc9948d98235f935df364137b69fca3517355d70bfb472be65b5cd367b420952d61a2ba17851d5a0722b7abf0aa8c186ff38a96580a9 SHA512 2c0ce2e58978ca410bb82814b225347031c75da51a918c22addf0b00f8c6d04fab001488364cdb61513c135014bf62ad4474bb0b9b32f686a7c5979b9ed903fe
+EBUILD zeroconf-0.38.6.ebuild 1367 BLAKE2B 0e9b3c433f753ef3ab8b78e59073f845ee99a735c3b759a4c7b390b544dc9ec37dd1021214220fdef0e4b4d5c2ed123f4cad73379c947a58c0aae0a94782d685 SHA512 341c442dd65546432f2bba1030fc210e4ba7f471c873490ee9f5cb4f4f45b18e00db0478e94d0e0f3b6ab0f27b6d0f518233ab67d9f320e5d02f5879be134bca
MISC metadata.xml 413 BLAKE2B f93eceda07029400d2fd7ab38f234e5a1747e3d86f228adc973bbd6cdc71456778a7d926457f976cb2c6f55678b2c671d2415e5c7a480306582f1e70f6f733dc SHA512 d228e198b2f495dd02cd3d9d948aae123461c70c8e0185a47b133000f0316a84ff33d9b6f4cc0196bca5cf638e53ae58a3cd746338c33729d957a1170a5f08dd
diff --git a/dev-python/zeroconf/zeroconf-0.38.5.ebuild b/dev-python/zeroconf/zeroconf-0.38.5.ebuild
new file mode 100644
index 000000000000..a8279caef7c4
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.38.5.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+)
diff --git a/dev-python/zeroconf/zeroconf-0.38.6.ebuild b/dev-python/zeroconf/zeroconf-0.38.6.ebuild
new file mode 100644
index 000000000000..3a0da3f79c8e
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.38.6.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/jstasiak/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/jstasiak/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+)