summaryrefslogtreecommitdiff
path: root/dev-python/zeroconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-01 11:14:56 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-01 11:14:56 +0100
commitc952bf4dc186a298c5ef1596e2c52642072db500 (patch)
tree0b0b9cc4cdda7b2f9d62548ba883329cf6c15274 /dev-python/zeroconf
parent97c0860d9b4db72365710e1b8ed20644d6f5e926 (diff)
gentoo auto-resync : 01:04:2023 - 11:14:56
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest2
-rw-r--r--dev-python/zeroconf/zeroconf-0.51.0.ebuild61
2 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index ff1b2d5636c0..475c37dd1ff4 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,5 +1,7 @@
DIST python-zeroconf-0.47.3.gh.tar.gz 151413 BLAKE2B eff81832a029cf173c55290355207bfd17b1701f85c60be544252d00579ad835eb2b7c0a29c967ba62b1293d9efae953bc3b564c5ca134c2a898621584cdf544 SHA512 e1435490ba6890d9f0fe8efd7be64f0f9fd20a6ae723b176861865a8a795593db7cd797062f9977a5b1df4107781011d25bdf69dd4cc54dd94ef6e891c425df4
DIST python-zeroconf-0.47.4.gh.tar.gz 151640 BLAKE2B 4591135e81fc0c1c22444fb8823f5ad246f234a79a9aa2697a947a7838f5880007e2acbfe8c60a3f69c0a1cf803e35b35b17b7cf013dc7408e759273bbca94b2 SHA512 2b8438e0832cfc6ac40d54eaed75749389fd9287b82b074f129bba76e7f31e3cfd58e5de28c54b3cf3e14d3c8540ff09b5f10d85f705ede2ef18718b1a87ebf1
+DIST python-zeroconf-0.51.0.gh.tar.gz 152236 BLAKE2B 2339bd47e4f8abecb5b56c722e275c0cef63d4ab389c58b9a50e22e2a450b527f11727615a9c61e6e23d275195353121c5697f2fd496fbf9370465db5d9258c8 SHA512 e62d74ce164cd92913382e5a5530e2732a739e065f3f2fa7bc5cc7f62e863c98e8979ab08f5527f301e833cd1107c2d1c412db1dfafbf2bd1546b6e197d2c43a
EBUILD zeroconf-0.47.3.ebuild 1714 BLAKE2B d5a5092327d4de61e1bec37c6d963030c5703ed4fe3360ab91f42133456367390bc547fb8f591512d86093078f2a279b16fcbbaff49252b6589498c55ac805b3 SHA512 1d6fc8b09de6aa52049ae8bffa2cde9d5a1299495b8af075805059d55c1a09d206b8cc161fc32728cb3cfcfbff4757f28baac6ced0ab3cad3dab7f88acec9fde
EBUILD zeroconf-0.47.4.ebuild 1716 BLAKE2B d8ab5caed8f2a6af3e2d2de5a1e57d4a9a1feb1406b2d9e3f2c33aca8d32c1bd5d1ec157525de42c134c78f657f60b657497ce1225ae8daafca7e51e570a49df SHA512 9a319e0420919cd2220f727decbfe3ccc04e7fdd9a1e7afb64e4dad04ca7550fd64a5f08f33b20cc022b9dae248d45d233c6a3e97ce0d7c329238932f608cd9d
+EBUILD zeroconf-0.51.0.ebuild 1716 BLAKE2B d8ab5caed8f2a6af3e2d2de5a1e57d4a9a1feb1406b2d9e3f2c33aca8d32c1bd5d1ec157525de42c134c78f657f60b657497ce1225ae8daafca7e51e570a49df SHA512 9a319e0420919cd2220f727decbfe3ccc04e7fdd9a1e7afb64e4dad04ca7550fd64a5f08f33b20cc022b9dae248d45d233c6a3e97ce0d7c329238932f608cd9d
MISC metadata.xml 395 BLAKE2B e1ce7a8fbd6d50fd59fbce671a535a3af2fde79dcc98f146c4e361759e61ce6d7e4e241866262fcd78744c673212d1946830c3d7628956b498a98d0af36d4c3d SHA512 544cb62da7212926b63c4e19467fc3e3f7c8210320a8096dc913a846d392e9a09c2b9860312f88effc8ad7a54e0329149a68012b08c674663af5779957e037f9
diff --git a/dev-python/zeroconf/zeroconf-0.51.0.ebuild b/dev-python/zeroconf/zeroconf-0.51.0.ebuild
new file mode 100644
index 000000000000..2b08539fe6eb
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.51.0.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=python-zeroconf-${PV}
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+SRC_URI="
+ https://github.com/python-zeroconf/python-zeroconf/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep '
+ >=dev-python/async-timeout-3.0.0[${PYTHON_USEDEP}]
+ ' 3.{9..10})
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-0.29.32[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+ tests/test_core.py::Framework::test_launch_and_close_v4_v6
+ tests/test_core.py::Framework::test_launch_and_close_v6_only
+ tests/services/test_types.py::ServiceTypesQuery::test_integration_with_listener_ipv6
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+ )
+
+ epytest -o addopts=
+}