summaryrefslogtreecommitdiff
path: root/dev-python/zeroconf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-03-06 01:47:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-03-06 01:47:32 +0000
commitd0283dc748c38f55706c7e4c04f4848afeef54a9 (patch)
treeef21380422805615f7e775efb5eab147749c15bf /dev-python/zeroconf
parent77d1bb6f8d47023aa21aaee830bf3229837233d1 (diff)
gentoo auto-resync : 06:03:2025 - 01:47:31next
Diffstat (limited to 'dev-python/zeroconf')
-rw-r--r--dev-python/zeroconf/Manifest2
-rw-r--r--dev-python/zeroconf/zeroconf-0.146.1.ebuild60
2 files changed, 62 insertions, 0 deletions
diff --git a/dev-python/zeroconf/Manifest b/dev-python/zeroconf/Manifest
index 338ad09a9642..723d21d8b7d3 100644
--- a/dev-python/zeroconf/Manifest
+++ b/dev-python/zeroconf/Manifest
@@ -1,5 +1,7 @@
DIST zeroconf-0.144.3.tar.gz 161347 BLAKE2B 43f75df44a95d58ec372fbd68013cce2c9e4c78fa5b5c445604c8cb8281fbf4b96b6625c5867ca2817877d81c28824a0b8fab322e2da326b864ead539561a359 SHA512 c849a8b1ade29a34e7a4a4ad7710368eba6253408eae9b655381625b79170b7deeecf0d4be4821ee598a2af1a431803b2f6a072a4c61e94cee5ec0a9895a0153
DIST zeroconf-0.145.1.tar.gz 161640 BLAKE2B 7a51237fa238db0bd6ff7bc2537ae9535351ccf087e1b4dd99610164ae7a94f4faf9a0eba6932a8ede488bbd67533a9bf19299037e37163df00674d1c583cdf5 SHA512 9b5dc03ff77ea5d0d0df8ae05218c1aaf43f31f3d3a3fb11c95799ad81e238959eda1b8adf45c0ca34e28c38784f96647dc2e1b7689579658df2ec0e1e0de844
+DIST zeroconf-0.146.1.tar.gz 161874 BLAKE2B 042bc3747dac7a63e05b454a12b5884d293490909e662cf8c7ab7bf871bd4983bbf04cb2eb2ae6e075a82ab586f95ef13c201875d42250898f234f69a288b21e SHA512 a0834e37f07e465e2bf4b99ac7630f98b7c09d9608ecd86d3b8e2a3cd9c3978c400f342b97c7299f10fe07de669356c088f74e4bb26d9316c98219844dee6392
EBUILD zeroconf-0.144.3.ebuild 1521 BLAKE2B a183044d8ae0e65238d20692fb38be1389d0607917f529317263d183873932c063e9e46e72950101883389b38d383e8a2cbd96da9f0f41ac1bbc1a562943f670 SHA512 82c746bae63e3fa2dc3b5eba9587182e2942495bbfa9580959924d8267d81de4655fabd1693a28a8f416778f100f90432d67ac07dcd19d09f310732c815d3f8b
EBUILD zeroconf-0.145.1.ebuild 1524 BLAKE2B 11feb0eaec1c4f7e8cd91b1253585a4c741f5fc880618cde9fe8b28d7b292a797c884a8e38c93659c24fd2919ccf8f5640d8fda7306bb30c5b0cb3b92384af05 SHA512 9f90c7b05212c39af8300e680a26adfcff77d1f3b060ee9f60794f5f0a9bea5e56114f90f661c4416a078ab1acb145f57a2f5fd53ab168adfabc6ee625ba8b3b
+EBUILD zeroconf-0.146.1.ebuild 1524 BLAKE2B 11feb0eaec1c4f7e8cd91b1253585a4c741f5fc880618cde9fe8b28d7b292a797c884a8e38c93659c24fd2919ccf8f5640d8fda7306bb30c5b0cb3b92384af05 SHA512 9f90c7b05212c39af8300e680a26adfcff77d1f3b060ee9f60794f5f0a9bea5e56114f90f661c4416a078ab1acb145f57a2f5fd53ab168adfabc6ee625ba8b3b
MISC metadata.xml 395 BLAKE2B e1ce7a8fbd6d50fd59fbce671a535a3af2fde79dcc98f146c4e361759e61ce6d7e4e241866262fcd78744c673212d1946830c3d7628956b498a98d0af36d4c3d SHA512 544cb62da7212926b63c4e19467fc3e3f7c8210320a8096dc913a846d392e9a09c2b9860312f88effc8ad7a54e0329149a68012b08c674663af5779957e037f9
diff --git a/dev-python/zeroconf/zeroconf-0.146.1.ebuild b/dev-python/zeroconf/zeroconf-0.146.1.ebuild
new file mode 100644
index 000000000000..8ab627f86158
--- /dev/null
+++ b/dev-python/zeroconf/zeroconf-0.146.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_EXT=1
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Pure Python Multicast DNS Service Discovery Library (Bonjour/Avahi compatible)"
+HOMEPAGE="
+ https://github.com/python-zeroconf/python-zeroconf/
+ https://pypi.org/project/zeroconf/
+"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/ifaddr-0.1.7[${PYTHON_USEDEP}]
+"
+# the build system uses custom build script that uses distutils to build
+# C extensions, sigh
+BDEPEND="
+ >=dev-python/cython-3.0.8[${PYTHON_USEDEP}]
+ >=dev-python/setuptools-65.6.3[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest-asyncio[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export REQUIRE_CYTHON=1
+
+python_test() {
+ local -x SKIP_IPV6=1
+ local EPYTEST_DESELECT=(
+ # network
+ tests/test_core.py::Framework::test_close_multiple_times
+ tests/test_core.py::Framework::test_launch_and_close
+ tests/test_core.py::Framework::test_launch_and_close_context_manager
+
+ # fragile to timeouts (?)
+ tests/services/test_browser.py::test_service_browser_expire_callbacks
+ tests/utils/test_asyncio.py::test_run_coro_with_timeout
+
+ # randomly broken by a leftover thread?
+ tests/test_circular_imports.py::test_circular_imports
+ )
+ local EPYTEST_IGNORE=(
+ tests/benchmarks
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -p asyncio
+}