summaryrefslogtreecommitdiff
path: root/dev-python/zipp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /dev-python/zipp
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest2
-rw-r--r--dev-python/zipp/zipp-3.7.0.ebuild43
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
index 4b63e4bd4a47..59e81218b787 100644
--- a/dev-python/zipp/Manifest
+++ b/dev-python/zipp/Manifest
@@ -1,3 +1,5 @@
DIST zipp-3.6.0.tar.gz 13047 BLAKE2B 2e3f5fd0acf9f931f5a74957e9ae29f12a42bc824eb36d769720282ec0413d90b0b45f0524f3b319ce614f43c061ae324fb29f7f2a83e7aeb393283827bca5d1 SHA512 8e21b0a757ed9ebddeca43d3e4b64549dc4e59f781704626b0b2b0a117752b84798a0484cceedd4684ee0459643df4d0f479e64a143c8d9337d2b66951a7b227
+DIST zipp-3.7.0.tar.gz 12989 BLAKE2B 8a315dfd28c8aa1d5a568699886ea47b34000381981d1f4e578bcc10d7c9dc772bfd99ae9d720836e300dd1aaa5e12f0667bbe40d69668306f90aed23ec0cc8f SHA512 bf0c00382273453286ce597fb5a0059b8b279edd01dc4f2d5accef41cc53d69ddda1a2b00f4c38ed4057eeac69ef225ba4bd3a70a16da025b33947cdd6a69ed8
EBUILD zipp-3.6.0.ebuild 1157 BLAKE2B facc2f97d68700ab997d1b2655059dac0b18c016f5a4f964cef3c31d4453bfda892867958917d932a2ecde0c2b1b776055ba9a5c7f5a79447059c16f0bc14fe0 SHA512 04e3dc1e66e42c25c6b6bfb6415c57231b81867509381a4ef06b335e26cf9481c23ed51cc2e5d79b6338a9b23aea302f459e7538ac2872bdfe902c6e33a7eef0
+EBUILD zipp-3.7.0.ebuild 1165 BLAKE2B fa429305db0085ad1ab8ea82aba683edd5f1946298a6c3de23a1e4a5dd6f92fcbddcbfd87a2fb1b41b7f1a791ab68658cd7fea3264653367f5885a1bdb9eb790 SHA512 9fcd9bf08b339069773ddfb758d3e71863bd686647740888c26ee7912228490e6854b86818f59779c8f7df509fc44d09d1a320d7ace8c85e3f3adc90ea4a2407
MISC metadata.xml 548 BLAKE2B 0bcd7b95c50e9e14ada6f3f02145bec64ee365beacf3447659276c1a5454355714f83fd2dc81a035a56d11ba1eb989f32bc0209a540b28fb72c3126d4d45a5fa SHA512 f214f6711b3197a44ec5c03b418aab3c9b907e0b3a297cb1c4e2ac3a499acefeb4de411443495db9678cbfd75460f89c9c40a57fc1bc404acbab844223a129d2
diff --git a/dev-python/zipp/zipp-3.7.0.ebuild b/dev-python/zipp/zipp-3.7.0.ebuild
new file mode 100644
index 000000000000..bef59282ca20
--- /dev/null
+++ b/dev-python/zipp/zipp-3.7.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ dev-python/toml[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-3.4.2[${PYTHON_USEDEP}]
+ test? ( dev-python/jaraco-itertools[${PYTHON_USEDEP}] )
+"
+
+distutils_enable_sphinx docs \
+ ">=dev-python/jaraco-packaging-3.2" \
+ ">=dev-python/rst-linker-1.9"
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # speed tests are flaky by design
+ test_zipp.py::TestPath::test_implied_dirs_performance
+)
+
+EPYTEST_IGNORE=(
+ # Ignoring zipp.py from ${S} avoids ImportPathMismatchError with Python < 3.8
+ # by ensuring only zipp from ${BUILD_DIR} is loaded
+ zipp.py
+)
+
+python_prepare_all() {
+ # dep of disabled test
+ sed -i -e '/func_timeout/d' test_zipp.py || die
+ distutils-r1_python_prepare_all
+}