summaryrefslogtreecommitdiff
path: root/dev-python/zipp
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-07-10 23:40:16 +0100
commit51af5f0eb4cddbe6aa7953717873691d77aae9ff (patch)
tree1541525274162b033ebbc3ed38abaf335fbbd49a /dev-python/zipp
parent7014a5a3ea0feffab9701fdd6b64cc7667a985af (diff)
gentoo resync : 11.07.2019
Diffstat (limited to 'dev-python/zipp')
-rw-r--r--dev-python/zipp/Manifest3
-rw-r--r--dev-python/zipp/metadata.xml17
-rw-r--r--dev-python/zipp/zipp-0.5.1.ebuild44
3 files changed, 64 insertions, 0 deletions
diff --git a/dev-python/zipp/Manifest b/dev-python/zipp/Manifest
new file mode 100644
index 000000000000..31c39f30fe89
--- /dev/null
+++ b/dev-python/zipp/Manifest
@@ -0,0 +1,3 @@
+DIST zipp-0.5.1.tar.gz 10763 BLAKE2B 4f70d6ed94203d4b9fb9127930a07797c3cbfa023e0cd472e9d3a18e1877619dbefee654cd0364592a594b6e9e0aabc813e0560695bb18f8e3a64cb4ce76f0e2 SHA512 d4486ae98159677cd481cddb3bd00d5d2237dc94f0f3129b03994800b0e136c12b05e02d2ca7d628043dabce323f34dd919b9ba731549656802527abdcfea120
+EBUILD zipp-0.5.1.ebuild 1045 BLAKE2B ba2452da28b41fdc3d8ed0db560f149fe77a4839a556fb8114d13490e51ac6a087665f427029585bb7877003d1fdcd53d9997a5250000f840f06643437cb2621 SHA512 ebdcdfeffddb439985b144ae72c3738d08503e400526cd7f3ce1ee4ee9ad29429904df5d5df3d42807b67c28f51eebe6e66cc2232ca90854fb35f97a3b802016
+MISC metadata.xml 523 BLAKE2B b2c729977d84466557f0fae273e5463a41fded78780842e4a92899cc79ad8cf2843fe9c397a70f1d7cab8a7ca317a6723b119047323e0be8862b7294afe96b33 SHA512 82b88eb00bb385c47ebf5c5cd560de25e4f865086983fd9a5767b7fb286406dd06273e8a596df31aba57baaf051b7c353f50f445753541de5b15e6a439132381
diff --git a/dev-python/zipp/metadata.xml b/dev-python/zipp/metadata.xml
new file mode 100644
index 000000000000..a0ceea39a38e
--- /dev/null
+++ b/dev-python/zipp/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>sbraz@gentoo.org</email>
+ <name>Louis Sautier</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">zipp</remote-id>
+ <remote-id type="github">jaraco/zipp</remote-id>
+ <bugs-to>https://github.com/jaraco/zipp/issues</bugs-to>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/zipp/zipp-0.5.1.ebuild b/dev-python/zipp/zipp-0.5.1.ebuild
new file mode 100644
index 000000000000..2d0e62d3d6e3
--- /dev/null
+++ b/dev-python/zipp/zipp-0.5.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7}} )
+
+inherit distutils-r1
+
+DESCRIPTION="Backport of pathlib-compatible object wrapper for zip files"
+HOMEPAGE="https://github.com/jaraco/zipp"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/setuptools_scm-1.15.0[${PYTHON_USEDEP}]
+ test? (
+ dev-python/contextlib2[${PYTHON_USEDEP}]
+ dev-python/pathlib2[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/unittest2[${PYTHON_USEDEP}]
+ )
+ doc? (
+ >=dev-python/jaraco-packaging-3.2[${PYTHON_USEDEP}]
+ >=dev-python/rst-linker-1.9[${PYTHON_USEDEP}]
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ )
+"
+
+python_compile_all() {
+ if use doc; then
+ sphinx-build docs docs/_build/html || die
+ HTML_DOCS=( docs/_build/html/. )
+ fi
+}
+
+python_test() {
+ pytest -vv || die "tests failed with ${EPYTHON}"
+}